Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Strange switching issue.

Mark Balcerak
Occasional Visitor

Strange switching issue.

For some reason all out network traffic is coming up to the gateway and back down again.

I cannot seem to find the cause of this issue. i was wondering if anyone else had this issue.

I'm running a 5412zl with K14.65, the gateway is connected to port b1.

when I do a ping and then check "show arp" I see it has the MAC of the gateway in the table.

Layer 3 support should be fully disabled.

Here is the config:


hostname "Backbone2"
time timezone -300
no qos dscp-map 000000
no qos dscp-map 001000
no qos dscp-map 010000
no qos dscp-map 011000
no qos dscp-map 100000
no qos dscp-map 101000
no qos dscp-map 110000
no qos dscp-map 111000
module 1 type J8707A
module 2 type J8705A
module 7 type J8705A
module 9 type J8702A
module 10 type J8702A
module 11 type J8702A
module 12 type J8702A
ip default-gateway 10.10.10.1
vlan 1
name "DEFAULT_VLAN"
untagged A2-A4,B1,B3-B20,B24,G1-G24,I1-I24,J1-J24,K1-K24,L1-L24
ip address 10.10.10.7 255.255.0.0
tagged A1,B21-B23
no untagged B2
exit
vlan 10
name "sonicpoint"
untagged B2
tagged A1,B21-B23
no ip address
exit
vlan 20
name "sonicguest"
tagged A1,B2,B21-B23
no ip address
exit
vlan 21
name "sonicberry"
tagged A1,B2,B21-B23
no ip address
exit
vlan 30
name "soniccorpo"
tagged A1,B2,B21-B23
no ip address
exit
vlan 22
name "sonicmes1"
tagged A1,B2,B21-B23
no ip address
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
no ip icmp redirects
timesync sntp
sntp unicast
sntp server priority 1 10.10.11.2 3
spanning-tree
spanning-tree priority 1
password manager
6 REPLIES
Cajuntank MS
Valued Contributor

Re: Strange switching issue.

So I see a lot of tagged VLANs, but since the switch is not doing routing, how are those VLANs getting routed/talking to each other. You say your gateway is through port B1, but nowhere do I see B1 tagged on your VLANs so your gateway can provide routing between those VLANs (assuming you have those VLANs defined on your gateway device, whatever it is)

If your not going to do routing on this switch, then you'll need to tag B1 on your VLANs that you want to communicate with. The gateway will then have these same VLANs defined on it and routing enabled.
Mark Balcerak
Occasional Visitor

Re: Strange switching issue.

The gateway of the vlans reside through port b2 which is a separate port on our sonicwall gateway/firewall.

The LANs gateway comes out b1 into X0 on the sonicwall, b2 connects to X4 on the sonicwall and has the gateway of every vlan.
Cajuntank MS
Valued Contributor

Re: Strange switching issue.

So you have "subinterfaces" defined on the sonicwall for each vlan and those IP addresses are the the gateways for your hosts on their respective VLANs.

Can you explain your statement of "For some reason all out network traffic is coming up to the gateway and back down again." a little more? Is that traffic not getting past the Sonicwall? Are those VLANs not talking to each other correctly? etc...



Mark Balcerak
Occasional Visitor

Re: Strange switching issue.

the vlans are routing correctly through the sonicwall to the main vlan.

If I access an intranet site on the same subnet and do a packet capture I can see all traffic on the sonicwall go in X0 and our X0 back into the switch.

I just upgraded to K15.04.0003 and its still doing the same thing.
Cajuntank MS
Valued Contributor

Re: Strange switching issue.

So is there something that you are having problems accessing or your just courious about this traffic via the packet capture?
Sorry, guess I still confused if your problem.
Mark Balcerak
Occasional Visitor

Re: Strange switching issue.

I created a mirror port of the port connected to the firewall and analyzed it with wire shark and saw that the sonicwall was responding to all ARP broadcasts.

By changing a few faulty NAT policies I was able to fix it, everything is normal now.

:)