Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Switch port missing under "show run"

SOLVED
Go to solution
Dan_394
Advisor

Switch port missing under "show run"

Hi

I've got a very basic setup, mainly because I am unfamiliar with hp switches" and in this setup when I run "show running-config" I can see all the ports except interface 23 which is the port that connects to my cisco switch. The cisco switch is configured as a trunk port. Any thoughts as to why this interface may be missing?

Thanks
Dan
5 REPLIES
serpel
Trusted Contributor

Re: Switch port missing under "show run"

hi dan,
please attache the configuration (sh run). this could help finding the problem.
you could try to tag the port 23 to your vlans,cos in the hp world the cisco trunk port is a tagged port:

conf
vlan 1
tagged 23
exit
wr mem

hth alex
Dan_394
Advisor

Re: Switch port missing under "show run"

Hi Alex,

Here's my configuration:

time daylight-time-rule None
cdp run
mirror-port 1
interface 1
speed-duplex 100-full
exit
interface 2
speed-duplex 100-full
exit
interface 3
speed-duplex 100-full
exit
interface 4
speed-duplex 100-full
exit
interface 5
speed-duplex 100-full
exit
interface 6
speed-duplex 100-full
exit
interface 7
speed-duplex 100-full
exit
interface 8
speed-duplex 100-full
exit
interface 9
speed-duplex 100-full
exit
interface 10
speed-duplex 100-full
exit
interface 11
speed-duplex 100-full
exit
interface 12
speed-duplex 100-full
exit
interface 13
speed-duplex 100-full
exit
interface 14
speed-duplex 100-full
exit
interface 15
speed-duplex 100-full
exit
interface 16
speed-duplex 100-full
exit
interface 17
speed-duplex 100-full
exit
interface 18
speed-duplex 100-full
exit
interface 19
speed-duplex 100-full
exit
interface 20
speed-duplex 100-full
exit
interface 21
speed-duplex 100-full
exit
interface 22
speed-duplex 100-full
exit
interface 24
speed-duplex 100-full
exit
ip default-gateway 10.30.25.1
snmp-server community "xxxx" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address 10.30.25.4 255.255.255.0
ip igmp
exit
vlan 50
name "Office"
exit
interface 19
monitor
exit

All I want to do is add another vlan i.e vlan 50 which I have done, and then send this vlan down the link to the Cisco switch which is on port 23, when I run "show cdp ne" on the hp switch I get:

CDP neigbors information

Port Device ID | Platform Capability
---- ----------------------------- + ---------------------------- -----------
23 cisco01.example.c... | cisco WS-C3750G-48TS R S In

Thanks
Dan
serpel
Trusted Contributor
Solution

Re: Switch port missing under "show run"

Ok,
in this part port 23 is configured
vlan 1
name "DEFAULT_VLAN"
untagged 1-26 <--------*
ip address 10.30.25.4 255.255.255.0
ip igmp
exit
*this means the port is part of vlan 1 as access port(in cisco terms).
there are two possibilities to add the port to vlan 50.
1- as access port:
conf
vlan 50
untagged 23
exit
but then the port disappears from vlan 1
2- as trunk port
conf
vlan 50
tagged 23
exit
then it remains as "native port" in vlan 1 and as trunk port(again in cisco term) in vlan 50

hth
alex
Dan_394
Advisor

Re: Switch port missing under "show run"

Thanks for that Alex,

You solved my problem. Could you also please explain why port 23 doesn't appear in the "show run" output, while all other ports do?

Thanks
Dan
serpel
Trusted Contributor

Re: Switch port missing under "show run"

i will try,
my guess would be that port 23 isn't configured to 100/fd, but is auto/auto. this is the default setting and default settings don't appear in the show run.

hth
alex

to see the the actual port status
show interface brief
and see the port configuration with
show interface configuration