Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Switch to Switch Trunk and have to manage all the switches

lijujohn
Occasional Advisor

Switch to Switch Trunk and have to manage all the switches

Hi all,

I need an advise in Switch to switch Trunk and how to manage all the switches. As i am new to VLAN and things. Please give me a little detailed advise.

i have 4 number of 2910 switches all are 48 port layer 3 switches. All are connecteed in the following way

 

sw1--------sw2----------sw3-----------sw4

 

also i have 18 VLAN s assigned on the switches and this VLANS repeat in all the switches

VLAN 2 , 3, 4....19

The main gateway that goes to the firewall and internet is from SWITCH1 and so i guess all the VLANs should terminate in the main SWITCH. how i can do this and also i wanted to manage all the switches?

 

If i am using trunk to trunk please help me with how to do the trunking .

 

anyone please help me in this issue.

Thanks, 

7 REPLIES
DMilford
Frequent Advisor

Re: Switch to Switch Trunk and have to manage all the switches

You have asked many questions, and unfortunately there is no quick easy answer for all of this. The thing is, configuring vlans on switches is never a plug-and-play activity. It involves some sophisticated knowledge and training. From a general standpoint, the switch configuration you have drawn should work fine, but you want some redundancy. I would recommend setting up your trunk links with multiple lines each, at least 2 but preferably 4, if you can afford the extra ports (that would be 8 ports each dedicated to trunk links on the 2 middle switches). Bandwidth performance would be best if you could configure the multiple trunk links to always be on and load balanced.

 

As for detailed advice on setting up VLAN's and switch management, direction would be far too lengthy and involved for a forum such as this. I refer you to the 2910 Setup, install, and configure documents here - http://h20000.www2.hp.com/bizsupport/TechSupport/SupportTaskIndex.jsp?lang=en&cc=us&taskId=115&prodSeriesId=3901671&prodTypeId=12883&supportTaskId=22845

 

Also take a look at the Installation Guide here - http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02564359/c02564359.pdf

 


DMilford - Although I am an HP employee, I am speaking for myself and not for HP. Rio Rancho, NM, USA, - PPS Division, CSS
lijujohn
Occasional Advisor

Re: Switch to Switch Trunk and have to manage all the switches

Hi thanks for your reply,
Switches are connected via 10Gbe Module (J9165A). i have gone Through the link you sent me and there si nothing about setting up a VLAN. I have configured Switch 1 as seen below with 6 VLANs and VLAN 99 is the interface that is connected to the main network. (cisco we can assign ip for port. In HP i had to create a VLAN and assign IP for it and then untagg the port )

Switches below SWITCH 2 , 3 and 4 .. I know i have to craete the VLANs needed and tagg it to the TRUNK. Between SWITCH 1nd 2 it is fine because its in the same trunk .. what about the below switches how i can create the trunk in that and Do i need different trunks (trk2 ,3 ) . or just one trunk (trk1). ?

 
show running-config
; J9087A Configuration Editor; Created on release #R.11.30

hostname "30H1SW"
trunk A1 Trk1 Trunk
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "MANAGEVLAN"
   untagged 24,27-28
   no ip address
   ip helper-address 192.168.x.x 
   tagged Trk1
   no untagged 1-23,26
   exit
vlan 2
   name "30HDMZ"
   untagged 1-8
   ip address 10.3.0.1 255.255.254.0
   ip helper-address 192.168.x.x 
   tagged Trk1
   exit
vlan 3
   name "30HPROADMIN"
   untagged 9-10,19-22
   ip address 10.3.2.1 255.255.255.192
   ip helper-address 192.168.x.x 
   tagged Trk1
   exit
vlan 4
   name "30HLECT"
   untagged 11-18
   ip address 10.3.2.65 255.255.255.240
   ip helper-address 192.168.x.x
   tagged Trk1
   exit #
vlan 5
   name “30HSALE”
   ip address 10.3.3.0 255.255.255.0
   ip helper address 192.168.x.x
   tagged trk1
vlan 6
   name “30HMAINTENECE”
    ip address 10.2.4.0 255.255.255.0
    ip helper address 192.168.x.x
    tagged trk1
vlan 99
   name "VLAN99"
   untagged 23,26
   ip address 192.168.1.199 255.255.254.0  
   exit
ip route 0.0.0.0 0.0.0.0 192.168.x.x
banner motd "AUTHORIZED PERSONNAL ONLYQ"
banner motd "~"
banner motd "~"
spanning-tree Trk1 priority 4

DMilford
Frequent Advisor

Re: Switch to Switch Trunk and have to manage all the switches

I would assume you need trunk 2 and trunk 3, since these would be different multiple interfaces on switch2 and 3. VLANS need to be defined for each switch, though there should be a way to copy config commands so you can just duplicate them and not have to type them in individually. Then you can make small adjustments like trunk #, port #'s with individual commands to finalize the config of each switch. 10GB should be enough bandwidth for the trunk lines, but I would still recommend redundancy in the form of another 10GB line between each. This backup link can be down, just waiting to be turned on if STP informs it that the main link has failed. Or, even better, you could join it with the main link as a single virtual link and load balance for twice the bandwidth.

 

VLAN data needs to stay tagged throughout the network, on all the trunk lines. Only on the final nodes (ports) to end devices (or single-VLAN subnets) can it pass untagged. If VLAN99 is the native VLAN it can be untagged everywhere, but that is the only one.

DMilford - Although I am an HP employee, I am speaking for myself and not for HP. Rio Rancho, NM, USA, - PPS Division, CSS
lijujohn
Occasional Advisor

Re: Switch to Switch Trunk and have to manage all the switches

Please have a look at the config of rest of the switches ( Switch 2,3) , because i did created the trunk and connected it doesnt seems working..First and second switch is fine working not the third switch ..

please just see ...if i have to change anything in this config

SWITCH 2:

show running-config

Running configuration:

; J9087A Configuration Editor; Created on release #R.11.25

hostname "30H2SW"

trunk A1 Trk1 Trunk

trunk B1 Trk2 Trunk

ip routing

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 26-28,Trk1

ip address dhcp-bootp

no untagged 1-24

exit

vlan 2

name "30HDMZ"

untagged 1-16,23

no ip address

tagged Trk1, Trk2

exit

vlan 4

name "30HLECT"

untagged 17-22, 24-40

no ip address

tagged Trk1, Trk2

exit

vlan 3

name "30HPROADMIN"

no ip address

tagged Trk1, Trk2

exit

spanning-tree Trk1 priority 4

spanning-tree Trk2 priority 4

 

SWITCH 3:

show running-config

Running configuration:

; J9087A Configuration Editor; Created on release #R.11.25

hostname "30H-3-SW"

trunk A1 Trk2 Trunk

trunk B1 Trk3 Trunk

ip routing

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 26-28,Trk1

ip address dhcp-bootp

no untagged 1-24

exit

vlan 5

name "30HSALES"

untagged 1-23

no ip address

tagged Trk2, Trk3

exit

vlan 4

name "30HLECT"

untagged 24-30

no ip address

tagged Trk2, Trk3

exit

vlan 6

name "30HMAINTENENCE"

no ip address

tagged Trk2, Trk3

exit

spanning-tree Trk2 priority 4

spanning-tree Trk3 Priority 4

Thanks

 

lijujohn
Occasional Advisor

Re: Switch to Switch Trunk and have to manage all the switches

can anyone please help me in this

DMilford
Frequent Advisor

Re: Switch to Switch Trunk and have to manage all the switches

First of all, you have VLAN1 untagged on trunk 1.

Other things I would change would be to copy the config settings from Switch 1, particularly the VLAN IP address assignments.

DMilford - Although I am an HP employee, I am speaking for myself and not for HP. Rio Rancho, NM, USA, - PPS Division, CSS
lijujohn
Occasional Advisor

Re: Switch to Switch Trunk and have to manage all the switches

Thanks for the response,

 

I did given IP's to switch 2 and 3 . what actually happened is packet drop. So worked on it and found out

- If we give IP for all the repeating VLAN's on different switch , the packet drops after the first Switch that VLAN is in.

eg: switch 1 has VLAN 5 and VLAN 5 repeats on switch 2 and 3 . and if i give IP for all this VLAN's created in switch 2 and 3 and tagg them on the respective trunk  , it only work in switch 1. because packet dropping after switch1.  and after i found out if i just tag the VLANs on to the trunk with out assigning IP it works fine. ( in this case i cannot telnet anyother switch but switch 1)

 

 

Please give an advise in this please.