Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Totally simpleVLAN (rookie) question...sorry!

SOLVED
Go to solution
UserD
Occasional Advisor

Totally simpleVLAN (rookie) question...sorry!

Hi everyone,
If I have VLAN 1 as 172.20.12.1/21 and VLAN 3 and 172.20.32.1/24 on a 5300xl...how can I get VLAN 1 to get to a server on VLAN 3? static route? Tagging? Any help would be so much appreciated. Thank you.


here's a snippet of my 5300 config...

ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,C8-C16,Trk3
ip address dhcp-bootp
tagged B2,Trk1
no untagged B1,B3-B14,C1-C7
exit
vlan 5
name "External_Net"
untagged B1-B14
ip address 192.168.1.2 255.255.255.0
tagged Trk1
exit
vlan 3
name "Voice_VLAN"
untagged C3-C7
ip address 172.20.32.1 255.255.255.0
tagged C1-C2,C15-C16,Trk1
exit
9 REPLIES
UserD
Occasional Advisor

Re: Totally simpleVLAN (rookie) question...sorry!

oh, just as a side note...the server is a Mitel voice server that gives out IPs to phones ONLY. So, I need to access that server which is 172.20.32.2 from a workstation which is 172.20.8.28. I am afraid that our Domain DHCP will interfere with the Mitel DHCP for the phones if we do what I need right now...

Thanks again...
Joel Belizario
Trusted Contributor
Solution

Re: Totally simpleVLAN (rookie) question...sorry!

Just wondering why you have setup VLAN 1 to use DHCP to obtain an IP address?

From your config, IP routing has been enabled in the CLI which is necessary for inter-VLAN routing.

All you need now are ip addresses assigned to the respective VLANs. When you assign an IP address to a VLAN you are in effect creating a virtual router.

Another thing to check in your config is that VLAN 1 (or any other VLAN that needs traffic routed) is not defined as the management VLAN as this will disable routing of non-management traffic into that VLAN.

Hope this helps, good luck!
UserD
Occasional Advisor

Re: Totally simpleVLAN (rookie) question...sorry!

Thank you for replying so promptly, Joel!
Anyway, I told you I was a rookie...you must've been shaking your head in disappointment.

Anyway, the reason for that was because our entire data network is on there. If I leave VLAN 1 as management, what addressing scheme should I use for that? Our network is simple as you can see. should it look more like this? and if so, that should be all I need. That, and not forcing dhcp on the routers.

VLAN 1 172.20.35.1/24 - our management
VLAN 2 172.20.8.1/21 --our data
VLAN 3 172.20.32.1/24 --our voice
VLAN 5 192.168.1.2/24 --our external net

Then, it's all about tagging the uplinks, right?
Joel Belizario
Trusted Contributor

Re: Totally simpleVLAN (rookie) question...sorry!

Please don't apologize we are all on the forums for the same reason!

Anyway my issue with not setting the address statically is that obviously on a switch reload the IP address may change, and this may or may not be an issue with access control lists (and other features) that rely on the VLAN ip address.

As far as addressing for management goes I don't see any issues with the scheme you have, though you may want to consider defining VLAN 1 as the management VLAN to prevent unwanted traffic from other VLANs from being routed there.

Yep just ensure your uplinks to other devices are tagged appropriately and I think you'll be fine.

On a side note probably want to change the default SNMP value from public especially since it is a unrestricted one.

Good luck!
UserD
Occasional Advisor

Re: Totally simpleVLAN (rookie) question...sorry!

Hi Joel, your help and kind words have helped me understand the world of VLAN a bit more. I will do as you suggest and will report the results to you. I already assigned the points because I am very grateful for you and these forums. Thanks again!
Dmitry G. Spitsyn
Trusted Contributor

Re: Totally simpleVLAN (rookie) question...sorry!

Hi, UserD !

Do not forget to set (default) routes on the communicating hosts pointing to the appropriate VLAN's addresses.

Good luck,
Dmitry
UserD
Occasional Advisor

Re: Totally simpleVLAN (rookie) question...sorry!

Hi Dmitry,
do you mean for me to make sure that the computers have the proper gateway (the vlan interface IP)? If not, could you elaborate please?
Joel Belizario
Trusted Contributor

Re: Totally simpleVLAN (rookie) question...sorry!

I believe that is what he is suggesting, without the gateways defined the hosts wouldn't be able to communicate with other VLANs.
UserD
Occasional Advisor

Re: Totally simpleVLAN (rookie) question...sorry!

Hi again Joel,
I believe I have done that. You know what...I was composing a reply with another question when I realized why my vlans weren't talking...wrong gateway on one of the machines...duh! Everything seems to be working exactly as I had hoped. Thank you all for your help. I can only hope to help someone else in the future on these forums. I wish I could dole out more points to you! Anyways, upwards and onwards I suppose. Take care.