Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk and Vlan between HP Procurve Switchs

SEMLALI
Occasional Contributor

Trunk and Vlan between HP Procurve Switchs

Hello,

I have 3 switch HP Procurve 5412, i use Voip and data in the network.
I will create a vlan voice and vlan data by switch, and create a trunk link between différent switchs.
Can you help me :(
3 REPLIES
cenk sasmaztin
Honored Contributor

Re: Trunk and Vlan between HP Procurve Switchs

hi
according to hp trunk meaning of link agregation
if you want vlan's to move on the other switch
you must have tagged port configuration

for example
******************************************
hostname "sw1"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "managemet"
untagged 21-26
ip address 10.0.1.1 255.255.255.0
no untagged 1-20
exit
vlan 2
name "data"
untagged 1-10
ip address 10.0.2.1 255.255.255.0
tagged 24
exit
vlan 3
name "voip"
untagged 11-20
ip address 10.0.3.1 255.255.255.0
tagged 24
voice
exit
*************************************
this switch sw1 namely core switch
vlan member port be happen untagged port
vlan carrying port (uplink port )must have tagged port

**************************************

hostname "sw2"
snmp-server community "public" Unrestricted
vlan 1
name "managemet"
untagged 21-26
ip address 10.0.1.1 255.255.255.0
no untagged 1-20
exit
vlan 2
name "data"
untagged 1-10
ip address 10.0.2.1 255.255.255.0
tagged 24
exit
vlan 3
name "voip"
untagged 11-20
ip address 10.0.3.1 255.255.255.0
tagged 24
voice
exit

similar config for sw2 namely edge switch
all vlan member port must have untagged port and vlan carring port (uplink port )must have tagged port


good luck
cenk

SEMLALI
Occasional Contributor

Re: Trunk and Vlan between HP Procurve Switchs

For information i have a Ipphone and workstation in the same port.
and i want to do à phone in a vlan3(Voice) and workstation in vlan2 (data).
I also want that vlan restricted with oder flours (oders VLAN).
i have 7 switch HP procurve 5308 xl

SW1:
SW1-->phone(Vlan2)--> workstation(Vlan3)

SW2:
SW2-->phone(Vlan2)-->workstation(Vlan3)

SW3:
SW2-->phone(Vlan2)-->workstation(Vlan3)

and i will restrict communication between the workstations(SW1), workstation(SW2), and workstation (SW3)
the idea it's to limite the brodcast domaine voice and data in the network.
now i have juste tow vlan, one for data, and another for voice.
cenk sasmaztin
Honored Contributor

Re: Trunk and Vlan between HP Procurve Switchs

example config for you
******************************************
this switch is core all vlan have ip address
all vlan have member port(untagged) and all vlan's
have vlan carrying port (tagged)for uplink and ip
phone device
ip routing enable must have routing between vlan's a
and vlan's user goto internet
this switch is main routing device and main vlan device
interface 26 be happen uplink port your core switch
interface 5-25 must be connect workstation and server(vlan2)
interface 2-4 must be connect voip server(vlan 3)
interface 1,21,26 must be connect network admin for switch management

----------------
hostname "sw1"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "managemet"
untagged 1,21-26
ip address 10.0.1.1 255.255.255.0
no untagged 2-25
exit
vlan 2
name "data"
untagged 5-25
ip address 10.0.2.1 255.255.255.0
tagged 26
exit
vlan 3
name "voip"
untagged 2-4
ip address 10.0.3.1 255.255.255.0
tagged 1-26
voice
exit

***********************************************

this swich is any edge switch
all vlan defined on switch
interface 1-25 workstation vlan port
same time voip vlan tagged port
have only vlan 1 ip address not needed ip address
other vlanS
interface 26 uplink port to core switch

you must be connect 1 to 25 interface fristly ip
phone and ip phone on connect pc
your ip phone must have support 802.1q vlan taging
protocol and you must config on your ip phone (vlan id 3)


-----------------
hostname "sw2"
snmp-server community "public" Unrestricted
vlan 1
name "managemet"
untagged 26
ip address 10.0.1.2 255.255.255.0
no untagged 1-25
exit
vlan 2
name "data"
untagged 1-25
tagged 26
exit
vlan 3
name "voip"
tagged 1-26
voice
exit

good luck
cenk