Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk between 2848 and Cisco 4500 IOS

SOLVED
Go to solution
dcoops
Occasional Visitor

Trunk between 2848 and Cisco 4500 IOS

What I like to do is trunk(tag)vlan 11-19 only.
Also on the HP side is it

trunk 41-44 trk1 lacp or trunk ?

and should I change the primary-vlan ID ?

Cisco Sswitch

interface GigabitEthernet4/1
switchport mode trunk
switchport trunk allowed vlan 11-19
switchport trunk encapsulation dot1q
switchport trunk native vlan 4094
channel-group 2 mode active


interface GigabitEthernet4/2
switchport mode trunk
switchport trunk allowed vlan 11-19
switchport trunk encapsulation dot1q
switchport trunk native vlan 4094
channel-group 2 mode active

interface GigabitEthernet4/3
switchport mode trunk
switchport trunk allowed vlan 11-19
switchport trunk encapsulation dot1q
switchport trunk native vlan 4094
channel-group 2 mode active

interface GigabitEthernet4/4
switchport mode trunk
switchport trunk allowed vlan 11-19
switchport trunk encapsulation dot1q
switchport trunk native vlan 4094
channel-group 2 mode active

interface Port-channel2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 4094
switchport mode trunk
switchport trunk allowed vlan 11-19

#######################################

; J4904A Configuration Editor; Created on release #I.10.43

hostname "EM7SWITCH02"
snmp-server contact "xxxxxxxxxxxx"
snmp-server location "xxxxxxxxxxx"
max-vlans 256
time timezone -8
interface 1
no lacp
exit
interface 2
no lacp
exit
interface 3
no lacp
exit
interface 4
no lacp
exit
interface 5
no lacp
exit
interface 6
no lacp
exit
interface 7
no lacp
exit
interface 8
no lacp
exit
interface 9
no lacp
exit
interface 10
no lacp
exit
interface 11
no lacp
exit
interface 12
no lacp
exit
interface 13
no lacp
exit
interface 14
no lacp
exit
interface 15
no lacp
exit
interface 16
no lacp
exit
interface 17
no lacp
exit
interface 18
no lacp
exit
interface 19
no lacp
exit
interface 20
no lacp
exit
interface 21
no lacp
exit
interface 22
no lacp
exit
interface 23
no lacp
exit
interface 24
no lacp
exit
interface 25
no lacp
exit
interface 26
no lacp
exit
interface 27
no lacp
exit
interface 28
no lacp
exit
interface 29
no lacp
exit
interface 30
no lacp
exit
interface 31
no lacp
exit
interface 32
no lacp
exit
interface 33
no lacp
exit
interface 34
no lacp
exit
interface 35
no lacp
exit
interface 36
no lacp
exit
interface 37
no lacp
exit
interface 38
no lacp
exit
interface 39
no lacp
exit
interface 40
no lacp
exit
interface 41
no lacp
exit
interface 42
no lacp
exit
interface 43
no lacp
exit
interface 44
no lacp
exit
interface 45
no lacp
exit
interface 46
no lacp
exit
interface 47
no lacp
exit
interface 48
no lacp
exit
trunk 41-44 Trk1 LACP
trunk 45-48 Trk2 LACP
ip default-gateway 10.170.0.1
sntp server xxxxxxx
sntp server xxxxxxx
timesync sntp
sntp unicast
snmp-server community "xxxxx" Operator
vlan 1
name "DEFAULT_VLAN"
untagged Trk1-Trk2
no ip address
no untagged 1-40
exit
vlan 11
name "TRUST_VLAN"
untagged 1-40
ip address 10.170.0.102 255.255.128.0
tagged Trk1-Trk2
exit
vlan 12
name "HEARTBEAT"
tagged Trk1-Trk2
exit
vlan 13
name "VMKERNAL"
tagged Trk1-Trk2
exit
vlan 14
name "OOB_ADMIN"
tagged Trk1-Trk2
exit
vlan 15
name "DMZ_VLAN"
tagged Trk1-Trk2
exit
vlan 16
name "FUTURE_VLAN"
tagged Trk1-Trk2
exit
vlan 17
name "VLAN17"
tagged Trk1-Trk2
exit
vlan 18
name "VLAN18"
tagged Trk1-Trk2
exit
vlan 19
name "LB_IP_VLAN"
tagged Trk1-Trk2
exit
primary-vlan 11
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
password manager
password operator
2 REPLIES
cenk sasmaztin
Honored Contributor

Re: Trunk between 2848 and Cisco 4500 IOS

hi...

trunk statement cisco and procurve diffrent statement
for cisco ;vlan carry port
for procurve ;link agregation protocol
two method on procurve switch trunk
lacp 802.3ad and hp trunk

you can make two method link aggregation on procurve.

can you make carry vlans same port use only tag port command unatg port this vlan member tag port carry vlans information ports.

good luck
cenk

Mohieddin Kharnoub
Honored Contributor
Solution

Re: Trunk between 2848 and Cisco 4500 IOS

Hi

Your Native Vlan on the Cisco is 4094, and its by default on the ProCurve 1 and you changed to 11.

With the Native Vlan, the frame is not changed and so its not Tagged.

Remove the Native Vlan 4094 form the Cisco switch and the Primary-Vlan 11 from the ProCurve switch, and it will be ok.

Otherwise, change the Native Vlan on the Cisco to match the Primary Vlan on the ProCurve and be sure to keep it Unttaged on the Trunk from both sides.

Good Luck !!!
Science for Everyone