Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunking HP 2626 to Cisco 2950-24

Glenn Borromeo
Occasional Advisor

Trunking HP 2626 to Cisco 2950-24

can anyone email me the configuration for trunking (port trunking/Link Aggregation)HP 2626 and Cisco 2950-24. I need the configuration to be done on the Cisco side.

TIA
7 REPLIES
Arnaud_9
Valued Contributor

Re: Trunking HP 2626 to Cisco 2950-24

Glenn,

The joined file should help you.

If you want to tag the VLAN 1, you will need to set a different "native" VLAN, witch will be untagged.
In the Cisco trunk, you will need to had the following command :
switchport trunk native vlan XX

and on the HP switch :
vlan 1
tagged Trk1
vlan XX
untagged Trk1

Arnaud
OLARU Dan
Trusted Contributor

Re: Trunking HP 2626 to Cisco 2950-24

1. Your HP config is OK as it is.

2. Define the link aggregation protocol on Cisco (note that pagp=FEC):
"
(config)#interface range fastEthernet 0/1 - 4
(config-if)#channel-group 1
(config-if)#channel-protocol pagp
"

3. Define trunking a-la-Cisco (what you already entered as switchport for each interface is OK):
"
(config)#interface range fastEthernet 0/1 - 4
(config-if)#switchport trunk native vlan1
!use "Untagged" frames when trunking VLAN1, just like you have set for HP!
(config-if)#switchport trunk allowed vlan 1-3
"

4. Populate your VLANs on the Cisco switch, using commands like:
"
(config)#interface range fastethernet 0/5 - 17
(config-if)#switchport mode access
(config-if)#switchport access vlan 1
(config-if)#interface range fastethernet 0/18 - 38
(config-if)#switchport mode access
(config-if)#switchport access vlan 2
(config-if)#interface range fastethernet 0/39 - 48
(config-if)#switchport mode access
(config-if)#switchport access vlan 3
"
OLARU Dan
Trusted Contributor

Re: Trunking HP 2626 to Cisco 2950-24

Glenn,

I had the impression that you attached the configuration, but it was Arnaud who attached the .txt file. Arnaud's config is correct, and you should use it completed with what I posted above.

Dan
Glenn Borromeo
Occasional Advisor

Re: Trunking HP 2626 to Cisco 2950-24

Guys,

Thanks for the reply but the attached txt file didn't work since there is no command " port group 1 distribution destination" and "switchport trunk encapsulation dot1q" on Cisco 2950-24 (WS-C2950-24).
Any other suggestions?

TIA

Re: Trunking HP 2626 to Cisco 2950-24

Are you using a software on the Cisco that supports "FEC" and 802.1q? Might be worth the effort make sure you have the latest software, if not for this so for securityreasons ;-)

Ive never worked with 2950 so I dont know exactly what the switch can do...

/Magnus
Arnaud_9
Valued Contributor

Re: Trunking HP 2626 to Cisco 2950-24

Glenn,

I was not really up to date with my config !
Both commands that don't work are not used anymore on 2950 and maybe on latest Cisco Switches (it was working fine on 35xxXL and 29xxXL).

Dan's commands should work.

On 2950 :
"port group *" is now replaced by "channel-group *"
and
"switchport trunk encapsulation dot1q" have to be replaced with "switchport trunk" only because 2950 support only 802.1q encapsulation.

For more help look at this sample config at the 2950 sections :
http://www.cisco.com/en/US/products/hw/switches/ps607/products_configuration_example09186a0080094789.shtml

Arnaud
Stuart Teo
Trusted Contributor

Re: Trunking HP 2626 to Cisco 2950-24

Glenn,

What version of CatOS are you running? Doing a "show ver" should list the version.

Also, the below lingo-translation might help you.

1) What HP calls a trunk, cisco calls an etherchannel. On a cisco box, implement it using the port-channel interfaces. It's straight forward on the HP box.

2) What cisco calls a trunk, HP has no name for. For HP, that is just an interface or a trunk that carries multiple VLANs. The rules on both side are the same. Only 1 VLAN can be untagged, the rest needs to be tagged. On cisco, use the "native vlan" command to define which is the untagged VLAN.

3) What HP calls an FEC, cisco calls PAgP. They're the same thing. This is not the only way to build an etherchannel. You can either build a HP trunk (aka cisco "dynamic desirable" or "trunk") or build an LACP trunk. Both cisco & HP calls LACP LACP since it's IEEE.

4) I prefer to set the cisco to encapsulate using dot1q. The default is to negotiate. That will cause the cisco box to try ISL with the other switch. HP doesn't talk ISL. So why bother to let it negotiate? Just nail it! But that's just me.





If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.