Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunking/load balancing between 2 5308xl switches using wireless link

SOLVED
Go to solution
Joeri Golsteyn
Occasional Visitor

Trunking/load balancing between 2 5308xl switches using wireless link

I interconnected 2 Procurve 5308xl switches between our main and remote office using a wirless wifi link operating at 54Mbps. The wirless routers are acting as a wifi bridge and this is working just fine for the last year or so.

We added a second wifi link to have redundancy, but I would also like use the extra bandwith and use load balancing

I added both ports in a trunk (non LACP) and the redundancy is woring just fine if one of the links is lost.

The only problem is that it does not do any load-balancing.
The reason, I believe, is that trunking needs the use the full 100Mbps of the first port before it will use the second port defined in the trunk. As we are cheating and only have a 54Mbps connection between the switches, this 100Mbps will never be reached and the second link will not be used.

I tried using bandwith control (rate-limit), but this is not allowed on trunked ports.

Does anyone know if this is even technically possible? Does spanning-tree offer any solutions to have load-balancing without using the trunk option?

Any help is welcome ;-)

Thanks,

Joeri
5 REPLIES
Mohammed Faiz
Honored Contributor

Re: Trunking/load balancing between 2 5308xl switches using wireless link

Hi,

The issue is down to the way load balancing is done over trunked ports. It's based on source-address and destination-address pairs and is nothing to do with traffic load.
Is your wifi link just a layer 2 link or is it encapsulated in a tunnel?
If the answer is the latter then that's your main problem, if the SA and DA are always the same (i.e. the endpoints of the tunnel) then your traffic flow across the two ports will always be the same.
To load balance in true fashion you need another device/appliance to do the job.
MSTP will allow you to do some load-balancing but again it's not perfect. In effect, you choose how VLANs are split across the links (so the load balancing depends upon how evenly your VLANs are loaded)

HTH
Joeri Golsteyn
Occasional Visitor

Re: Trunking/load balancing between 2 5308xl switches using wireless link

Hi,

I'm not using any kind of tunnel, so I suppose the wireless bridge is just behaving as a L2 link.

If I understand correctly the SA and DA for the trunk are the IP addresses of the HP 5308 switches in the respective VLAN, not the IP addresses of the clients connected to the switches on both ends?

I created a seperate VLAN to inter-link both switches as I do not want any broadcast traffic over the wifi link.

This is the config:
-------- Relevant Switch Config Side A
hostname "HP5308DS"
interface G23
name "Wireless Router 1"
flow-control
no lacp
exit
interface G24
name "Wireless Router 2"
flow-control
no lacp
exit
trunk G23-G24 Trk2 Trunk
ip routing
vlan 1
name "DS"
untagged A1-A24,G22
no ip address
qos priority 0
ip helper-address 192.168.101.2
no untagged B1-B2,C1-C24,D1-D16,D18-D22,D24,E1-E16,F1-F6,F9-F24,G1-G21,H1-H24,Trk1-Trk4
exit
vlan 4
name "KS"
untagged B1-B2,C7-C8,C10-C12,C14-C22,C24,D1-D5,D7-D10,D13-D16,D18-D22,D24,E6-E13,E15-E16,F1-F6,F9-F24,G1-G21,H1-H24,Trk3
ip address 192.168.130.1 255.255.255.0
qos priority 0
ip helper-address 192.168.130.9
tagged E1,E3,E5,E14
exit
vlan 203
name "BRIDGE1"
ip address 192.168.203.2 255.255.255.0
tagged Trk2
exit
ip route 192.168.101.0 255.255.255.0 192.168.203.1


-------- Relevant Switch Config Side B
hostname "HP5308DS"
interface B18
name "Wireless Router 1"
flow-control
no lacp
exit
interface D6
name "Wireless Router 2"
flow-control
no lacp
exit
trunk B18,D6 Trk2 Trunk
ip routing
vlan 1
name "DS"
untagged A5,A14,B1-B4,B10,B15-B17,B20-B24,C2,C4-C5,C13-C17,C19-C23,D1-D2,D4-D5,D9-D16,D18,D20-D24,E1-E10,E12-E24,F2,F4-F12,F18,F2
1-F24,G1-G4,Trk1
ip address 192.168.101.1 255.255.255.0
qos priority 0
ip helper-address 192.168.101.2
tagged A2-A4,A9-A10,A16
no untagged A1,A6-A8,A11,A15,B5-B9,B11-B14,B19,C1,C3,C6-C12,C18,C24,D3,D7-D8,D17,D19,E11,F1,F3,F13-F17,F19-F20,Trk2
exit
vlan 4
name "KS"
untagged E11
no ip address
qos priority 0
ip helper-address 192.168.130.9
tagged A3-A4,A9-A10,A16
exit
vlan 203
name "BRIDGE1"
ip address 192.168.203.1 255.255.255.0
tagged Trk2
exit
ip route 192.168.130.0 255.255.255.0 192.168.203.2

So when I access a Client on the other side I have the following route:
Client 1 VLAN4=192.168.130.120 <-> (IP HP5308DS) 192.168.203.1 <-> Client2 VLAN1=192.168.101.2

The are many other VLANs, but this is not relevant to the config...

If I understand correctly trunking will not help me for load-balancing.

The only option I have is to use MSTP and distribute the VLANs manually over the primary and secondary wifi link? Both serving as backup link for eachother. Can you confirm this?

Many thanks for your insights...
Mohammed Faiz
Honored Contributor
Solution

Re: Trunking/load balancing between 2 5308xl switches using wireless link

Hi,

No, the load balancing is based on the client SA/DA pairs not the address of the switches.
Here's a quote from the manual that explains it better than I can :) (in the example, switch 1 and 2 are connected via a trunk)

"The load-balancing is done on a per communication basis. Otherwise, traffic
is transmitted across the same path as shown in figure 12-13. That is, if Client
A attached to Switch 1 sends five packets of data to Server A attached to
Switch 2, the same link is used to send all five packets. The SA/DA address
pair for the traffic is the same. The packets are not evenly distributed across
any other existing links between the two switches; they all take the same path."

Joeri Golsteyn
Occasional Visitor

Re: Trunking/load balancing between 2 5308xl switches using wireless link

Ok,

I understand, 2 different clients might use 2 different links... This answers my question as for now this will do what we want.

I'm looking to upgrade to 802.11n wifi links in the near future anyway.

Thanks for your quick response.
rick jones
Honored Contributor

Re: Trunking/load balancing between 2 5308xl switches using wireless link

With the posible exception of Linux's round-robin load balancing, I don't think there is any bonding/trunking/aggregation solution out there that will spread the packets of a single "flow" across the links of a trunk.

Doing so is fraught with issues - primarily that it will introduce packet reordering. TCP "deals" with it, but out of order TCP segments trigger immediate ACKs, which addes to overhead. Trigger enough of these out of order, immediate ACKs and you can trigger TCP fast retransmit, which will simply add to the load, and limit the TCP congestion window.

In various contexts, not necessarily all available in a ProCurve switch, I've seen flows defined as:

1) All traffic between a given SA and DA pair
2) All traffic between a given Src and Dst IP address
3) All traffic between a given "four tuple" of Src/Dst IP plus Src/Dst Layer 4 (eg TCP, UDP) port number
there is no rest for the wicked yet the virtuous have no pillows