Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Untag

Edward Hasted
Occasional Contributor

Unable to Untag

We are using an HP ProCurve 4204vl Switch.

In VLAN Configuration/Modify I am unable to untag a port. So If I set a port as Untagged if I try to revert it back to know I get the following message:

"An error was encountered while attempting to set your configuration. Your configuration was not modified."

I have tried this on a number of VLAN/Ports and it behaves consistently. If I cahnge it to another setting like Forbid I can revert it back to No.

Why, and what's the fix?

Many thanks, Ed
5 REPLIES
showneek
Respected Contributor

Re: Unable to Untag

Hi, suppose that is related to VLAN membership rules.

1. Port has to be member at least one VLAN (default as untagged in VLAN 1).

2. As untagged port can be member at most one VLAN.

So if you make port untagged in other VLAN (eg. VLAN 2) and this port is not member (tagged) of another VLAN you cannot revert untagged membership. You have to reassign the port to another VLAN (possibly back to VLAN 1) because port has to be member at least one VLAN.
Edward Hasted
Occasional Contributor

Re: Unable to Untag

I appreciate that, but maybe my question is maybe simpler than you think.

On my switch I made only one change of a port from "No" to "Untagged". Nothing else was done.

Why can't I change it back to it's original state of "No" that is shown in the drop down box.

If the setting was "No" origianlly I don't understand why it is blocking me from putting it back to the setting it has 5 seconds previously...

EckerA
Respected Contributor

Re: Unable to Untag

ok,
you did put the port as untagged to a different vlan and then back into the default vlan..
just put the port back again untagged into an other vlan and it will be no untagged in the default vlan..
hth
alex
Martin_A7
Occasional Visitor

Re: Unable to Untag

I know this is an old post, but i just ran into this issue and found this post.

I had the same setup/issue as the original poster, and found that the ports on VLAN1 that were set to 'No' (set to 'Untagged' on VLAN2) had to be set to 'Tagged' on VLAN1 (did not have to 'Apply' before changing) then changed to 'Untagged' and then finally 'Apply'ing. Doing this allowed me to set all ports to VLAN1 so i could, ultimately, remove VLAN2. Nothing else worked as far as moving those ports from VLAN2 to VLAN1 - possibly an issue with the firmware, or maybe by design. This was an HP ProCurve 2510G-48 (J9280A) (Y.11.12, ROM N.10.02).

Hope this helps anyone else that may run into this issue.

Arimo
Respected Contributor

Re: Unable to Untag

Hi

 

Actually this is caused simply by the general VLAN requirements.

 

Showneek has the right gist. Assume port 1 is Untagged on VLAN 2, and shows as "No" on VLAN 1. Now change the status on VLAN 1 to Untagged. This means its status on VLAN 2 changes to "No" because the port is no longer a member of this VLAN. If the switch SW allowed changing the status on VLAN 1 back to "No", the port would be orphaned, not a member of any VLAN, and this is not allowed.

 

So to change the status on VLAN 1 back to "No" in this situation the only way is to add the port to any other VLAN as untagged or tagged member. It doesn't matter which one, as long as the port is a member on any VLAN. Configuring from "No" to Untagged does not require first configuring to Tagged. If it does, you should contact support, as you're looking at a SW bug.


HTH,

Arimo
HPE Networking Engineer