Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to add static ARP for Multicast NLB on GbE2c Blade switch

SOLVED
Go to solution
Ola_Einar
Visitor

Unable to add static ARP for Multicast NLB on GbE2c Blade switch

Hi

 

I'm trying to get NLB to work for an Exchange 2010 installation. The 2 servers are virtual servers (VMWare) and pr recommendation from VMWare I'm trying to set it up using Multicast. I'm unable to ping the cluster address however.

As far as I can find out I need to add a static ARP on the switch.

When I log on to the Blade switch, I can go to Layer 3 / ARP and add a static ARP. I add the cluster IP, cluster MAC, the VLAN that the servers are on, and a port (Which port am I suppose to use here by the way?)

Anyway , the static ARP seem to be added fine. When I press Apply however error messages are added to  the log:

 

Oct 10 12:25:25 Blade_1_-_GbE2c_-_Switch_1 ERROR cfg: Error: No enabled subnet for static ARP entry with IP xx.xx.xx.xx, VLAN xxx
Oct 10 12:25:25 Blade_1_-_GbE2c_-_Switch_1 ERROR cfg: Error: Static ARP entry with invalid MAC: 03:bf:xx:xx:xx:xx
Oct 10 12:25:25 Blade_1_-_GbE2c_-_Switch_1 ERROR mgmt: Error: Apply not done

 

(I have added the x to MAC an IP to anonymize)

Does anyone have an idea of what the problem might be?

 

Full name and version of switch is GbE2c Ethernet Blade Switch for HP c-Class BladeSystem with firmware 5.1.3

2 REPLIES
showneek
Respected Contributor
Solution

Re: Unable to add static ARP for Multicast NLB on GbE2c Blade switch

Hi,

 

I am not hundred percent sure about it but think that the one problem in Microsoft NLB Multicast mode is that you have to add static ARP with unicast ip address mapped to multicast mac address and basically that is against standard so most switches does not allow that.

 

To work with NLB in multicast mode some switches add this "feature" in newer firmware (from HP networking products for example A5800, ProVision series switches in E family) but not sure if this is possible for GbE2c blade switch even with newer firmware if there is one. Just try to see release notes.

 

BR,

Jan

 

Ola_Einar
Visitor

Re: Unable to add static ARP for Multicast NLB on GbE2c Blade switch

OK, thanks a lot.

Will start reading the documentation and see what I can find out. Hopefully I won't need to add the staic ARp at all.

 

Ola EInar