Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Config

Gordon Curry
Occasional Advisor

VLAN Config

Hi all,

I'm struggling with VLAN's again and need to find out where I'm going wrong.

I have a pair of 5406zl switches on which I want to create a VLAN for server iLO connections (see drawing). There is a DHCP scope on our DHCP server and the VLAN needs to be accessable from the local 192.168.78.x network and the 192.168.3.x network.

I've created VLAN199 on each switch with an ip address for each and set a secondary ip address on the Cisco router LAN interface of 192.168.199.254 but I can't get any connectivity.

-----------------------------------------------

Switch config's are;

Switch01:

trunk A15,B15,C15,D15,D21 Trk5 Trunk
ip default-gateway 192.168.78.1
snmp-server community "public" Unrestricted
snmp-server host 192.168.20.223 "public"
snmp-server host 192.168.3.203 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,A16-A24,B1,B13-B14,B16-B24,C1-C14,C16-C19,C21,C23,D1-D14,D16-D20,D22-D24,Trk5
ip address 192.168.78.230 255.255.255.0
no untagged B2-B12,C20,C22,C24
exit
vlan 3
name "MPLS"
untagged C20,C22,C24
no ip address
exit
vlan 199
name "iLO"
untagged B2-B12
ip helper-address 192.168.78.12
ip address 192.168.199.1 255.255.255.0
exit

-----------------------------------------------

Switch02:

trunk A15,B15,C15,D16,D22 Trk5 Trunk

ip default-gateway 192.168.78.1
snmp-server community "public" Unrestricted
snmp-server host 192.168.20.223 "public"
snmp-server host 192.168.3.203 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,A16-A24,B1-B14,B16-B24,C1,C13-C14,C16-C24,D1-D15,D17-D21,D23-D24,Trk5
ip address 192.168.78.231 255.255.255.0
no untagged C2-C12
exit
vlan 199
name "iLO"
untagged C2-C12
ip helper-address 192.168.78.12
ip address 192.168.199.2 255.255.255.0
exit


Thanks in advance for any help with this.

Regards

Gordon.
3 REPLIES
cenk sasmaztin
Honored Contributor

Re: VLAN Config

hi Gordon

ip routing enable must be each switch
and trunk port (trk5 )must be
tagged member vlan 199

no needed ip address vlan 199 second switch

trunk A15,B15,C15,D15,D21 Trk5 Trunk
ip routing******************************************
ip default-gateway 192.168.78.1*********(not needed )
snmp-server community "public" Unrestricted
snmp-server host 192.168.20.223 "public"
snmp-server host 192.168.3.203 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,A16-A24,B1,B13-B14,B16-B24,C1-C14,C16-C19,C21,C23,D1-D14,D16-D20,D22-D24,Trk5
ip address 192.168.78.230 255.255.255.0
no untagged B2-B12,C20,C22,C24
exit
vlan 3
name "MPLS"
untagged C20,C22,C24
no ip address
exit
vlan 199
name "iLO"
untagged B2-B12
tagged Trk5***************************
ip helper-address 192.168.78.12
ip address 192.168.199.1 255.255.255.0
exit


trunk A15,B15,C15,D15,D21 Trk5 Trunk
ip routing*****************************************
ip default-gateway 192.168.78.1*********(not needed)
snmp-server community "public" Unrestricted
snmp-server host 192.168.20.223 "public"
snmp-server host 192.168.3.203 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,A16-A24,B1,B13-B14,B16-B24,C1-C14,C16-C19,C21,C23,D1-D14,D16-D20,D22-D24,Trk5
ip address 192.168.78.230 255.255.255.0
no untagged B2-B12,C20,C22,C24
exit
vlan 3
name "MPLS"
untagged C20,C22,C24
no ip address
exit
vlan 199
name "iLO"
untagged B2-B12
tagged Trk5******************************
ip helper-address 192.168.78.12
ip address 192.168.199.1 255.255.255.0*********(not needed must be no ip address)
exit
cenk

cenk sasmaztin
Honored Contributor

Re: VLAN Config

and please send me 2821 router sh run print
cenk

Gordon Curry
Occasional Advisor

Re: VLAN Config

Hi cenk sasmaztin.

Thanks for the quick reply....

I'll try out the settings you suggest and post the results. Have to be done out of hours though, this is in production, so I won't get a chance until tonight.

Gordon.