Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Tagging /IP Phone

Rex1981
Occasional Contributor

VLAN Tagging /IP Phone

I am having issues with setting up our Mitel IP phones with our hp switches.
I have a 5308xl connected to a 2524 over fiber, the connection is trunked.

I plug a Mitel IP phone into the 2524 with the Phone VLAN tagged.. DHCP is also set up so that the phone gets the correct VLAN and IP information.. But the phone refuses to work.. Any ideas would be great. Maybe I have mucked up the switch cnfig some how. I am inlcuding my running config for both my 5308 and 2524... Any help would be great!

Below is 5308 Config.. Attached is 2524

trunk C15 Trk1 Trunk
ip default-gateway 172.20.1.2
sntp server 172.20.1.26
ip routing
timesync sntp
sntp unicast
logging facility syslog
logging 172.20.1.161
snmp-server community "public"
snmp-server host 172.20.1.163 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A2-A6,A8-A15,B2,B4,B6-B15,C14,C16,D1-D9,D12-D16,E1-E16,F1,F3-F14,F16
ip address 172.20.1.2 255.255.255.0
tagged A7,Trk1
no untagged A1,A16,B1,B3,B5,B16,C1-C13,D10-D11,F2,F15
ip igmp
monitor
exit
vlan 2
name "Plant2"
untagged Trk1
ip address 172.20.2.1 255.255.255.0
ip helper-address 172.20.1.27
tagged A7,C16
exit
vlan 10
name "Internet"
untagged B16
ip address 172.20.10.1 255.255.255.0
tagged C16
exit
vlan 12
name "CustSrvc"
untagged A16,C1-C13
ip address 172.20.12.1 255.255.255.0
ip helper-address 172.20.1.27
tagged A7,C16
exit
vlan 15
name "Order Entry"
untagged B1,B3,B5,D10-D11,F2,F15
ip address 172.20.15.1 255.255.255.0
ip helper-address 172.20.1.27
tagged A7,C16
exit
vlan 20
name "PHONE"
untagged A7
ip address 172.20.25.1 255.255.255.0
qos priority 6
ip helper-address 172.20.1.27
tagged A1-A6,A8-A16,B1-B16,C1-C14,C16,D1-D16,E1-E16,F1-F16,Trk1
voice
exit
vlan 900
name "MetE_to_Plt3"
untagged A1
ip address 192.168.1.9 255.255.255.252
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
ip authorized-managers 172.20.1.163 255.255.255.0
gvrp
ip route 0.0.0.0 0.0.0.0 172.20.10.2
spanning-tree Trk1 priority 4
ip router-id 172.20.1.3
router ospf
area backbone
redistribute static
exit
vlan 1
ip ospf area backbone
exit
vlan 2
ip ospf area backbone
exit
vlan 10
ip ospf area backbone
exit
vlan 12
ip ospf area backbone
exit
vlan 15
ip ospf area backbone
exit
vlan 20
ip ospf area backbone
exit
vlan 900
ip ospf area backbone
exit
password manager
4 REPLIES
Evert Goor
Trusted Contributor

Re: VLAN Tagging /IP Phone

The configuration on the switches side is ok. The only question is the configuration in the DHCP server.
Did you put also the vlan 20 in the dhcp server or are you using the mitel server as the dhcp provider. And what are the exact messages on the phone.

Did you tried to put the phone in a port with vlan 20 untagged and see if the phone gets a new ip address and connects to the mitel.

Mostly the problem is in the dhcp a problem.
please post the dhcp settings for vlan20 if you use an other dhcp server then the mitel.

Good Luck

Rex1981
Occasional Contributor

Re: VLAN Tagging /IP Phone

I use DHCP Helper Address for VLAN 20. If I untag a port on VLAN 20 and connect a PC it gets the correct IP address. I have my DHCP settings as follows.



066 Boot Server Host Name 172.20.25.2
067 Bootfile Name Standard /sysro/e2t8260
128 128 Standard 172.20.25.2
129 129 Standard 172.20.25.2
130 130 Standard MITEL IP PHONE
132 132 Standard 0x14
133 133 Standard 0x6


Then Below is the DHCP settings for the voice vlan.

066 Boot Server Host Name Standard 172.20.25.2 None
067 Bootfile Name Standard /sysro/E2T8260 None
128 128 Standard 172.20.25.2 None
129 129 Standard 172.20.25.2 None
130 130 Standard MITEL IP PHONE None


Evert Goor
Trusted Contributor

Re: VLAN Tagging /IP Phone

put the extra options you have in the basic vlan also in the vlan 20.

I added the mitel documentation what to set in the dhcp server.
Hazrat
Occasional Visitor

Re: VLAN Tagging /IP Phone

If it works when the port is untagged, it sounds like the phone is not getting the proper VLAN through DHCP.

Remember, the phone will DHCP on the untagged vlan, and then the DHCP server (if sending the vlan info through dhcp which is how I read your post) will get an IP and VLAN parameters. Then the phone should start transmitting on the tagged vlan.

For me anyway using Bind DHCP, I had to set the two subnets (the tagged and untagged) as 'shared' for it to actually work.

You can try setting the phone's vlan manually, if that works then the problem is something with DHCP passing the vlan to the phone.