Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Trunk on 2510-48 to WRT54GS with DD-WRT

Chris Conlan
Occasional Contributor

VLAN Trunk on 2510-48 to WRT54GS with DD-WRT

I currently have a WRT54GS v3 setup with DD-WRT mega and all the info for VLANs setup.

I logged into the CLI interface and know that the "trunk" command is to be used to define the trunk. The output it gives with trunk ? is [ethernet] PORT-LIST. I know setting up a trunk is way different on a Cisco switch.

How do you go about setting up Port 50 as the trunk link? I currently have VLAN1 (default management), VLAN2 (Administration), VLAN3 (Students), and VLAN4 (Guest) setup via the web interface.

I'm at a loss right now.
3 REPLIES
Chris Conlan
Occasional Contributor

Re: VLAN Trunk on 2510-48 to WRT54GS with DD-WRT

Alright, after enable MENU when logging into the switch, I enabled TRK1 and TRUNK on Port 48.

The question I have is, when you go to VLAN Port Assignment and see TRK1 at the bottom, do all of the VLANs need to be TAGGED?
Mohammed Faiz
Honored Contributor

Re: VLAN Trunk on 2510-48 to WRT54GS with DD-WRT

Hi,

Trunks in the Cisco terminology and trunks on HP switches (and most other networking devices for that matter) mean very different things.
A Cisco trunk is related to VTP (VLAN trunking protocol) which deals with the assignment of VLANs to inter-swtich links.
An 'HP trunk' deals with the aggregation of multiple switch ports to form a larger/more resilient pipe (an etherchannel in the Cisco world).
If you want to present a number of VLANs to your netgear then you just need to tag each of those on port 50 (or any port of your choosing). For example:

switch(config)# vlan 1 tag 50
switch(config)# vlan 2 tag 50
...

The basic rule is VLANs are tagged for inter-switch links and untagged for access ports. You can only have one untagged VLAN on a port but muliple VLANs can be tagged on the same port.
Chris Conlan
Occasional Contributor

Re: VLAN Trunk on 2510-48 to WRT54GS with DD-WRT

I figured my issue out. I totally forgot to add the IPs for the VLANs (10.10.2.1, etc). Once those were set and I had the TRK1 set to TAGGED on all the VLANs, they were handing out the right IPs.