Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Trunking between Procurve 2848 and CISCO 3750G

wtu
Occasional Advisor

VLAN Trunking between Procurve 2848 and CISCO 3750G

I configured a 48-port CISCO 3750G switch with three VLANs (400,500, and 600) in addition to the default VLAN 1 which is not being used on this switch. I have three Procurve 2848 switches. I'd like to use these switches for each of the three VLANs (Therefore, each Procurve switch will be associated with just one VLAN but capable of carrying traffic to/from other VLANs). In the furture, I may buy more Procurve switches or just un-intelligent layer two switches as needed for port expansion if I were to run out of ports on any of the VLANs. The 3750G is connecting to a CISCO 2821 router. From the router, the other Gigabit Ethernet interface is linked to a Procurve 2848 switch where our server farm resides and two VLANs configured are in use (VLAN 1 and VLAN 300). The two serial interfaces of the 2821 router connect to two remote LANs via their corresponding PTP T1 lines.

I would appreciate it if anyone is willing to provide your configuration experiences/comments to me for the following:

1. Configuration articles/examples for configuring aggregated links between CISCO 3750G and Procurve 2848 (Has HP dropped support of configuring CISCO EtherChannel aware type of trunks on Procurve? If yes, what should I use instead?)

2. What Spanning Tree protocol variant would be the best fit in the above net topology? Why?
May I have some examples?

3. Is there a smart way to peform a port monitoring (e.g. SPAN) on a single switch port for all VLAN traffic coming from/going to all HP and CISCO switches? Any articles/examples will be highly appreciated!

Thanks again!
2 REPLIES
OLARU Dan
Trusted Contributor

Re: VLAN Trunking between Procurve 2848 and CISCO 3750G

I will try to help you solve question #1.

I understand that you need to link each of your HP 2848s to the Cisco 3750G in a star topology.

In each of the HPs you will need to define all three VLANs (400, 500 and 600) in a way that their 802.1Q VLAN IDs match the 802.1Q VLAN IDs that you used on the Cisco device.

I would suggest you define 3 new VLANs in every 2848 and leave de DEFAULT_VLAN unchanged, just as you did to VLAN1 in the 3750 - I am sure that later you will need this VLAN for switch management purposes, by using a dedicated switch management subnet.

[It would be a good ideea to use a dedicated VLAN for printers and the print server also, to minimize the printjob traffic that has to pass through the inter-VLAN router - I suppose the 3750 will have this job for your internal network]

Later you will assign the ports of 2848s to whatever VLAN you want for clients (computers, printers, other edge switches...) by untagging them for their respective VLAN.

Case A
If you want to use just one physical link between each HP and the Cisco, then you don't have to use port aggregation.

In this case, port configuration for the uplink port should look like this:

A.1 Cisco
Suppose you used 802.1Q VLAN IDs 4,5 and 6 for your VLANs 400, 500 and 600 respectively.

interface GigabitEthernet1/0/bb
description "To SWT-yy#port-xx"
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,4-6
switchport mode trunk
switchport nonegotiate
speed nonegotiate
flowcontrol receive on
no cdp enable


A.2 HP
-> use Mode=1000FDx and FlowCTRL=Enable for the uplink port in "Switch Configuration - Port/Trunk Settings" menu
-> use tagging for the 3 client vlans, and leave the DEFAULT_VLAN untagged for the uplink port in "Switch Configuration - VLAN - VLAN Port Assignment" menu


Case B
If you want to use more than one physical link between each HP and the Cisco -suppose you've decided that 3 ports will be enough- then you have to use port aggregation.

In this case, port configurations for the uplink ports should look like this:

B.1 Cisco
Suppose you want to aggregate ports GigabitEthernet1/0/22 to /24 of 3750 to ports 41 to 43 of SWT-zz (HP ProCurve 2848).

interface Port-channel1
description *** To SWT-zz (HP ProCurve 2848) ***
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/0/22
description To SWT-zz#41 (HP2848)
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 1 mode on
!
interface GigabitEthernet1/0/23
description To SWT-zz#42 (HP2848)
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 1 mode on
!
interface GigabitEthernet1/0/24
description To SWT-zz#43 (HP2848)
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 1 mode on


B.2 HP SWT-zz
-> use Mode=Auto; FlowCTRL=Disable; Group=Trk1; Type=LACP for all the 3 uplink ports (e.g. 41, 42 and 43) in "Switch Configuration - Port/Trunk Settings" menu
-> use tagging for the 3 client vlans, and leave the DEFAULT_VLAN untagged for Trk1 in "Switch Configuration - VLAN - VLAN Port Assignment" menu



If you want to make th 3750 the Inter-VLAN router for your network, you will have to configure more things in that device, like IP addresses for the VLAN interfaces and IP routing.

I hope this helps you to clear Question #1.
wtu
Occasional Advisor

Re: VLAN Trunking between Procurve 2848 and CISCO 3750G

Thank you for taking time to reply my first question. I adopted option B for redundancy consideration. I use the 3750G for inter-VLAN routing. Therefore, I configured it with IP addresses for the three client VLANs. The switch itself also has an IP and the default gateway is the CISCO 2821 router. This router knows where to route traffic to/from other networks (e.g., the server farm, backup, remote office networks, etc.) The downside of the above design is that the 2821 becomes the single point of failure unless I buy one more router and configure HSRP.

I still have some further questions as the following:

a. LACP trunks related
According to my past experience with Procurve LACP trunks, some of the trunk ports could suddenly transfer to the blocked state. I had four HP Procurve switches with trunking and VLANs configured across them.

The question is that could similar situation happen to the option B config and cause the trunk to fail? If yes, is there a better way to prevent that from happening? I've never encountered similar situations when I connect two CISCO switches with EtherChannels. However, I don't have much confidence with other combinations such as CISCO/HP, CISCO/3COM, or CISCO/ASANTE.

b. CISCO stack related
If I add more 3750G switches to the stack, will there any impact to the existing HP/CISCO configurations?

c. 802.1Q tagging related
For non-trunk ports, I did untag for them for their associated VLANs. Is this correct?

Your time and assistance are highly appreciated!