Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Trunking issue

JodyG
Occasional Visitor

VLAN Trunking issue

001AA0-B1E184

Hi,
apologies if this has been covered before!

We are running the following setup:
2 x 2650-PWR switches
1 x 2824 switch
The 2650 switches are connected to the 2824 via the 1Gbs uplink ports.
Because we have a VoIP phone system, we are using 3 VLANS:
1 - DEFAULT_VLAN - used for uplinks
9 - Voice - used for IP phones
10 - Data - used for desktops (which are connected to the IP phones)

This weekend we increased the bandwidth between the 2650 switches and the 2824 by implementing static LACP trunks.
However, since then users on one of the 2650 switches cannot connect to any network resources, although they do obtain an IP address from the DHCP server on the data LAN (which is connected to the 2824 switch).
The configration on both the 2650 switches is the same so I'm not sure what the issue is.
We upgraded the firmware on all the switches at the weekend (I.10.70 for the 2824 and H.10.83 for the 2650's), so we have the latest firmware.

Here are the configs:

**************************
2824 (core switch)
; J4903A Configuration Editor; Created on release #I.10.70

hostname "Core-switch"
interface 1
name "Mitel_3300"
qos priority 6
exit
interface 2
name "Tracker"
exit
interface 4
name "NSU"
exit
interface 7
speed-duplex auto-1000
exit
interface 11
name "firewall"
speed-duplex auto-1000
exit
interface 21
qos priority 6
no lacp
exit
interface 22
qos priority 6
no lacp
exit
interface 23
name "Link_to_Switch_1"
qos priority 6
no lacp
exit
interface 24
name "Link_to_Switch_2"
qos priority 6
no lacp
exit
trunk 21,23 Trk1 LACP
trunk 22,24 Trk2 LACP
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged Trk1-Trk2
ip address dhcp-bootp
no untagged 1-20
exit
vlan 10
name "Data"
untagged 7-20
ip address 192.168.224.31 255.255.255.0
ip address 10.0.224.31 255.255.255.0
tagged Trk1-Trk2
exit
vlan 9
name "Voice"
untagged 1-6
ip address 192.168.222.1 255.255.255.0
qos priority 6
tagged Trk1-Trk2
exit
vlan 8
name "VLAN8"
exit
ip route 0.0.0.0 0.0.0.0 10.0.224.254
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
**************************

**************************
switch_1 (2650)
; J8165A Configuration Editor; Created on release #H.10.83

hostname "Switch_1"
interface 1
qos priority 6
exit
interface 2
qos priority 6
exit
interface 3
qos priority 6
exit
interface 4
qos priority 6
no lacp
exit
interface 5
qos priority 6
exit
interface 6
qos priority 6
no lacp
exit
interface 7
qos priority 6
exit
interface 8
qos priority 6
exit
interface 9
qos priority 6
exit
interface 10
qos priority 6
exit
interface 11
qos priority 6
exit
interface 12
qos priority 6
exit
interface 13
qos priority 6
exit
interface 14
qos priority 6
exit
interface 15
qos priority 6
exit
interface 16
qos priority 6
exit
interface 17
qos priority 6
exit
interface 18
qos priority 6
exit
interface 19
qos priority 6
exit
interface 20
qos priority 6
exit
interface 21
qos priority 6
exit
interface 22
qos priority 6
exit
interface 23
qos priority 6
exit
interface 24
qos priority 6
exit
interface 25
qos priority 6
exit
interface 26
qos priority 6
exit
interface 27
qos priority 6
exit
interface 28
qos priority 6
exit
interface 29
qos priority 6
exit
interface 30
qos priority 6
exit
interface 31
qos priority 6
exit
interface 32
qos priority 6
exit
interface 33
qos priority 6
exit
interface 34
qos priority 6
exit
interface 35
qos priority 6
exit
interface 36
qos priority 6
exit
interface 37
qos priority 6
exit
interface 38
qos priority 6
exit
interface 39
qos priority 6
exit
interface 40
qos priority 6
exit
interface 41
qos priority 6
exit
interface 42
qos priority 6
exit
interface 43
qos priority 6
exit
interface 44
qos priority 6
exit
interface 45
qos priority 6
exit
interface 46
qos priority 6
exit
interface 47
qos priority 6
exit
interface 48
qos priority 6
exit
interface 49
qos priority 6
no lacp
exit
interface 50
name "Uplink_to_Core"
qos priority 6
no lacp
exit
trunk 49-50 Trk1 LACP
ip default-gateway 10.0.224.254
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
forbid 6
untagged Trk1
no ip address
no untagged 1-48
exit
vlan 10
name "Data"
untagged 1-48
ip address 10.0.224.32 255.255.255.0
tagged Trk1
exit
vlan 9
name "Voice"
no ip address
qos priority 6
tagged 1-48,Trk1
exit
spanning-tree Trk1 priority 4
**************************

**************************
switch_2 (2650)
; J8165A Configuration Editor; Created on release #H.10.83

hostname "Switch_2"
interface 1
qos priority 6
exit
interface 2
qos priority 6
exit
interface 3
qos priority 6
exit
interface 4
qos priority 6
exit
interface 5
qos priority 6
exit
interface 6
qos priority 6
no lacp
exit
interface 7
qos priority 6
exit
interface 8
qos priority 6
exit
interface 9
qos priority 6
exit
interface 10
qos priority 6
exit
interface 11
qos priority 6
exit
interface 12
qos priority 6
exit
interface 13
qos priority 6
exit
interface 14
qos priority 6
exit
interface 15
qos priority 6
exit
interface 16
qos priority 6
exit
interface 17
qos priority 6
exit
interface 18
qos priority 6
exit
interface 19
qos priority 6
exit
interface 20
qos priority 6
exit
interface 21
qos priority 6
exit
interface 22
qos priority 6
exit
interface 23
qos priority 6
exit
interface 24
qos priority 6
exit
interface 25
qos priority 6
exit
interface 26
qos priority 6
exit
interface 27
qos priority 6
exit
interface 28
qos priority 6
exit
interface 29
qos priority 6
exit
interface 30
qos priority 6
exit
interface 31
qos priority 6
exit
interface 32
qos priority 6
exit
interface 33
qos priority 6
exit
interface 34
qos priority 6
exit
interface 35
qos priority 6
exit
interface 36
qos priority 6
exit
interface 37
qos priority 6
exit
interface 38
qos priority 6
exit
interface 39
qos priority 6
exit
interface 40
qos priority 6
exit
interface 41
qos priority 6
exit
interface 42
qos priority 6
exit
interface 43
qos priority 6
exit
interface 44
qos priority 6
exit
interface 45
qos priority 6
exit
interface 46
qos priority 6
exit
interface 47
qos priority 6
exit
interface 48
qos priority 6
exit
interface 49
qos priority 6
no lacp
exit
interface 50
name "Uplink_to_Core""
qos priority 6
no lacp
exit
trunk 49-50 Trk2 LACP
ip default-gateway 10.0.224.254
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged Trk2
no ip address
no untagged 1-48
exit
vlan 10
name "Data"
untagged 1-48
ip address 10.0.224.33 255.255.255.0
tagged Trk2
exit
vlan 9
name "Voice"
no ip address
qos priority 6
tagged 1-48,Trk2
exit
spanning-tree Trk2 priority 4
**************************

As a temporary fix we are moving users from switch_2 to switch_1, but we will run out of ports soon.

Any advice would be much appreciated.
3 REPLIES
JodyG
Occasional Visitor

Re: VLAN Trunking issue

Following on from this, I've noticed that the core and switch_1 switches are seeing MAC addresses from VLAN 10 on switch_2 in both VLAN 1 and VLAN 10.
I'm guessing traffic isn't being tagged correctly between switch_2 and the core switch, but I don't understand why.
Shadow13
Respected Contributor

Re: VLAN Trunking issue

1st of all, remove the ip address in vlan 10 from both switch 1 and switch 2 there is no need for them coz you already configured the ip address in the core switch in vlan 10.

2nd, why you are using 2 ip address underf vlan 10 ?

3rd. ip default-gateway 10.0.224.254 <---- this ip address is configured where ?


4th. after removing the ip address just clear the arp cache on the pcs and the switches and see if it works.

5th. I can see that you are using STP, plz check the interface brief to see which ports are blocked.

6th. can you show me the topology or how these switches are connected to see how the STP is acting.

Regards,
Islam Hassan
Mohammed Faiz
Honored Contributor

Re: VLAN Trunking issue

Hi,

Have you checked to make sure that the trunks have formed correctly ("show lacp" and "show trunk" should tell you).
You've setup up the trunks as LACP trunks but you've got LACP disabled on the ports that you are trunking over. I'd suggest that any switch-switch trunk you have are just static trunks (trunk 49-50 Trk1).

HTH.