Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Voice en Data

VLAN Voice en Data

We want to install an ip voice centrale.
We have two vlan's: Data, Voice.
Data have a ipadress:10.49.10.243 en Voice: 192.168.1.243.
The new telephone is a hub. The telephone must have a ipadres in the range of 192.168.1.x and the cable from the telephone goes to the pc in the range of 10.49.10.x. The DHCP from the voice is 192.168.1.1. Must we use an iphelper adress?
34 REPLIES
nunocosta75
Advisor

Re: VLAN Voice en Data

hi, you need to configure the helper address with the ip of the dhcp server, so the switch can relay the dhcp packets to the dhcp server.
Regards.

Re: VLAN Voice en Data

The ipadress from the DHCP server is:
192.168.1.1 and 10.49.10.19
Must i config some routes on the Procurve 2650?
like this:
192.168.1.0 255.255.255.0 192.168.1.1.
10.49.10.0 255.255.255.0 10.49.10.19.

Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

If the switch has an ip-adress in both vlan's, no static route needs to be configured.
(implicit route exists because of interface in subnet).
you may check if "ip routing" command is active in switch configuration.

you configure the ip-helper adress on the vlan that does not contain the DHCP-server.

Re: VLAN Voice en Data

We have the latest firmware.
On the procurve switch we can communicate with both vlans but not on the clients when we get an ipadress from the 192.168.1.x network. The cisco dhcp server have two ipadresses 10.49.10.19 and 192.168.1.1.
The DHCP give adress from 192.168.1.x
to 192.168.1.x. We place the cable from the switch in to a telephone en then to the telephone to the pc.
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

these lines are sufficient to make the
switch route between the two networks.
>>>
ip routing
vlan 20
ip address 192.168.1.1 255.255.255.0
exit
vlan 10
ip address 10.49.10.243 255.255.255.0
exit
<<<

the statement
>>> ip route 192.168.1.0 255.255.255.0 10.49.10.19
<<<
must be removed.
this does not result in connecting the two network. It may even work against you. as id directs the switch to send data for 192.168.1.0 out on vlan10 instead on vlan20!!!
routing is allready active just by using "ip routing".


the statement >>>ip default-gateway 192.168.1.1 <<
must also be removed as it points to the switches interface address.
If present at all, it should point to an external router.
But in conbination with using "ip routing" it's ignored anyway, and another command "ip route 0.0.0.0 0.0.0.0 " must be used.

What you probably miss is
>>>
vlan 20
name "Voice"
tagged 1-50
exit
vlan 10
name "Data"
untagged 1-50
exit
<<<
with this all ports use untagged packets in
the data-vlan, and port-7 ALSO sends tagged packets from the voice vlan to the phone.
the ip-phone receives all packets, listens to vlan-7 tagged packets (voice) and forwards untagged packets (data) to the PC.

your phone somehow must recognize vlan7 as it's own, either in its local config or centraly.

Re: VLAN Voice en Data

This is the new config file.
I have changed the gateway adress to 10.49.10.20
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

the "ip default-gateway " will still be ignored.

so how does this config behave ?

>>>
vlan 20
name "Voice"
untagged 13-14
ip address 192.168.1.243 255.255.255.0
qos priority 7
ip helper-address 192.168.1.1
ip helper-address 10.49.10.19
tagged 7-12,15-50
exit
vlan 10
name "Data"
untagged 1-12,15-50
ip address 10.49.10.243 255.255.255.0
tagged 13-14
exit
<<<
You've got tagged and untagged reversed from my suggestion.
to my knowledge a port with both phone and pc must be untagged in data-vlan and tagged in voice-vlan.
but i allready asked how does this config behave?

the "ip helper-address 192.168.1.1" in vlan-20 can be removed. It will do nothing as this is in the same subnet as the interface itself (192.168.1.243)
But does this mean you have got 2 different dhcp-servers?
If each subnet has its own dhcp-server you don't need an ip-helper at all, and both ip helper lines can be removed.
an ip-helperaddresss is only neccessary from a subnet that does not have it's own dhcp-server

Re: VLAN Voice en Data

We want to used the telephone as hub. In the telephone configuration we can make a option to go the data vlan. Is this possible when we used the voice as untagged en then data as tagged?
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

Yes I allready mentioned this :
"all ports use untagged packets in the data-vlan, and port- ALSO sends tagged packets from the voice vlan to the phone.
the ip-phone receives all packets, listens to vlan-7 tagged packets (voice) and forwards untagged packets (data) to the PC."

now with regard to "hub-ing".
A "hub" has no knowledge of vlans.
The phone when properly configured DOES.

- It passes untagged packets without interfering from the switch-side to the pc-side of the phone and vica versa
(thus works as a hub).

- It intercepts packets with the right vlan-tag that in the phone is configured as voice-vlan, and also responds with taggged packets.

So the switch knows which packets are sent from the phone (tagged) and which from the pc (untagged) and the switch can forward them to the rest of the network in the right vlan.

Re: VLAN Voice en Data

But the DHCP server of the VOIP central how must this port configured in the switch?
voice-untagged and data tagged or data-untagged voice tagged?
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

plse be more clear about the situation.
I allready asked "But does this mean you have got 2 different dhcp-servers?"

if you do, each server must be connected to a port in it's own subnet/vlan.

if you only got one, with two dhcp-"scope's", then this will best be in the data-vlan. It only needs an ip-adress in the data-subnet.

The switch, with the defined ip-helper will route dhcp-requests from the vouice-vlan to the dhcp-server in the data-vlan and route the response back.

Pieter

Re: VLAN Voice en Data

We have two different dhcp servers.
IP Voice and Data.
The telephone>> get a ipadress from the dhcp voice and then go to data with the hub option from the telephone
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

So you don't need any ip-helper at all

Re: VLAN Voice en Data

The DHCP server from voice must have port voice-untagged and data-tagged?
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

A standard windows server is not configured to use vlan's (can be added).
if is has only an ip-adress in the voice-subnet then it only needs the voice vlan untagged.

Re: VLAN Voice en Data

but the cable go to the telephone with 192.168.1.x range en then in the telephone go to data
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

Yes,
but the switch sees tagged and untagged packets as if they came from a different cable and forwards this to a different network.
thats why it's called V(irtual)LAN.

effectively you have got two separate networks even as they use the same cable and the same switch.
- your data-network from pc (untagged) to switchport to data-dhcp-server.
- and your voice-network from phone (tagged) to switchport to voice dhcp-server
cenk sasmaztin
Honored Contributor

Re: VLAN Voice en Data

see attach

cenk

Re: VLAN Voice en Data

I have a voip DHCP server and a Data DHCP server.
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

Does this scetch clarifies things for you?

- only ports used for phones are tagged voice-vlan and untagged data vlan.
- all other red-ports are untagged datavlan
- all green-ports are untagged voicevlan

Re: VLAN Voice en Data

Thank you. The VOIP DHCP have only a poort untagged I mean not data tagged?

Re: VLAN Voice en Data

The want also to use the cisco as data gateway 10.49.10.19.
Pieter 't Hart
Honored Contributor

Re: VLAN Voice en Data

yes the switchport for the voip-dhcp has only the voip vlan untagged.
The voip-dhcpserver has only a voip ip-address (192.168.1.x).

the switchport for the gateway has only the datavlan untagged.

in the data-dhcp you define the default-gateway option for the PC's either directly to the 10.49.10.19 or to the switch 10.49.10.243.
the switch must be able to forward to this gateway as default route
"ip route 0.0.0.0 0.0.0.0 10.49.10.19"

for all data-hosts with fixed ip-configuration you must also set the default-gateway to either the switch or the gateway.

maybe also in the voice-dhcp you may want the default-gateway option set to the switch 192.168.1.243.

if hosts behind the gateway 10.49.10.19 must communicate with the voip-vlan you must add a route back on the gateway
"ip route 192.168.1.0 355.555.255.0 10.49.10.243"

and maybe on the network behind the gateway also the route back must be configured.

Re: VLAN Voice en Data

On the data network we want the gateway: 10.49.10.19 same product as 192.168.1.1.
I have now untagged the port as voice.
How can we communicate with both adresses?
I can now only communicate with 192.168.1.1.
Must I set some routes?