Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN & DHCP Problem

snandra
Occasional Visitor

VLAN & DHCP Problem

I have a core HP 2910al (J9145A) Switch uplinked to 3 * HP 2520G's (J9299A)

The Core has 4 vlans:
Vlan 1 = Management
Vlan 2 = Data
Vlan 3 = Voice
Vlan 4 = Servers

Core:
Port 1 = management
Ports 2 - 20 untagged in Vlan 4
Ports 21 - 24 tagged in vlans 2 & 3
IP helper-address is configured for vlan2 (10.0.0.3 Windows DHCP Server)
DHCP-Relay is on
IP UDP-BCAST-Forward is on


Edge switches
Vlan 1 = Management
Vlan 2 = Data
Vlan 3 = Voice

Ports 1 - 23 untagged vlan 2
Port 24 tagged in vlan 2

Problem:
laptop plugged in a port belonging to Vlan2 does not recieve an IP address via DHCP.
If I configure a static IP address on the laptop everything if fine, I can even browse shares on the DHCP server and the DHCP server can contact the laptop.
The switches are running the latest fireware.

Please help, I need to implement this solution first thing tomorrow!

Configs:
CORE

Running configuration:

; J9145A Configuration Editor; Created on release #W.14.38

hostname "Lornamead Core Switch"
module 1 type J9145A
interface 21
name "Uplink for Edge"
exit
interface 22
name "Uplink for Edge"
exit
interface 23
name "Uplink for Edge"
exit
interface 24
name "Uplink for Edge"
exit
ip routing
ip udp-bcast-forward
vlan 1
name "Mgmt"
untagged 1,21-24
ip address 172.16.10.254 255.255.255.0
no untagged 2-20
exit
vlan 2
name "Data"
ip helper-address 10.0.0.36
ip address 10.1.0.254 255.255.255.0
tagged 21-24
exit
vlan 3
name "Voice"
ip address 192.168.1.254 255.255.255.0
tagged 21-24
exit
vlan 4
name "Servers"
untagged 2-20
ip address 10.0.0.254 255.255.255.0
exit
snmp-server community "public" unrestricted
password manager


EDGES:


; J9299A Configuration Editor; Created on release #J.14.01

hostname "Lornamead Edge .251"
ip default-gateway 10.0.0.254
vlan 1
name "Mgmt"
untagged 24
ip address 172.16.10.251 255.255.255.0
no untagged 1-23
exit
vlan 2
name "Data"
untagged 1-23
tagged 24
no ip address
exit
vlan 3
name "Voice"
tagged 24
no ip address
exit
snmp-server community "public" Unrestricted


Please please can someone helpme??

Thanks
5 REPLIES
Mohammed Faiz
Honored Contributor

Re: VLAN & DHCP Problem

Hi,

The trouble is that your "core" switch doesn't know how to route the traffic to the DHCP server.
You can fix it be enabling routing ("ip routing") however this would mean that it would route traffic across all VLANs that it has an IP address on. i.e. your clients would be able to see all your servers etc.
east
Occasional Contributor

Re: VLAN & DHCP Problem

Do you have a scope for the 10.1.0.x range set up on your DHCP server?

Does the laptop get an IP address when plugged into the core switch in either Server Or Data VLAN?


cenk sasmaztin
Honored Contributor

Re: VLAN & DHCP Problem

I want two questions to you

1-whic port connect your dhcp server
2-what is the default gateway address your dhcp server

and ip routing must have enable on core switch
cenk

kianwei
Advisor

Re: VLAN & DHCP Problem

Make sure your DHCP server have the scope and DHCP is reachable when you are using static IP in that specific user VLAN too. Besides, make sure you PC or device connect to the correct VLAN.For your case ip routing is already enabled as I can see "ip routing" in your config. ;p
Mohammed Faiz
Honored Contributor

Re: VLAN & DHCP Problem

Hah, yes sorry, ignore my comment. I missed that line in the config somehow!
Try what kianwei suggests :)