Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN and VOIP setup Procurve 2626

SOLVED
Go to solution
Joe Sheridan
Occasional Advisor

VLAN and VOIP setup Procurve 2626

Can someone point me in the right direction with this one? I have 4 Procurves and ShoreTel VOIP system. The system was originally setup with voice and data traffic on one network - 192.168.254.0. I want to separate the traffic. I have created a VLAN for the voice traffic (VLAN 10) and want to use the default VLAN for data traffic. I also want the two VLANs to communicate. The gateway for the default VLAN is the IP of our firewall 192.168.254.1. Some of the workstations and phones are stand-alone and some workstations are linked to an IP phone. I haven't assigned any ports or tested anything yet. I just want to get some guidance on how this should be properly configured. Here is a sample config of what I have so far. Please offer any suggestions or comments you may have.
Thx!

HP ProCurve Switch#1 2626-PWR# sh run

Running configuration:

; J8164A Configuration Editor; Created on release #H.08.60

hostname "HP ProCurve Switch#1 2626-PWR"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address dhcp-bootp
exit
vlan 10
name "VOIP"
ip address 172.16.0.1 255.255.0.0
qos priority 7
ip helper-address 192.168.254.13
exit
13 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: VLAN and VOIP setup Procurve 2626

hi joe you can make below config on your Procurve switch
and please careful listen to me

1-you wirite on firewall ip route command
ip route 172.16.0.0 255.255.255.0 172.16.0.1
ip route 192.168.254.0 255.255.255.0 192.168.254.2
----------------------------------------------------

2-you make config again dhcp server
scobe vlan 1
ip address range 192.168.254.20.......250
subnet mask:255.255.255.0
default gateway :192.168.254.2

scobe vlan 2
ip address range 172.16.0.20..........250
subnet mask:255.255.255.0
default gateway:172.16.0.1

dhcp server nic address must be 192.168.254.13
subnet mask 255.255.255.0
default gateway 192.168.254.2
-----------------------------------------------------
3-shore tel voip server config

ip address 172.16.0.2
subnet mask:255.255.255.0
default gateway :172.16.0.2
priority 7
connect on switch interface 20

ip phone config
vlan id 10
dhcp enable
qos priority 7
-------------------------------------------
example connect phone and pc
interface 1 :frist connect ip phone network plug and on ip phone pc plug connect to pc


-------------------------------------------


ProCurve Switch 2626# conf
ProCurve Switch 2626(config)# vlan 1
ProCurve Switch 2626(vlan-1)# ip address 192.168.254.2/24
ProCurve Switch 2626(vlan-1)# vlan 10
ProCurve Switch 2626(vlan-10)# voice
ProCurve Switch 2626(vlan-10)# name voip
ProCurve Switch 2626(vlan-10)# ip address 172.16.0.1 255.255.0.0
ProCurve Switch 2626(vlan-10)# qos priority 7
ProCurve Switch 2626(vlan-10)# ip helper-address 192.168.254.13
ProCurve Switch 2626(vlan-10)# untag 20
ProCurve Switch 2626(vlan-10)# tag 1-19,21-26
ProCurve Switch 2626(vlan-10)# ex
ProCurve Switch 2626(config)# ip routing
ProCurve Switch 2626(config)# ip route 0.0.0.0 0.0.0.0 192.168.254.1
ProCurve Switch 2626(config)# int 20
ProCurve Switch 2626(eth-20)# name shoretelvoipserver
ProCurve Switch 2626(eth-20)# wr mem
ProCurve Switch 2626(eth-20)# sh run

Running configuration:

; J4900B Configuration Editor; Created on release #H.10.50

hostname "ProCurve Switch 2626"
interface 20
name "shoretelvoipserver"
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-19,21-26
ip address 192.168.254.2 255.255.255.0
no untagged 20
exit
vlan 10
name "voip"
untagged 20

in this way seperate broadcast two vlan for performance and priority 7 vlan 10 on netwrok and enable voip vlan special feature has procurve two vlan connect each other vlan and internet.

cenk....
cenk

cenk sasmaztin
Honored Contributor

Re: VLAN and VOIP setup Procurve 2626

ip address 172.16.0.1 255.255.255.0
qos priority 7
ip helper-address 192.168.254.13
tagged 1-19,21-26
voice
exit
ip route 0.0.0.0 0.0.0.0 192.168.254.1
cenk

Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Thanks for the quick reply Cenk!
Below is the existing route on the firewall and the two new routes I would add. Does this look correct?
Also, wouldn't any ports that stand-alone workstations are connected to remain untagged?
thx...

Src * Dest * Service * GW * Intface * Metric
Existing:
Any * 192.168.254.0 * Any * 0.0.0.0 *LAN * 20

Add:
Any * 172.16.0.0 * Any * 172.16.0.1 * LAN* 20
Any * 192.168.254.0 *Any*192.168.254.2*LAN*20
Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Also, any idea about how I should configure the uplink ports on the switches?
cenk sasmaztin
Honored Contributor

Re: VLAN and VOIP setup Procurve 2626

ok joe new routing true
but no need you existing routing.

router connect untag port on vlan 1

yes you can connect to pc(alone) any port on switch (because all port (int20excep)vlan 1 untag member)

yes you can connect to ip phone (alone) on switch (because all port vlan 10 tag )with set on ip phone vlan id

cenk...........
cenk

cenk sasmaztin
Honored Contributor

Re: VLAN and VOIP setup Procurve 2626

uplink port connect to other switch must be

vlan 1 untag vlan 2 tag port and not assign ip address on other switch vlans

my above config already int 26 uplink port


cenk............
cenk

Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Sounds good, Cenk. One last question, hopefully, what about the other three switches. If I don't assign them an IP address, how do I manage them? If I assign an IP address, VLAN 1 on that switch then has that IP.
cenk sasmaztin
Honored Contributor

Re: VLAN and VOIP setup Procurve 2626

hi
I think you create different vlan for managemant on all switch
because no vlan 1 management vlan for default setings on switch vlan 1 only default vlan

can you make create management vlan decrale vlan id with managemet-vlan command

managemet vlan not routing cabability (for security)and isolated all other vlan
ultimate way connect switch for security



for example
switch 1
(config)#vlan 20
config(vlan 20)#ip address 10.0.0.1/24
config(vlan 20)#exit
(config)#managemet-vlan 20

switch 2
(config)#vlan 20
config(vlan 20)#ip address 10.0.0.2/24
config(vlan 20)#exit
(config)#managemet-vlan 20

switch 3
(config)#vlan 20
config(vlan 20)#ip address 10.0.0.3/24
config(vlan 20)#exit
(config)#managemet-vlan 20
cenk

Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Cent,
I have a ShoreGear 60/12 and a ShoreGear T1. Those should have the same port configuration as the ShoreTel server, correct?
Here is the configuration I have.


Running configuration:

; J8164A Configuration Editor; Created on release #H.08.60

hostname "HP ProCurve Switch#1 2626-PWR"
interface 12
name "ShoreGear-60/12"
exit
interface 16
name "Sonicwall_Firewall"
exit
interface 22
name "ShoreGear-T1"
exit
interface 23
name "voipserver"
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-11,13-21,24-26
ip address 192.168.254.2 255.255.255.0
no untagged 12,22-23
exit
vlan 10
name "VOIP"
untagged 12,22-23
ip address 172.16.0.1 255.255.0.0
qos priority 7
ip helper-address 192.168.254.13
tagged 1-4,6,8-11,13,15,17-21,24-26
exit
ip route 0.0.0.0 0.0.0.0 192.168.254.1
Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Yep, it's working.
Thanks for all your help, Cenk. I couldn't have done it without your guidance.
cenk sasmaztin
Honored Contributor

Re: VLAN and VOIP setup Procurve 2626

thanks joe
welcome
cenk

Joe Sheridan
Occasional Advisor

Re: VLAN and VOIP setup Procurve 2626

Something to add that I just found out about is that the DHCP server's port needs to be set to no untag or forbid in the voice VLAN (I don't know if this applies to other HP switches). This comes straight from HP.
MGaccess
Frequent Advisor

Re: VLAN and VOIP setup Procurve 2626