Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN configuration on 2510 and routing through Cisco 1841

eash
Advisor

VLAN configuration on 2510 and routing through Cisco 1841

I am badly in need some urgent assistance as i am configuring HP switches for the first time.

One of my customers have got 3 HP 2510 switches connected as follows port 26 of switch A is connected port 25 of Switch B and port 26 of this is connected as uplink to port 25 of switch C.

Port 25 of Switch will be connected to 1841 router.


I need to configure 5 LAN's there needs to be routing between VLAN's and also with the cisco router.

19 REPLIES
Shadow13
Respected Contributor

Re: VLAN configuration on 2510 and routing through Cisco 1841

create the vlans on all the 3 switches, tag the ports connected to the switches in all the vlans except the default vlan which is vlan 1 then on the port connected to the router tag the on all vlans except vlan 1

on the cisco router configure sub-interfaces 1 for each vlan and on the main interface use dot1q encapsulation so the cisco router will be router on a stick.

this is in brief :D
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Shadow,

Please find the below the router and switch configuration. Request you help for check the configuration.
HP2510
------
Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "Switch-1"
snmp-server community "public" Unrestricted
vlan 10
name "MMGNT"
untagged 1-24
ip address 192.168.0.2 255.255.255.0
ip-help address 192.168.0.x 255.255.255.0 (watch gaurd ip address)
tagged 25-26
exit

vlan 1
name "VLAN -1"
no ip address
untagged 9-20
tagged 25-26
exit

vlan 4
name "VLAN 4"
no ip address
untagged 21-24
tagged 25-26
exit

vlan 5
name "VLAN 5"
no ip address
untagged 1-8
tagged 25-26
exit


HP2510
------
Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "Switch-2"
snmp-server community "public" Unrestricted
vlan 10
name "MMGNT"
untagged 1-24
ip address 192.168.0.3 255.255.255.0
ip-help address 192.168.0.x 255.255.255.0 (watch gaurd ip address)
tagged 25-26
exit

vlan 2
name "VLAN 2"
no ip address
untagged 3-14
tagged 25-26
exit

vlan 3
name "VLAN 3"
no ip address
untagged 15-23
tagged 25-26
exit

vlan 4
name "VLAN -4"
no ip address
untagged 1-2,24
tagged 25-26
exit


HP2510
------
Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "Switch-3"
snmp-server community "public" Unrestricted
vlan 10
name "MMGNT"
untagged 1-24
ip address 192.168.0.4 255.255.255.0
ip-help address 192.168.0.x 255.255.255.0 (watch gaurd ip address)
tagged 25-26
exit

vlan 4
name "VLAN 4"
no ip address
untagged 1-6
tagged 25-26
exit

vlan 5
name "VLAN 5"
no ip address
untagged 7-17
tagged 25-26
exit


Cisco 1841
--------------------

Current configuration : 1216 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname shimizu-Cisco
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$eomE$7R.KO87o.hwjCOSrDWHGZ/
enable password spc
!
no aaa new-model
ip cef

!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/0.1
description MMGNT-VLAN 10
encapsulation dot1Q 1 native
ip address 192.168.0.1 255.255.255.224
!
interface FastEthernet0/0.2
description VLAN -1
encapsulation dot1Q 2
ip address 192.168.0.33 255.255.255.224
!
interface FastEthernet0/0.3
description VLAN-2
encapsulation dot1Q 3
ip address 192.168.0.65 255.255.255.224
!
interface FastEthernet0/0.3
description VLAN-3
encapsulation dot1Q 4
ip address 192.168.0.97 255.255.255.224
!

interface FastEthernet0/0.4
description VLAN-4
encapsulation dot1Q 5
ip address 192.168.0.129 255.255.255.224
!

interface FastEthernet0/0.6
description VLAN-5
encapsulation dot1Q 6
ip address 192.168.0.161 255.255.255.224

!
interface FastEthernet0/1
ip address 192.168.0.10 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0/0
Shutdown
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password spc
login
!
scheduler allocate 20000 1000
end

Regards,
Eash



Shadow13
Respected Contributor

Re: VLAN configuration on 2510 and routing through Cisco 1841

what is the native vlan on cisco ? make sure that the port connected to cisco router from the 2510 switch is untagged on the native vlan configured on cisco.

and the gateway on the clients will be the ip address of each vlan configured on the cisco router.

I did not concentrate on the configuration you posted but the tagging is right.

eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Shadow,

Thanks for your assitance mate.

I have change config of switch 1 as follows so as to make sure that the port connected to cisco router from the 2510 switch is untagged on the native vlan configured on cisco.


snmp-server community "public" Unrestricted
vlan 10
name "MMGNT"
untagged 1-24
ip address 192.168.0.2 255.255.255.0
ip-help address 192.168.0.x 255.255.255.0 (watch gaurd ip address)
untagged 25
tagged 26
exit

Regarding and the gateway on the clients should I configure ip default-gateway for each lan to match with the ip address of the vlan configured on the cisco router.

Regards,
Easwar
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Dear All,

Any help on the mentioned configuration.
Josh Boyer
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Eash,

Your clients should have the corresponding ip address of the routers sub interface as a default gateway for example:

Client 1 (member of vlan 1):
Ip address: 192.168.0.35-62 (something in the range) 255.255.255.224
Default gateway: 192.168.0.33

Client 2 (member of vlan 2):
Ip address: 192.168.0.66-94 (something in the range) 255.255.255.224
Default Gateway: 192.168.0.65

And so on...

For the IP default gateway command on the switch you would want this is matching the ip address of the MGMT vlan sub-interface on the router which I think is 192.168.0.1. I don't think you can make multiple entries of the ip default gateway command on the switch.

I haven't been working with procurves to long so correct me if I'm wrong...members.
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Josh,

Thanks for your suggestion.

Should I configure 5 scope on the DHCP server for 5 LAN.
Josh Boyer
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi eash,

Yes if you want to use a single DHCP server to service all of your subnets(vlans) then you would create 5 scopes on your DHCP server one for each subnet(vlan). For example

Scope 1:

IP Address range: 192.168.0.35-->192.168.0.62 /27
Default Gateway: 192.168.0.33
DNS1: x.x.x.x
DNS2: x.x.x.x

Scope 2:

IP address range: 192.168.0.66-->192.168.0.94 /27
Default Gateway: 192.168.0.65
DNS1: x.x.x.x
DNS2: x.x.x.x

And so on...


You will then need to configure DHCP-Relay on your Cisco router:

on each sub-interface added the following:

ip helper-address x.x.x.x (the IP address of your DHCP server)

*note you dont need this command on the sub-interface that the DHCP server is natively a member of.

Please let me know if this answers your questions of if you need further help with this.
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Josh,

Thanks for the detailed reply and sorry for my delayed response.

Now the customer has changed the plan he wants stacking and all the three switches are connected as follows,

Switch A port 25 connected to router port 26 connected to Switch B on port 25 and port 26 is connected to Switch on port 25.

I have enabled stacking and I am able to see the other switches but dont see the port of those switches.The customer wants to configure 5 VLAN spread over the ports in all these swithes.

Please see the configuration.
; J9019B Configuration Editor; Created on release #Q.11.17

hostname "abc Switch-1"
snmp-server contact "xyz"
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address 192.168.0.2 255.255.255.0
exit
vlan 2
name "VLan-1"
no ip address
exit
vlan 3
name "VLAN-2"
no ip address
exit
stack commander "xyz"
stack auto-grab
stack member 1 mac-address 0026f15f1b00
stack member 2 mac-address 0026f15f9340

xyz Switch-1#

Thanks,
Eash
wants to c
Shadow13
Respected Contributor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Stacking in HP is not to combine the switch as 1 switch, it's only used to manage the switched through 1 IP address, but to configure them you need to configure each 1 seperatly
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Shadow,

Thanks for the reply.

The customer VLAN's are from 1 to 5 they dont want to change the VLAN number. So I thaought with stacking I will be able so see all the ports of the stack.

Anyway to do that.
Shadow13
Respected Contributor

Re: VLAN configuration on 2510 and routing through Cisco 1841

configure the same vlans on the other switches and tagged the upling ports between the switches in these vlans except vlan 1 which should be untagged, then untag the ports of the clients in the vlan where you want to assign to them
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi Shadow,

I tried and it did not work. Only the systems connected to the the first switch worked and were able to get the IP address from the the DHCP server which is configured on the router
The systems on the second and third switch were not getting connected please find below the configuration of the 3 switches and the router. The router is connected to the BB modem.
One other problem although the system on the first switch is getting the IP address but it is not able to reach the internet.

Please find the config of the three switches and the router.

Running configuration:

; J9019B Configuration Editor; Created on release #Q.11.17

hostname "switch-1"
ip default-gateway 192.168.0.202
snmp-server community "public" Unrestricted
vlan 1
name "MMGT"
untagged 25-26
ip address 192.168.0.201 255.255.255.248
no untagged 1-24
exit
vlan 2
name "VLAN2"
untagged 1-8
tagged 25-26
exit
vlan 5
name "VLAN5"
untagged 21-24
tagged 25-26
exit
vlan 6
name "VLAN6"
untagged 9-20
tagged 25-26
exit
stack commander "xyz"
stack auto-grab
stack member 1 mac-address 0026f15f9340
stack member 2 mac-address 0026f15f1b00

switch-1#

hostname "switch-2"
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
no ip address
tagged 25-26
no untagged 1-24
exit
vlan 3
name "VLAN3"
untagged 3-14
tagged 25-26
exit
vlan 4
name "VLAN4"
untagged 15-23
tagged 25-26
exit
vlan 5
name "VLAN5"
untagged 1-2
tagged 25-26
exit
vlan 6
name "VLAN6"
untagged 24
tagged 25-26
exit
stack join 0026f15d6aa0

switch-2#
hostname "switch-2"
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
no ip address
tagged 25-26
no untagged 1-24
exit
vlan 3
name "VLAN3"
untagged 3-14
tagged 25-26
exit
vlan 4
name "VLAN4"
untagged 15-23
tagged 25-26
exit
vlan 5
name "VLAN5"
untagged 1-2
tagged 25-26
exit
vlan 6
name "VLAN6"
untagged 24
tagged 25-26
exit
stack join 0026f15d6aa0

switch-2#

Running configuration:

; J9019B Configuration Editor; Created on release #Q.11.17

hostname "switch-3"
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 18-24,26
no ip address
tagged 25
no untagged 1-17
exit
vlan 2
name "VLAN2"
untagged 7-17
tagged 25
exit
vlan 5
name "VLAN5"
untagged 1-6
tagged 25
exit
stack join 0026f15d6aa0

switch-3#

sh run
Building configuration...

Current configuration : 2420 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zeroip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.19 192.168.0.21
ip dhcp excluded-address 192.168.0.83
ip dhcp excluded-address 192.168.0.144
ip dhcp excluded-address 192.168.0.63
!
ip dhcp pool VLAN2
network 192.168.0.0 255.255.255.224
default-router 192.168.0.1
dns-server 202.148.202.3
lease 2
!
ip dhcp pool VLAN3
network 192.168.0.32 255.255.255.224
default-router 192.168.0.33
dns-server 202.148.202.3
lease 2
!
ip dhcp pool VLAN4
network 192.168.0.64 255.255.255.224
default-router 192.168.0.65
dns-server 202.148.202.3
lease 2
!
ip dhcp pool VLAN5
network 192.168.0.96 255.255.255.224
default-router 192.168.0.97
dns-server 202.148.202.3
lease 2
!
ip dhcp pool VLAN6
network 192.168.0.128 255.255.255.224
default-router 192.168.0.129
dns-server 202.148.202.3
lease 2
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description MMGNT-VLAN 1
encapsulation dot1Q 1 native
ip address 192.168.0.202 255.255.255.248
no snmp trap link-status
!
interface FastEthernet0/0.2
description VLAN -2
encapsulation dot1Q 2
ip address 192.168.0.1 255.255.255.224
no snmp trap link-status
!
interface FastEthernet0/0.3
description VLAN-3
encapsulation dot1Q 3
ip address 192.168.0.33 255.255.255.224
no snmp trap link-status
!
interface FastEthernet0/0.4
description VLAN-4
encapsulation dot1Q 4
ip address 192.168.0.65 255.255.255.224
no snmp trap link-status
!
interface FastEthernet0/0.5
description VLAN-5
encapsulation dot1Q 5
ip address 192.168.0.97 255.255.255.224
no snmp trap link-status
!
interface FastEthernet0/0.6
description VLAN-6
encapsulation dot1Q 6
ip address 192.168.0.129 255.255.255.224
no snmp trap link-status
!
interface FastEthernet0/1
ip address 192.168.0.209 255.255.255.248
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.210
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router#

eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi All,

REquest you help to go through the config and let me know what is wrong.
1.Why systems in the second and third switch not coming on the LAN
2.Allthough systems in the first switch was on the LAN they were not able to reach the internet.

Regards,
Eash
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi all,

Any feed back on the configs

Regards,
Eash
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi All,

Please help on the config.

Regards,
Eash.
AndeasBehncke
Occasional Visitor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi eash,

1. Check your configuration of the native vlan, this need the components to "talk".
2. Did you can ping any System in the WAN or Internet? The default route on your Router shows an address, that i can not refer to your global IP configuration.

Greets
eash
Advisor

Re: VLAN configuration on 2510 and routing through Cisco 1841

Hi andeas,

Thanks for the support.

The default route on the router is pointing to the customer's BB router and IP address on that device is 192.168.0.210. The present config on is the BB router is default gateway for the LAN and after the 2510 switch introduction the router sits between the 2510 and BB router.

Regarding your suggestion of native LAN it was not sure what you were referring to.

Regards,
Easwar.
Shadow13
Respected Contributor

Re: VLAN configuration on 2510 and routing through Cisco 1841

the uplink ports between the switches should be untagged in VLAN 1 specially that the 1st switch uplink ports to the 2nd switch is untagged and on the 2nd switch they are tagged, this will lead to both switches not able to communicate to each other and of course the other switches also that connect through the 2nd switch will not be able to reach the 1st switch in VLAN 1

untag all the uplink ports in VLAN 1 plz