Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN dot1q with 3 VLANs between a CISCO Router and HP procurve 2524 switch

Dmitry_23
Occasional Visitor

VLAN dot1q with 3 VLANs between a CISCO Router and HP procurve 2524 switch

Hi,
I'm trying to put a link with three VLANs between HPprocurve switch and Cisco as5350, I need make routed vlans, but don't do this.

FastEthernet0/0 (cisco) <->
22 port HP

****
5350
****
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description #### switch ####
encapsulation dot1Q 1 native
ip address 10.25.0.1 255.255.255.252 secondary
!
interface FastEthernet0/0.2
description #### VLAN 2 ####
ip address 192.168.0.1 255.255.255.0 secondary

encapsulation dot1Q 2
!
interface FastEthernet0/0.3
description #### VLAN 3 ####
encapsulation dot1Q 3
ip address 192.168.1.1 255.255.255.0

******
hp2524
******
hostname "sw"
max-vlans 24
time timezone 3
time daylight-time-rule None
cdp run
ip default-gateway 10.25.0.1
ip timep manual 192.5.41.209
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address 10.25.0.2 255.255.255.248
exit
vlan 2
name "vlan 2"
tagged 22,24
no ip address
exit
vlan 3
name "vlan 3"
tagged 22-23
no ip address
exit
no aaa port-access authenticator active

Not Ping beetween cisco and PC (port 23) to addr 192.168.1.2
and not Ping beetween cisco and PC (port 24) to addr 192.168.0.2

what's wrong? please help.
1 REPLY
Ron Kinner
Honored Contributor

Re: VLAN dot1q with 3 VLANs between a CISCO Router and HP procurve 2524 switch

You are trying to trunk out to your PCs. No need for tagging on the ports going to PC. I assume the router is on port 22. Try:

vlan 1
name "DEFAULT_VLAN"
untagged 1-22
ip address 10.25.0.2 255.255.255.248
exit
vlan 2
name "vlan 2"
untagged 24
tagged 22
no ip address
exit
vlan 3
name "vlan 3"
untagged 23
tagged 22
no ip address
exit

Ron