Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN question - best way to set this up?

ript73
Occasional Contributor

VLAN question - best way to set this up?

Hello all. Been reading up on VLANs as I've never messed with them. I've attached our network diagram. The reason for 2 internet connections is they are in different buildings and it's a separate company, however they still need to communicate with each other over the LAN.

My question is, what is the best way to set this up?

Thanks for your time!
2 REPLIES
ript73
Occasional Contributor

Re: VLAN question - best way to set this up?

I've started to configure some things and have not got it working quite yet. Below are the configs for the 2 main switches. The first is our main routing switch. Thanks for your help!

Running configuration:

; J8697A Configuration Editor; Created on release #K.13.68

hostname "ProCurve Switch 5406zl"
module 1 type J8702A
module 2 type J8702A
module 3 type J8705A
module 4 type J8705A
module 5 type J8705A
interface B6
speed-duplex auto-10-100
exit
interface B10
speed-duplex auto-10-100
exit
ip default-gateway 192.168.35.50
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C20,C22-C24,D1-D24,E1-E24
ip address 192.168.32.1 255.255.252.0
no untagged C21
exit
vlan 100
name "VLAN100"
untagged C21
ip helper-address 192.168.1.2
ip address 192.168.1.252 255.255.255.0
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
no ip ssh
snmp-server community "public" Unrestricted
snmp-server host 192.168.35.23 "public"
snmp-server host 192.168.35.33 "public"
snmp-server host 192.168.35.34 "public"
snmp-server contact "IT Department" location "Server Room"

Running configuration:

; J8697A Configuration Editor; Created on release #K.14.41

hostname "ProCurve Switch 5406zl"
module 1 type J8702A
module 2 type J8702A
module 3 type J8705A
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C21,C23-C24
no untagged C22
no ip address
exit
vlan 100
name "VLAN100"
untagged C22
ip address 192.168.1.254 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.1.1
snmp-server community "public" unrestricted
selles
Occasional Visitor

Re: VLAN question - best way to set this up?

i guess you'd better tag all vlans in your uplinks ports

vlan 1
no untagged c21
vlan 100
no untagged c21

same on other switch

so all traffic is properly tagged between the 2 switches

let us know when it works
and otherwise what are your troubles