Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN's in Hp procurve 2524 along with Cisco 3550-12G, and Cisco 2950

mbreddy
Occasional Visitor

VLAN's in Hp procurve 2524 along with Cisco 3550-12G, and Cisco 2950

Hi Guy's
I am looking for help on the following problem.

Existing network
Cisco 3550-12G L3 Switch with 10 Gigabit SX ports
5 * Cisco 2950 L2 Switch with 2 giga SX ports

We have created 10 VLAN's on L3 Switch and things are working fine

Recently we bought 10 Hp Procurve 2524 Switches with GigaBit SX modules.
We want to integrated these new Switches in to the existing network including using the same VLAN's Etc.

Can any one suggest me the config details to be modified or created on both HP Procurve 2524 and Cisco 3550 -12G switches

Thanks in Advance


1 REPLY
Jason Scott
Regular Advisor

Re: VLAN's in Hp procurve 2524 along with Cisco 3550-12G, and Cisco 2950

Hiya,

Firstly you'll want to make sure your Cisco kit is using 802.1Q for vlan tagging rather than ISL.

Secondly, on the HP kit, if for example port 25 is an uplink and the other ports are in a specific vlan (113 in this example) you will want something similar to this:

vlan 1
name "DEFAULT_VLAN"
no untagged 1-24
untagged 25

vlan 113
name "VLAN113"
untagged 1-24
tagged 25

If your switch had users from multiple vlans you would need to tag the uplink ports with those vlans:

vlan 1
name "DEFAULT_VLAN"
no untagged 1-24
untagged 25

vlan 113
name "VLAN113"
untagged 1-15
tagged 25

vlan 115
name "VLAN115"
untagged 16-24
tagged 25

Your vlan number should match the vlan number used on the cisco switches. The name doesn't have to match.

With 802.1Q, the switch tags frames to identify them as belonging to a particular vlan and then strips the tags whenever the frame is destined for a port that is untagged (usually a client PC).

Not sure if I've gone to basic there or not depending on your level of knowledge. Hope this helps though.

On your Cisco kit, for the port that uplinks to the HP kit you will want something like the following:

interface gigabitethernet 1
switchport mode trunk
switchport trunk encapsulation dot1q

Regards,