Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN with 2824

Ross Yendle
Occasional Visitor

VLAN with 2824

Hi,

I'm about to VLAN my current production network, but before I do that I thought that I would setup a lab LAN with similar equipment to make sure that I have the configuration correct.

For the Lab I've set up a 2824 and a 2524 switch, trunked with 4 computers setup between the two switches, and am using these to test connectivity. I can setup the VLANs and can ping accross the trunk to the computer on the other switch, but even though I've got IP routing enabled I can't ping between VLANs or even ping the VLAN interface on the switch. The 2824's are meant to auto learn the routes, but it doesn't seem to be.

Can anyone advise? Thanks in advance...
11 REPLIES
Jeff Carrell
Honored Contributor

Re: VLAN with 2824

hmmm...can you show us your 2824 & 2524 configs?

as long as you have ip addr on each of the vlans on the 2824 and have 'ip rounging' enabled, then any device on any of the vlans (with appropriate ip addr/gateway config) should be able to ping...

then to move moe than 1 vlan across switch lonks, the connecting port(s) need to be 'tagged' into each of the vlans...

hth...jeff
serpel
Trusted Contributor

Re: VLAN with 2824

hi,
can you give us a show run and what is the default gateway for the clients?
ben
Ross Yendle
Occasional Visitor

Re: VLAN with 2824

Attached are the configs...

I've been playing with the ARP settings trying to figure out why it wasn't routing. But the default gateways for the clients are the same as the VLAN interface address. All machine firewalls are off.

thanks for your help.
serpel
Trusted Contributor

Re: VLAN with 2824

hi,
why do you need those to routes:
ip route 168.48.4.0 255.255.255.0 168.48.1.1
ip route 168.48.3.0 255.255.255.0 168.48.1.1
i don't see a vlan with 168.48.1.0/24
with your cofiguration the subnet 168.48.1.0 can't be reached.
you might want a route to the default gateway
ip route 0.0.0.0 0.0.0.0 168.48.2.1
cos the default gateway configuration:
ip default-gateway 168.48.2.1
is not working if you enable ip routing.

ben
cenk sasmaztin
Honored Contributor

Re: VLAN with 2824

2824 switch make routing other 2524 switch only L2 unable routing therefore no need ip address you can assign ip address only default vlan (for managemet)
connect between two switch vlan 1 untag all other vlan tag port please test my config



Running configuration:

; J4903A Configuration Editor; Created on release #I.10.67

hostname "ProCurve Switch 2824"
interface 22
no lacp
exit
trunk 22 Trk1 Trunk*******no need
ip default-gateway 168.48.2.1
ip routing
ip irdp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-2,4-12,14-21,22,23-24,
ip address 168.48.2.2 255.255.0.0
no untagged 3,13
ip proxy-arp
ip irdp
ip irdp broadcast
exit
vlan 10
name "Test VLAN 1"
untagged 13
ip address 168.48.3.1 255.255.255.0
tagged 22****************
ip proxy-arp
ip irdp
ip irdp broadcast
ip irdp maxadvertinterval 500
exit
vlan 20
name "Test VLAN 2"
untagged 3
ip address 168.48.4.1 255.255.255.0
tagged 22*****************
exit
spanning-tree


*************************************************************
Running configuration:

; J4813A Configuration Editor; Created on release #F.05.69

hostname "HP ProCurve Switch 2524"
cdp run
interface 26
no lacp
exit
trunk 26 Trk1 Trunk****no need******
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-2,4-12,14-25,26
ip address 168.48.2.10 255.255.0.0
no untagged 3,13
exit
vlan 10
name "Test VLAN 1"
untagged 3
tagged 26
exit
vlan 20
name "Test VLAN 2"
untagged 13
tagged 26
exit

spanning-tree



cenk

Ross Yendle
Occasional Visitor

Re: VLAN with 2824

Thank you both for your replies. The main issue I'm having with this isn't with the main config of the switch, it's that the 2824 isn't doing the routing that I believe it should. From a workstation on 168.48.4.10/24 I can't even ping the other VLAN interface (168.48.3.1) on the same switch. Without setting static routes is there any suggestions? I thought that the 2824 was meant to have basic routing and be able to learn routes?
cenk sasmaztin
Honored Contributor

Re: VLAN with 2824

plese check

168.48.4.10/24 ip pc

default gatewat must be 192.168.4.1

and conncet vlan 20 untag port for example interface 3
cenk

cenk sasmaztin
Honored Contributor

Re: VLAN with 2824

interface 3 on 2824 switch
cenk

cenk sasmaztin
Honored Contributor

Re: VLAN with 2824

ip routing enable on switch each vlan interface become router ethernet interface

so you want make routing on router must be ethernet interface pc default gateway address

there fore vlan ip address must be default gateway address vlan member pc


cenk

Ross Yendle
Occasional Visitor

Re: VLAN with 2824

Hi,
Yes the PC connected to port 3 on the 2824 has the default g/w set to 168.48.4.1
And according to the config that you supplied port 3 is untagged for vlan 2, but still not able to ping 168.48.3.1
cenk sasmaztin
Honored Contributor

Re: VLAN with 2824

please connect in vlan 10 (interface 13) one pc

ip address 168.48.3.2 /24 default gateway
168.48.3.1

and retest
cenk