Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLANS over WLAN

Björn Andreas Höfer
Occasional Advisor

VLANS over WLAN

Hi there,

I have a ProCure Wireless Edge Controller(J9001A) with some EE220 radios connected to it (J9005A).

My Problem:
I'm currently serving one wireless lan on the default VLAN 1, without any trouble.

Now I wanted to create a WLAN-SSID on an other VLAN - lets say on VLAN 5.

I've configured the the WLAN-Controller to serve as DHCP-Server for the VLAN 9, tagged all links (CDP, CUP on the 5304XL, other ports which point out to the networks, up- and downlinks on others switches...).

But when I enter the WLAN with an smartphone or laptop, I don't get an ip address.

If i connect the laptop to a wired port (with an static configured ip address) which is untagged in the VLAN (on the same switch, as the Radio Port) I get an IP-Address very fast (from the Wireless Controller) and I can ping all hosts (gateway, wireless controller...).

If I connect the laptop to the wlan and start wireshark (network sniffer) i can see that my laptop shouts out some DHCP Requests - and get one back, but it seems like he don't accepts them.

I've also tried another dhcp server (which is included in the Fortigate Firewall) - same effect - no ip-lease...

Does anybody have a clue why I don't get an address??
5 REPLIES
Pieter 't Hart
Honored Contributor

Re: VLANS over WLAN

>>>
- static configured ip address
- I get an IP-Address very fast (from the Wireless Controller)
<<<
there is some contradiction here
do you have static address or dhcp configured?
Pieter 't Hart
Honored Contributor

Re: VLANS over WLAN

also check if this is a typo, or do you really mean vlan5 and vlan9?

>>>
Now I wanted to create a WLAN-SSID on an other VLAN - lets say on VLAN 5.

I've configured the the WLAN-Controller to serve as DHCP-Server for the VLAN 9,
<<<
Björn Andreas Höfer
Occasional Advisor

Re: VLANS over WLAN

Problem solved by myself - 40 Minutes ago...

The Problem was that the CDP Port was wrong configured on the 5304XL.

Config which works for me now:
Port: CDP CUP
VLAN 2100 T T
VLAN 1 (Mgmt) U U
VLAN 5 (Misc) No T

Strange behavior - but it looks operational now - i will test the configuration with a few other combinations...
Björn Andreas Höfer
Occasional Advisor

Re: VLANS over WLAN

I've tried both:
with dhcp i did'nt get an ip address, so i configured a static ip to look if it works.

Yes, it was a typo, meant vlan 5

Both did'nt work - but now it worked out with the CDP port - except the management web-site... but i hope i'll get done with this in a short time...
Björn Andreas Höfer
Occasional Advisor

Re: VLANS over WLAN

Found the solution by myself - it was a problem with the cdp and cup port.