Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLANs, ACLs. Problems with outbound web traffic.

ssc_2
Occasional Visitor

VLANs, ACLs. Problems with outbound web traffic.

Hi All,

I'm currently trying to configure ACLs on inbound traffic to two different routed VLANs. VLAN4 is my Unified Communications VLAN and I have applied all the rules as per config below and everything is working as expected. I.e. incoming traffic hits OCS and outbound traffic (web and to SIP 5061) works. Actually, the only initial problem I had was with outbound web and SIP traffic.. but as soon as I added following ACE that started to work as well:

100 permit tcp 0.0.0.0 255.255.255.255 212.140.38.8 0.0.0.7 gt 1024 established

BUT, here's my problem. I have a second VLAN with proxy servers (VLAN2) and I have created a separate ACL as per below. As soon as I add the ACL to VLAN2 however, outbound access from my Unified Communications VLAN stops working. Everything except outbound traffic from my proxy VLAN works as well but outbound web browsing etc won't work.

Internet gateway is attached to VLAN1. The Switch is a Procurve 3500. Any ideas? Any help appreciated!


Running configuration:

; J9471A Configuration Editor; Created on release #K.14.41

hostname "ProCurve Switch 3500-24-PoE"
ip access-list extended "Proxy-Inbound"
10 permit tcp 0.0.0.0 255.255.255.255 212.140.38.112 0.0.0.15 eq 443
20 permit tcp 0.0.0.0 255.255.255.255 212.140.38.112 0.0.0.15 eq 80
30 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 587
40 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 110
50 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 143
60 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 995
70 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 993
80 permit tcp 0.0.0.0 255.255.255.255 212.140.38.120 0.0.0.0 eq 25
90 permit tcp 0.0.0.0 255.255.255.255 212.140.38.116 0.0.0.0 eq 53
100 permit udp 0.0.0.0 255.255.255.255 212.140.38.116 0.0.0.0 eq 53
110 permit udp 0.0.0.0 255.255.255.255 212.140.38.116 0.0.0.0 eq 4500
120 permit udp 0.0.0.0 255.255.255.255 212.140.38.116 0.0.0.0 eq 500
130 permit tcp 0.0.0.0 255.255.255.255 212.140.38.116 0.0.0.0 eq 1723
140 permit tcp 0.0.0.0 255.255.255.255 212.140.38.112 0.0.0.15 gt 1024 established
exit
ip access-list extended "OCS-Inbound"
10 permit tcp 0.0.0.0 255.255.255.255 212.140.38.11 0.0.0.0 eq 443
20 permit tcp 0.0.0.0 255.255.255.255 212.140.38.11 0.0.0.0 eq 5061
30 permit tcp 0.0.0.0 255.255.255.255 212.140.38.12 0.0.0.0 eq 443
40 permit tcp 0.0.0.0 255.255.255.255 212.140.38.13 0.0.0.0 eq 443
50 permit udp 0.0.0.0 255.255.255.255 212.140.38.13 0.0.0.0 eq 3478
60 permit tcp 0.0.0.0 255.255.255.255 212.140.38.13 0.0.0.0 range 50000 59000
70 permit udp 0.0.0.0 255.255.255.255 212.140.38.13 0.0.0.0 range 50000 59000
80 permit tcp 212.140.32.98 0.0.0.0 212.140.38.10 0.0.0.0
90 permit udp 212.140.32.98 0.0.0.0 212.140.38.10 0.0.0.0
100 permit tcp 0.0.0.0 255.255.255.255 212.140.38.8 0.0.0.7 gt 1024 established
exit
module 1 type J94bbA
interface 1
name "Xtreme-Internet"
flow-control
speed-duplex 10-full
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
ip default-gateway 212.140.33.1
ip routing
vlan 1
name "EXT_VLAN"
untagged 1-2
ip address 212.140.33.45 255.255.255.0
no untagged 3-24
exit
vlan 2
name "FEPROXY_VLAN"
untagged 3-6
ip address 212.140.38.113 255.255.255.240
exit
vlan 3
name "BEPROXY_VLAN"
untagged 7-10
ip address 192.168.2.1 255.255.255.0
exit
vlan 4
name "FEUC_VLAN"
untagged 11-14
ip address 212.140.38.9 255.255.255.248
ip access-group "OCS-Inbound" out
exit
vlan 5
name "BEUC_VLAN"
untagged 15-18
ip address 192.168.3.1 255.255.255.0
exit
vlan 6
name "BEGW_VLAN"
untagged 24
ip address 192.168.1.3 255.255.255.0
exit
vlan 7
name "MGMT_VLAN"
untagged 20
ip address 192.168.250.9 255.255.255.0
ip address 10.10.33.99 255.0.0.0
exit
vlan 8
name "TMP_VLAN"
untagged 21-23
no ip address
exit
vlan 9
name "WEBFE_VLAN"
untagged 19
no ip address
exit
filter source-port named-filter "drop-incoming-inet" drop 7-10,15-24
filter source-port 1-2 named-filter "drop-incoming-inet"
filter source-port named-filter "drop-outgoing-fepr" drop 7-24
filter source-port 3-6 named-filter "drop-outgoing-fepr"
filter source-port named-filter "drop-outgoing-bepr" drop 1-6,11-23
filter source-port 7-10 named-filter "drop-outgoing-bepr"
filter source-port named-filter "drop-outgoing-feuc" drop 3-10,15-24
filter source-port 11-14 named-filter "drop-outgoing-feuc"
filter source-port named-filter "drop-outgoing-beuc" drop 1-14,19-23
filter source-port 15-18 named-filter "drop-outgoing-beuc"
filter source-port named-filter "drop-outgoing-gw" drop 1-6,11-14,19-23
filter source-port 24 named-filter "drop-outgoing-gw"
ip route 0.0.0.0 0.0.0.0 212.140.33.1
ip route 192.168.250.0 255.255.255.0 vlan 1 distance 10
snmp-server community "public" unrestricted
management-vlan 7