Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VLan problem HP 2848

tobias Wester
Occasional Contributor

VLan problem HP 2848

This is my config.
i use the 2848 as a backboneswith.

the problem is that klients connected to VLan2 dont work.

10.10.10.221 is our hardware-VPN
10.10.10.220 is our FW

i am able to ping the VLN1 from VLan2 but i seem that Vlan2 dont get routed.

can you see any problem with the config.

Backbone# write terminal
; J4904A Configuration Editor; Created on release #I.08.98

hostname "Backbone"
snmp-server contact "Systemadministrator"
snmp-server location "Configura serverroom"
time timezone 1
interface 36
disable
exit
interface 37
disable
exit
interface 38
disable
exit
interface 39
disable
exit
interface 40
disable
exit
interface 41
disable
exit
interface 42
disable
exit
interface 43
disable
exit
interface 44
disable
exit
ip default-gateway 10.10.10.220
ip routing
timesync sntp
snmp-server community "public" Unrestricted
vlan 1
name "Servers 10"
untagged 1-24,36-48
ip address 10.10.10.219 255.255.255.0
no untagged 25-35
exit
vlan 2
name "Klients 12"
untagged 25-35
ip address 10.10.12.219 255.255.255.0
ip helper-address 10.10.10.218
ip helper-address 10.10.10.213
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
ip route 0.0.0.0 0.0.0.0 10.10.10.220
ip route 10.10.11.0 255.255.255.0 10.10.10.221
ip route 10.10.14.0 255.255.255.0 10.10.10.221
ip route 172.17.4.0 255.255.255.0 10.10.10.221

regards Tobias
3 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: VLan problem HP 2848

Hi

On your Firewall you should add the way back for Vlan2, by adding a static route for Vlan2 and the gateway for it is Vlan1 IP on the 2800 switch.

Example:

ip route 10.10.12.219 255.255.255.0 10.10.10.219

I think you can do it from the Web interface for the Firewall.

And i believe you should add also another route for Vlan2 on the VPN Box.

Good Luck !!!
Science for Everyone
tobias Wester
Occasional Contributor

Re: VLan problem HP 2848

Thanx.

strange thing.

When I put a client with the ip address 10.10.12.10 on vlan2 I am not able to ping my self.
But I am able to ping vlan1.
Mohieddin Kharnoub
Honored Contributor

Re: VLan problem HP 2848

Hi

IP Routing is enabled on the switch, so if you just disconnect the Firewall with the IP (10.10.10.220) you still should be ping devices on Vlan1 or Vlan2, because the switch is routing between these 2 Vlans.

Now any traffic goes out of the switch to the default route (to 10.10.10.220), it won't come back because the device should have a static route entry for this Vlan.

Sorry in the first post i typed the command wrong even i explained it correct :), it should be:

ip route 10.10.12.0 255.255.255.0 10.10.10.219

Or from the Web interface of the firewall,

Destination Network:10.10.12.0
Mask:255.255.255.0 or /24
Next Hop (or Gateway):10.10.10.219

Good Luck !!!
Science for Everyone