Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

VRRP Issue

SOLVED
Go to solution

VRRP Issue

I have 2 3500yl-48Gs and 1 2524 switch. Following the documentation for VRRP configuration I have configured everything as shown in the attachment.

The problem is when I disconnect router1, router2 becomes the master however it doesn't take over being the master's IP address.

Any ideas?

router1 config

hostname "ROUTER1"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-48
ip address dhcp-bootp
exit
vlan 119
name "V119"
ip address 10.119.1.1 255.255.0.0
tagged 1
exit
router vrrp
vlan 119
vrrp vrid 1
owner
virtual-ip-address 10.119.1.1 255.255.0.0
priority 255
enable
exit
exit


router2 config

hostname "ROUTER2"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-48
ip address dhcp-bootp
exit
vlan 119
name "V119"
ip address 10.119.1.2 255.255.0.0
tagged 1
exit
router vrrp
vlan 119
vrrp vrid 1
owner
virtual-ip-address 10.119.1.1 255.255.0.0
enable
exit
exit
6 REPLIES
Matt Hobbs
Honored Contributor

Re: VRRP Issue

On Router 2 it looks as though you've set it to 'owner' as well? This should be set to 'backup'.
Mohieddin Kharnoub
Honored Contributor

Re: VRRP Issue

Or you can add to Router2:

priority 100

after you change owner to backup
Science for Everyone

Re: VRRP Issue

Thank-you but that owner line isn't there. My copy and paste was incorrect.

When I do a show vrrp stat it clearly indicates router2 as the backup. When the cable is pulled to router1 then show vrrp stat indicates that router2 is the master.

Matt Hobbs
Honored Contributor

Re: VRRP Issue

Peter, assuming you're running K.11.17 - your configuration looks okay to me so I'd recommend you contact HP support direct about it. Otherwise if you can attach some of the 'show vrrp' commands from both switches before and after the failover it would be interesting to see.

I'm guessing that to test you have one host on the 2524 running a ping to 10.119.1.1, you then pull the cable to router 1 and it can no longer reach that address?
Mohieddin Kharnoub
Honored Contributor

Re: VRRP Issue

On the 2524, have you created Vlan119 and tag it to the ports connected to both of the 3500, and untag vlan 1.

Would you try to set the Priority of the backup router to 100(default), and try to ping from any host connected to 2524, then disconnect Router1.
Science for Everyone
Matt Hobbs
Honored Contributor
Solution

Re: VRRP Issue

It looks like this may have been related to the newer thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1034049

http://www.faqs.org/rfcs/rfc3768.html

6.4.3. Master

While in the {Master} state the router functions as the forwarding router for the IP address(es) associated with the virtual router.

While in this state, a VRRP router MUST do the following:

- MUST NOT accept packets addressed to the IP address(es) associated with the virtual router if it is not the IP address owner.


1.3. Definitions

IP Address Owner -- The VRRP router that has the virtual router's IP address(es) as real interface address(es). This is the router that, when up, will respond to packets addressed to one of these IP addresses for ICMP pings, TCP connections, etc.