Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan + ACL = HELP

agra
Occasional Contributor

Vlan + ACL = HELP

hi everybody...

I have hp procurve 5406zl works as a layer3 switch,and trying to create a ACL to control the traffic…..etc
The following is configuration that I made:


module 1 type J8706A

interface A14
name "N-b"
exit
interface A17
name "N-c"
exit
trunk A13 Trk13 Trunk
trunk A14 Trk14 Trunk
trunk A15 Trk15 Trunk
trunk A16 Trk16 Trunk
trunk A17 Trk17 Trunk
trunk A18 Trk18 Trunk
trunk A19 Trk19 Trunk
trunk A20 Trk20 Trunk
trunk A21 Trk21 Trunk
trunk A22 Trk22 Trunk
trunk A24 Trk24 Trunk
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A10-A12,A23,Trk13-Trk22,Trk24
ip address dhcp-bootp
no untagged A1-A9
ip igmp
exit
vlan 11
name "NB"
untagged A14
ip address 192.168.1.2 255.255.255.128
ip address 192.168.1.150 255.255.255.128
tagged Trk14
ip igmp
exit
vlan 14
name "NC"
untagged A17
ip address 192.168.4.2 255.255.255.128
ip address 192.168.4.150 255.255.255.128
tagged Trk17
ip igmp
exit

what I want is the following

subnets with 192.168.1.2 and 192.168.4.2 should communicate with each other.
subnets with 192.168.1.200 and 192.168.4.200 should communicate with each other and
communicate with DC-DNS server which is located in the 192.168.1.2 subnet
with ip 192.168.1.11

But the ACL am writing is not working at all iv tryed in many many ways, any ideas.
2 REPLIES
Tore Valberg
Trusted Contributor

Re: Vlan + ACL = HELP

Hi

I do not see any ACL's in your config. But i doo see some strange trunk configuration.

Maybe you are confusing trunks with Cisco trunks? In procurve trunks are link aggregation not "vlan trunking".

Both vlan 11 and 14 only have 1 port as member.

Also i would reccomend you to separate the subnets into separate vlans, the you can configure and assign ACL's to the vlan to controle access.

Example:
vlan 11
name "NB"
untagged A14
ip address 192.168.1.2 255.255.255.128
ip address 192.168.1.150 255.255.255.128
tagged Trk14

Here only port A14 is part of vlan 11. As trk14 and port 14 are the same port it can't be tagged and untagged at the same time in the same vlan.
So in Reality no traffic will flow on vlan 11 as it only have 1 port as untagged member. And same with vlan 14.

I would reccomend you to have a look in the Management and configration Guide for vlan configuration, and the Access Security Guide for ACl configuration.

http://www.hp.com/rnd/support/manuals/5400zl.htm

Hope this helps

Tore
agra
Occasional Contributor

Re: Vlan + ACL = HELP

ohh, am very sory iv posted a wrong config,
I'll explain a bit about it:

1- from every L2 switch to the 5406, we have one cable connected to a one port.

2- on every L2 sw we have 2 vlans (Vlan g + Vlan K).

3- every Vlan g should be able to comunicate with all Vlan g on all L2 SW, the same for Vlan k.


=======================================

now for the 5406 :

vlan 14
name "g14"
untagged A2
ip address 192.168.4.2 255.255.255.128
tagged Trk14
ip igmp
exit
vlan 148
name "k14"
ip address 192.168.4.245 255.255.255.128
tagged Trk14
exit
vlan 18
name "g18"
untagged A5
ip address 192.168.18.2 255.255.255.128
tagged Trk18
ip igmp
exit
vlan 188
name "k18"
ip address 192.168.18.245 255.255.255.128
tagged Trk18
exit
DC-DNS server which is located in the 192.168.4.2 subnet
with ip 192.168.4.1

I hope its clear, again am so sorry for posting the something wrong?