Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan Ipaddress

SOLVED
Go to solution
jwc1972
Advisor

Vlan Ipaddress

Hello

Trying to setup 4 Vlan
Vlan 1
ipaddress 10.22.30.0 255.255.255.0
i keep getting this error message Invalid Input address, I don't understand why?

Cheers
9 REPLIES
showneek
Respected Contributor

Re: Vlan Ipaddress

Hello, I think there should be space between ip and address commands... "ip address"

Cheers
jwc1972
Advisor

Re: Vlan Ipaddress

Good Spot
Nope no luck
vlan 30
ip address 10.22.30.0 255.255.255.0


Cheers
showneek
Respected Contributor

Re: Vlan Ipaddress

Oh this should work... What kind of switch do you use? Are you in VLAN context? Can you post whole CLI output when you try to configure IP address?
jwc1972
Advisor

Re: Vlan Ipaddress

Hello
Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "Switchoffice"
module 1 type J9147A
mirror-port 1
ip routing
vlan 1
name "Lan"
untagged 1-12
ip address 192.168.1.221 255.255.255.0
tagged 48
no untagged 13-47
exit
vlan 100
name "DMZ"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
vlan 20
name "Voip"
untagged 13-24
ip address 192.168.42.1 255.255.255.0
exit
vlan 30
name "UP Lan"
untagged 25-36
no ip address
exit
interface 40
monitor
exit


its the UP Lan i need adding 10.22.30.0 /24
showneek
Respected Contributor
Solution

Re: Vlan Ipaddress

Can't see anything why this address shouldn't be configured on vlan 30.

So this command does not work?

Switchoffice(config)# vlan 10 ip address 10.22.30.0 255.255.255.0

There is nothing related in release notes to this error too?

Try to configure address via setup interface or web interface.
cenk sasmaztin
Honored Contributor

Re: Vlan Ipaddress

hi

10.22.30.0 255.255.255.0 address

there is no ip address this address network address

unable assign vlan or other ip interface

for example this address unable assign pc nic or router interface

you can choose one address your 10.22.30.0/24 network for example 10.22.30.1 and assign vlan interface
cenk

cenk sasmaztin
Honored Contributor

Re: Vlan Ipaddress

showneek
Respected Contributor

Re: Vlan Ipaddress

Ohh, sorry... Of course, I overlooked the zero at the end of the address... Long day :(
jwc1972
Advisor

Re: Vlan Ipaddress

Cheers for the Answers

So the first ip address will be 10.22.30.1 /24 so the range is 10.22.30.1 to .254 I thought i had seen the address start with 10.22.30.0 /24

Excellent answers

Cheers