Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan and DHCP problem after software upgrade

JeffKWI
Occasional Advisor

Vlan and DHCP problem after software upgrade

We recently performed some upgrades to "preferred software" on our edge switches, and are now having problems passing DHCP traffic accross Vlans. Our DHCP serves out address to our PCs and VoIP Phones. PCs reside on Vlan60 and phone on Vlan61.

Our DHCP server currently gives out 10.1.60.xxx addresses on Vlan60 and 10.1.61.xxx addresses on Vlan61. This currently works (PCs and Phones) on the core switch, and but stopped working on our edge switch after the sofware upgrade on the edges. The PC will get a .60 address, but the VoIP phones will never get a .61 address.

Below is information on the swtiches on how the ports in question are tagged. I appreciate any help and suggestions on what's wrong.

Core Switch
------------
Model: 5406zl
ROM: K.12.21
SW Version: K.14.60

Port A5: DHCP Server (10.1.60.7)
Vlan1: No
Vlan60: Untagged
Vlan61: Tagged

Port A21: Link to 3500yl Edge Switch
Vlan1: Untagged
Vlan60: Tagged
Vlan61: Tagged

Vlan61: IP Helper enabled and pointing to 10.1.60.7

Edge Switch
------------
Model: 3500yl-48G
ROM: K15.10
SW Version: K.15.02.0005

Port 48: Link to 5406zl Core Switch
Vlan1: Untagged
Vlan60: Tagged
Vlan61: Tagged

Ports 1-47: PC & VoIP Phone
Vlan1: No
Vlan60: Untagged
Vlan61: Tagged
3 REPLIES
Jeff Carrell
Honored Contributor

Re: Vlan and DHCP problem after software upgrade

K.15.02.0005 is not the latest code. I don't remember experiencing DHCP(v4) problems with that K.15.02.0005 version, but DHCPv6 was not working till the latest K.15.04.0003 release.


IMHO, get K.15.04.0003 and try again.

PS, I would upgrade your 5406 & 3500's to this latest code.

hth...Jeff
JeffKWI
Occasional Advisor

Re: Vlan and DHCP problem after software upgrade

Thanks, I will udpate to the latest and report back my results.
Mark Wibaux
Trusted Contributor

Re: Vlan and DHCP problem after software upgrade

Unless you have configured your DHCP server to be multi-homed with VLAN tagging support enabled I would remove the VLAN61 tag from the port connecting to it.