Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan on hp Switch 2910al

jwc1972
Advisor

Vlan on hp Switch 2910al

Hello

I have made a complety mess of this, we have a hp switch 2910al. Default vlan
ip address 192.168.1.14 255.255.255.0
tagged 2-12
no tagged 1 13-40

IT Vlan
tag 41-48
ip address 10.5.5.11 255.255.255.0
exit

All I wanted was ports 1-39 to be on default vlan so when we plug in a cable it gets an 192.168.1.X address then ports 40-48 to be on a IT Vlan on address 10.5.5.11, so vlan 1 does not see it _vlan but IT-Vlan can see default VLAN.

Is this best configed at command line or web interface
5 REPLIES
Michael_Breuer
Esteemed Contributor

Re: Vlan on hp Switch 2910al

Hello,

end user ports usual need an untagged configuration on the VLAN. Thus you have to put 1-39 untagged in VLAN 1 and ports 40-48 in IT VLAN:

vlan 1
untagged 1-39
vlan x
name IT-VLAN
untagged 40-48

If you turn on "ip routing" you can route between all VLANs. To set packet filter you can use access-lists. See chapter "IPv4 Access Control Lists" in the Access Security Guide.

Cheers,

Michael
Ingentive Networks GmbH
jwc1972
Advisor

Re: Vlan on hp Switch 2910al

Hello Micheal

I have Untagged Default vlan port 1-48 to untagged then it_vlan 40-48 untagged its saying only one vlan can be untagged? should i have tag 1-39 on it_vlan? and Tag 40-48 on default vlan?
Michael_Breuer
Esteemed Contributor

Re: Vlan on hp Switch 2910al

indeed, a port can only be untagged member in only one VLAN. So you have to put one range (i.e. 1-39) in VLAN 1 and the other range in the IT VLAN.

Cheers,

Michal
Ingentive Networks GmbH
jwc1972
Advisor

Re: Vlan on hp Switch 2910al

Sorry About the delay

Ok
Vlan1
name "default"
untagged 1-39
tagged 40-48
exit
Vlan 100
name "it_vlan
untagged40-48
ip address 10.5.5.11 255.255.255.0
tagged 1-39
exit

If i plug a network cable in 1-39 I get an ipaddress of 192.168.1.* If i plug a network in 40-48 I get ip address 192.168.1.* I thought i would get ip address 10.5.5.11 255.255.255.0
Captain_Kplunk
Occasional Visitor

Re: Vlan on hp Switch 2910al

You haven't made a mess, its all a learning process.

From my basic knowledge, try this setup:

vlan 1
untagged 1-39

vlan 100
untagged 40-48

do this through the menu, so you can see the vlan assignments in a table. Ensure ports 40-48 are untagged in vlan 100 only. The others can be set to none, if you're not routing between them.