Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan routing setup

Donovan Webb
Occasional Visitor

Vlan routing setup

Hi Guys

I'm trying to setup VLAN routing on a 5406zl. All items are currently in the default vlan. I did this once ages ago, but can't quite remember all the details. I've enable routing, iphelper and created a new scope on my win2k3 DHCP server. It still doesn't seem to be getting DHCP leases. Not 100% certain if routing is working as I ran out of time and haven't yet installed a native DHCP/set static IP to test the routing.

The config is as follows on the core

; J8697A Configuration Editor; Created on release #K.13.25

hostname "A_CAB_5406_CORE"
snmp-server location "Server Room"
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8706A
trunk B17-B18 Trk4 Trunk
trunk B21-B22 Trk2 LACP
trunk B23-B24 Trk1 LACP
trunk D1-D2 Trk5 LACP
trunk D3-D4 Trk6 LACP
trunk D5-D6 Trk7 LACP
trunk D7-D8 Trk8 LACP
trunk B11-B12 Trk9 LACP
trunk B13-B14 Trk10 LACP
trunk B9-B10 Trk11 LACP
trunk B15-B16 Trk12 LACP
trunk B19-B20 Trk3 LACP
ip default-gateway 10.60.128.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 172.16.0.8 "public"
vlan 1
name "DEFAULT_VLAN"
forbid C2
untagged A1-A24,B1-B8,C1,C3-C24,D9-D24,Trk1-Trk12
ip address 10.60.129.201 255.255.252.0
no untagged C2
exit
vlan 2
name "VLAN2"
untagged C2
ip helper-address 10.60.128.16
ip address 10.60.132.1 255.255.252.0
tagged Trk4
exit
no ip ssh
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk6 priority 4
spanning-tree Trk7 priority 4
spanning-tree Trk8 priority 4
spanning-tree Trk9 priority 4
spanning-tree Trk10 priority 4
spanning-tree Trk11 priority 4
spanning-tree Trk12 priority 4


and as follows on the 2600's

; J4900B Configuration Editor; Created on release #H.10.67

hostname "A_CAB_SWITCH_5"
snmp-server location "Server Room"
interface 25
no lacp
exit
interface 26
no lacp
exit
trunk 25-26 Trk4 Trunk
ip default-gateway 10.60.128.1
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-22,24,Trk4
ip address 10.60.129.205 255.255.252.0
no untagged 23
exit
vlan 2
name "VLAN2"
untagged 23
no ip address
ip helper-address 10.60.128.16
tagged Trk4
exit
spanning-tree Trk4 priority 4

Any ideas, and am i missing something really simple?

Thanks in advance.
7 REPLIES
Pieter 't Hart
Honored Contributor

Re: Vlan routing setup

Hi Donovan,
You must configure the ip-helper on the switch that does the routing.
so on the 5406, not on the 2600!

this switch has no ip-adress, so cannot relay the dhcp-packets:
vlan 2
name "VLAN2"
untagged 23
no ip address
ip helper-address 10.60.128.16
tagged Trk4
exit

the default-gateway in the scope must point to the routers ip-adres in this vlan, so to
10.60.132.1

when the switch is routing "ip routing "
then default-gateway statement "ip default-gateway 10.60.128.1 " is ignored and can be removed.
use "ip route 0.0.0.0 0.0.0.0 10.60.128.1" instead

use "ip default-gateway" only when the switch has a single ip-adress for management and does no routing.
(so on the 2600 it's correct).
Donovan Webb
Occasional Visitor

Re: Vlan routing setup

Hi Pieter

I've decided to simplify the problem, as I suspect the problem is that the 5406zl switch isn't routing between the VLANs.

I've followed your suggestions, but am still having no luck.

I've set a few static IPs on laptops in VLAN2 subnet, and can ping the vlan2 side of the switch and the laptops can ping each other, but not the vlan1 interface or any devices on vlan1.

Config is as follows :

ip routing
snmp-server community "public" Unrestricted
snmp-server host 172.16.0.8 "public"
vlan 1
name "DEFAULT_VLAN"
forbid C2-C3
untagged A1-A24,B1-B8,C1,C4-C24,D9-D24,Trk1-Trk12
ip address 10.60.129.201 255.255.252.0
no untagged C2-C3
exit
vlan 2
name "VLAN2"
untagged C2-C3
ip helper-address 10.60.128.16
ip address 10.60.132.1 255.255.252.0
tagged Trk4
exit
no ip ssh


I've also tried adding the following routes

10.60.128.0 255.255.252.0 10.60.132.1
10.60.132.0 255.255.252.0 10.60.129.201

but it makes no difference.

Manual IP addresses for the laptops are (55&56)

10.60.132.55 IP
255.255.252.0 Mask
10.60.132.1 Default Gateway

Sorry about the big gaps in response, but I'm actually on a contract elsewhere and doing this as a favour for a friend, so only get to it occasionally.
Pieter 't Hart
Honored Contributor

Re: Vlan routing setup

can you check what ports connect the 5406 to the 2600?
should be 5604 port B17-B18 connected to 2600 port 25-26 on both switches these are trunked into trk4 and have trk4 untagged vlan-1 and tagged vlan-2).
Donovan Webb
Occasional Visitor

Re: Vlan routing setup

Hi Pieter

Thanks for the quick response.

Yes, 5406zl ports B17 and B18 are connected to ports 25 and 26 on the 2600, and both are TRK4.

However, I should have clarified, but I am plugging the laptops directly into ports c2 and c3 on the 5604 directly, so the routing is not working between vlans on the 5406zl switch itself.
Pieter 't Hart
Honored Contributor

Re: Vlan routing setup

can you check if a line "management-vlan VLAN-ID" exist in the config?
traffic will not route from/to a management vlan.
Donovan Webb
Occasional Visitor

Re: Vlan routing setup

Hi Pieter

No, there is no reference to a management vlan in the config file. On the other hand, it does seem like that kind of problem, so I'll make sure to disable the management vlan option, to ensure that it's not the cause. I'll also add a third VLAN and test the routing between the 2nd and 3rd VLANS when I am next on site to ensure the management vlan issues isn't the cause.

Unfortunately, that is going to be about 2 weeks from now, so apologies that I can't get back to you with some results sooner, as you've been a great help.

Many thanks for all the help so far.
serpel
Trusted Contributor

Re: Vlan routing setup

hi,
what is the default gateway for your devices in vlan 1. it should be 10.60.129.201.

hth
alex