Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Voip and VLAN Config

Jesse Sparks
Occasional Visitor

Voip and VLAN Config

We are working on setting up a Voip phone system and I am looking at setting up VLAN's on our switches to allow for a tagged vlan for our voice network. Here is what we have:

Core switch HP 3500yl - This switch is our main switch that our servers and other switches connect back to
We have 3 x HP 2626 - These switches connect the phones and the computers back to the core

Our data network runs on the default untagged network and I would like to create a tagged vlan for use on the phones.

default vlan = 10.0.0.x/24
voice vlan = 192.168.11.x/24

I have the tagged vlan running on the 3500yl and the phones with integrated switches are working at the moment but I can not get the voice vlan to work on the edge 2626 switches.

I am not sure what should do the routing and what the default gateways need to be setup as.
3 REPLIES
Matt Hobbs
Honored Contributor

Re: Voip and VLAN Config

Can you attach a copy of the running-config's from these switches?
Jesse Sparks
Occasional Visitor

Re: Voip and VLAN Config

Here are the configs:
Core 3500yl:
ProCurve J8692A Switch 3500yl-24G
Software revision K.12.16

Copyright (C) 1991-2007 Hewlett-Packard Co. All Rights Reserved.

RESTRICTED RIGHTS LEGEND

Use, duplication, or disclosure by the Government is subject to restrictions
as set forth in subdivision (b) (3) (ii) of the Rights in Technical Data and
Computer Software clause at 52.227-7013.

HEWLETT-PACKARD COMPANY, 3000 Hanover St., Palo Alto, CA 94303

We'd like to keep you up to date about:
* Software feature updates
* New product announcements
* Special events

Please register your products now at: www.ProCurve.com




Press any key to continue






















Enter switch number to connect to or : 0

SN MAC Address System Name Device Type Status
-- ------------- ---------------- --------------------- ----------------------
0 001b3f-f15cc0 AMS-0 ProCurve 3500yl-24G Commander Up
1 001b3f-083140 AMS-1 ProCurve 2626-PWR Member Up
2 001b3f-068c00 AMS-2 ProCurve 2626-PWR Member Up





















































AMS-0# show config

Startup configuration:

; J8692A Configuration Editor; Created on release #K.12.16

hostname "AMS-0"
interface 1
flow-control
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
ip default-gateway 10.0.0.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
qos priority 0
ip address 10.0.0.9 255.255.255.0
exit
vlan 5
name "VOICE01"
qos priority 7
ip helper-address 10.0.0.10
ip address 192.168.11.1 255.255.255.0
tagged 1,9,17-18
voice
exit
stack commander "AMS"
stack member 1 mac-address 001b3f083140
stack member 2 mac-address 001b3f068c00
ip route 0.0.0.0 0.0.0.0 10.0.0.1
router rip
exit

Edge 2626 1:
ProCurve J8692A Switch 3500yl-24G
Software revision K.12.16

Copyright (C) 1991-2007 Hewlett-Packard Co. All Rights Reserved.

RESTRICTED RIGHTS LEGEND

Use, duplication, or disclosure by the Government is subject to restrictions
as set forth in subdivision (b) (3) (ii) of the Rights in Technical Data and
Computer Software clause at 52.227-7013.

HEWLETT-PACKARD COMPANY, 3000 Hanover St., Palo Alto, CA 94303

We'd like to keep you up to date about:
* Software feature updates
* New product announcements
* Special events

Please register your products now at: www.ProCurve.com




Press any key to continue






















Enter switch number to connect to or : 1

SN MAC Address System Name Device Type Status
-- ------------- ---------------- --------------------- ----------------------
0 001b3f-f15cc0 AMS-0 ProCurve 3500yl-24G Commander Up
1 001b3f-083140 AMS-1 ProCurve 2626-PWR Member Up
2 001b3f-068c00 AMS-2 ProCurve 2626-PWR Member Up























AMS-1#































Startup configuration:

; J8164A Configuration Editor; Created on release #H.10.38

hostname "AMS-1"
ip default-gateway 10.0.0.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address dhcp-bootp
qos priority 0
exit
vlan 5
name "VOICE01"
no ip address
qos priority 7
ip helper-address 10.0.0.10
tagged 4,25-26
voice
exit
stack join 001b3ff15cc0

AMS-1#
AMS-1# hostname "AMS-1"
Invalid input: hostname
AMS-1# ip default-gateway 10.0.0.1
Invalid input: ip
AMS-1# ip routing
Invalid input: ip
AMS-1# snmp-server community "public" Unrestricted
Invalid input: snmp-server
AMS-1# snmp-server host 10.0.0.92 "public"
Invalid input: snmp-server
AMS-1# vlan 1
Invalid input: vlan
AMS-1# name "DEFAULT_VLAN"
Invalid input: name
AMS-1# untagged 1-26
Invalid input: untagged
AMS-1# ip address dhcp-bootp
Invalid input: ip
AMS-1# qos priority 0
Invalid input: qos
AMS-1# exit
AMS-1> vlan 5
Invalid input: vlan
AMS-1> name "VOICE01"
Invalid input: name
AMS-1> no ip address
Invalid input: no
AMS-1> qos priority 7
Invalid input: qos
AMS-1> ip helper-address 10.0.0.10
Invalid input: ip
AMS-1> tagged 4,25-26
Invalid input: tagged
AMS-1> voice
Invalid input: voice
AMS-1> exit
Do you want to log out [y/n]? n
AMS-1> 001b3ff15cc0
Invalid input: 001b3ff15cc0
AMS-1> show config
Invalid input: config
AMS-1> confg
Invalid input: confg
AMS-1> config
Invalid input: config
AMS-1> login
Invalid input: login
AMS-1> enter
Invalid input: enter
AMS-1>
enable Enter the Manager Exec context.
exit Return to the previous context or terminate current
console/telnet session if you are in the Operator
context level.
link-test Test the connection to a MAC address on the LAN.
logout Terminate this console/telnet session.
menu Change console user interface to menu system.
ping Send IP Ping requests to a device on the network.
show Display switch operation information.
traceroute Send traceroute to a device on the network.

AMS-1> enable
AMS-1# show config

Startup configuration:

; J8164A Configuration Editor; Created on release #H.10.38

hostname "AMS-1"
ip default-gateway 10.0.0.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address dhcp-bootp
qos priority 0
exit
vlan 5
name "VOICE01"
no ip address
qos priority 7
ip helper-address 10.0.0.10
tagged 4,25-26
voice
exit
stack join 001b3ff15cc0

Edge 2626 2:
ProCurve J8692A Switch 3500yl-24G
Software revision K.12.16

Copyright (C) 1991-2007 Hewlett-Packard Co. All Rights Reserved.

RESTRICTED RIGHTS LEGEND

Use, duplication, or disclosure by the Government is subject to restrictions
as set forth in subdivision (b) (3) (ii) of the Rights in Technical Data and
Computer Software clause at 52.227-7013.

HEWLETT-PACKARD COMPANY, 3000 Hanover St., Palo Alto, CA 94303

We'd like to keep you up to date about:
* Software feature updates
* New product announcements
* Special events

Please register your products now at: www.ProCurve.com




Press any key to continue






















Enter switch number to connect to or : 2

SN MAC Address System Name Device Type Status
-- ------------- ---------------- --------------------- ----------------------
0 001b3f-f15cc0 AMS-0 ProCurve 3500yl-24G Commander Up
1 001b3f-083140 AMS-1 ProCurve 2626-PWR Member Up
2 001b3f-068c00 AMS-2 ProCurve 2626-PWR Member Up























AMS-2#































Startup configuration:

; J8164A Configuration Editor; Created on release #H.10.38

hostname "AMS-2"
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address dhcp-bootp
qos priority 0
exit
vlan 5
name "VOICE01"
no ip address
qos priority 7
ip helper-address 10.0.0.10
tagged 25
voice
exit
stack join 001b3ff15cc0

I have been able to get some conmmunication going between the edge and core switches but I would like a 2nd opinion of the setup. I was also reading that leaving the production setup on the default vlan is not a good plan, should I look at moving off the default and using a new vlan for default?


cenk sasmaztin
Honored Contributor

Re: Voip and VLAN Config

hi I concept your two switch config file
you read carefully note int sh run print. After you make carefully look two switch for voip vlan simple config.

AMS-0# show config

Startup configuration:

; J8692A Configuration Editor; Created on release #K.12.16

hostname "AMS-0"
interface 1
flow-control
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
ip default-gateway 10.0.0.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
qos priority 0
ip address 10.0.0.9 255.255.255.0
exit
vlan 5
name "VOICE01"
qos priority 7
ip helper-address 10.0.0.10 unnecessary
ip address 192.168.11.1 255.255.255.0
tagged 1,9,17-18 I not see fibre minigbic port vlan 5 tag member you make int 23-24 vlan 5 tag and not see vlan 5 untag member port ip comminicaiton server device voip and cpu nic attach switch untag port example:int 10-11 untag
voice
exit
stack commander "AMS"
stack member 1 mac-address 001b3f083140 unneccessary
stack member 2 mac-address 001b3f068c00 unneccessary

ip route 0.0.0.0 0.0.0.0 10.0.0.1 which device use static route?
router rip which device use rip ?
exit






AMS-1> enable
AMS-1# show config

Startup configuration:

; J8164A Configuration Editor; Created on release #H.10.38

hostname "AMS-1"
ip default-gateway 10.0.0.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address dhcp-bootp incorrect this switch vlan1 ip address static ip .192.168.11.2 255.255.255.0
qos priority 0
exit
vlan 5
name "VOICE01"
no ip address
qos priority 7
ip helper-address 10.0.0.10
tagged 4,25-26 is good int
voice
exit

xxxxTwo switch 3500 and 2600 simple vlan and voip configxxxxx
AMS-0# show config



; J8692A Configuration Editor; Created on release #K.12.16

snmp-server community "public" Unrestricted
snmp-server host 10.0.0.92 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-9,12-24
ip address 10.0.0.9 255.255.255.0
exit
vlan 5
ip address 192.168.11.1 255.255.255.0
untag 10-11 (port 10-11 attach ip phone server devicevoip and cpu nic)
tagged 1-5,24 (port 24 for fibre minigbicâ port1-5 attach ip phone)
voice
exit









AMS-1> enable
AMS-1# show config

Startup configuration:

; J8164A Configuration Editor; Created on release #H.10.38

hostname "AMS-1"
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address 10.0.0.10 255.255.255.0
vlan 5
ip address 192.168.11.2 255.255.255.0
tagged 1-5,26 (int 26 for fibre minigbic portâ int 1-5 attach ip phone)
voice
exit




cenk