Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Web borwser access to procurve switches

Julian Griffiths
Frequent Advisor

Web borwser access to procurve switches

When I load up the web browser access to any switch I get lots of boxes saying "Loading java applet". it can then take 5 minutes or more before I see the Status/Overview screen. The switches are on the same sub-net and connected via 100Mbs.

It is also slow moving from one tab to another.

Telnet to the switch is fine; but I have found a large number of "SNMP security access violations" from my computer in the event logs. I have checked and double checked the SNMP settings on the switches and my PC and can't find any errors. Community name is the same, including case.

Is this the cause of the slow web access? If not, why is it so slow and how do I speed it up?
6 REPLIES
Les Ligetfalvy
Esteemed Contributor

Re: Web borwser access to procurve switches

You don't say what SNMP applications are running on your PC. I had posted here, an issue I am having with FLuke OVC causing so many access violations that the the syslog in PCM+ took hours to finally catch up even after stopping the Fluke software. I could see where the flood of log entries could slow things down.

You need to resolve your SNMP authentication issues first.
Eirram_1
Frequent Advisor

Re: Web borwser access to procurve switches

Is takes about 30 seconds for the main webpage of a Procurve switch to come up. Are you using MS or SUN java. Do you go through a proxy server? If yes, turn if off or set your browser to bypass for local IPs.

The SNMP violations should not be the reason for the slow web response.

Goodluck,
Eirram
DONNA L SEISER
Occasional Advisor

Re: Web borwser access to procurve switches

Hello David
I don't have an answer but wanted to say that I have seen strange things with the web browser also. I think it began after updating JAVA on my desktop because of needs of other apps. My issue is that it gives me the applets message, then says Done in left bottom corner but nothing displays. If I exit the screen and try again a few minutes later *sometimes* it brings it up. Also, I get two login screens when it does work. The second login screen looks quite different.
My version of Java runtime is SE v1.4.2-01.
Hope this helps in some way.
Donna
Charles Kuhl
Occasional Visitor

Re: Web borwser access to procurve switches

2848 switch and same issue here. Sometimes I can access the slave (of 2 switches) but the master will never feed me anything....

Re: Web borwser access to procurve switches

You dont say what switch you have, but i had similar problem in 5304XL with old firmware. After updating desktop java-plugin it started to respond slowly and after firmware update it began to work just fine. The switch firmware was below E07 so it was very old.

Julian Griffiths
Frequent Advisor

Re: Web borwser access to procurve switches

There were multiple copies of java on my PC. Removing all but the latest seems to have done the trick.