Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Well known multicast addresses

Massimo Poletti_1
Frequent Advisor

Well known multicast addresses

Hi

I have a problem with multicast.

On my LAN my provider has two Cisco routers (main and backup) talking using HSRP, but when main line goes down, the backup doesn't take the control (i.e. the virtual shared addess). They are connected to a 5304XL switch (fw 11.10).

My provider told me that the routers use multicast address 224.0.0.2 to communicate, but he found in the logs that two others devices on the LAN use the same address and this could (maybe) be is an issue.

The devices are special devices, unaccessible to me. My idea is to block multicast for all ports but the two routers' ports.
Unfortunately the manual (adv. traffic management guide) states that "well-known" addresses (224.0.0.x) are always forwarded.

What do you think about this?
Any suggestion?
Thanks
7 REPLIES
Shadow13
Respected Contributor

Re: Well known multicast addresses

have you tried with RACL ? am not sure if it will work just a suggestion
Massimo Poletti_1
Frequent Advisor

Re: Well known multicast addresses

Uhmmmm

Not sure that RACL could be useful.

thanks anyway
Gerhard Roets
Esteemed Contributor

Re: Well known multicast addresses

Hi Massimo

The 5300's should use 224.0.0.2. Since it is the well known all router multicast address. Just like 224.0.0.1 is the one for all hosts.

Simply blocking all well known multicast addresses ewould have adverse affect. I.e. OSPF not working / RIP not working ... the list goes on.

you might want to look at http://www.cisco.com/en/US/tech/tk648/tk362/technologies_q_and_a_item09186a00800a9679.shtml

If you can give us a show run and on which ports the Cisco's are connected. We might pick something up. If you can also give us the ip address of the hsrp protected ip.

HTH


Massimo Poletti_1
Frequent Advisor

Re: Well known multicast addresses

Here we go:

Running configuration:

; J4850A Configuration Editor; Created on release #E.11.10

hostname "ArgSemint.CS"

time timezone 60
time daylight-time-rule Western-Europe
module 2 type J4878A
module 1 type J4820B
module 3 type J4878A
module 4 type J4878A
interface A18
name "Router Main"
exit
interface A24
name "Router Bckp"
exit
ip default-gateway 192.168.19.1
sntp server 192.168.33.198
ip routing
timesync sntp
sntp unicast
logging 192.168.13.182
snmp-server community "******" Unrestricted
snmp-server host 192.168.13.182 "*****"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B4,C3-C4,D1-D4
ip address 192.168.19.247 255.255.254.0
ip helper-address 192.168.4.199
ip helper-address 192.168.13.145
tagged C1-C2
exit
vlan 81
name "ARGRX"
ip address 192.168.81.1 255.255.255.0
tagged C1-C2
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
ip route 0.0.0.0 0.0.0.0 192.168.19.1
spanning-tree
password manager


HSRP:
Virtual 192.168.19.1
Main router: 192.168.19.2
Backup router: 192.168.19.4

Thanks
Ragards
Shadow13
Respected Contributor

Re: Well known multicast addresses

From the link that Gerhard mentioned:
A. The destination address of HSRP hello packets is the all routers multicast address
(224.0.0.2). The source address is the primary IP address of the router assigned to the
interface."

So can a RACL be applied to filter the traffic using the SOURCE ip address of the routers ??

Permitting only the traffic to the IP address of the other router ??
AUS Adam
Advisor

Re: Well known multicast addresses

I would track down the other devices on the LAN using multicast and see why they are doing this, if is not necessary turn it off.

The other option would be to sit your routers in there own subnet / vlan, as I think you need multicast routing enabled to route multicast addresses across subnets.

Massimo Poletti_1
Frequent Advisor

Re: Well known multicast addresses

Problem solved from the provider.

It was a Cisco IOS issue. The releases on the routers was incompatible (only for HSRP).
After an update now all is OK.

Thanks anyway to all of you.

1 point for the first that answered me