Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

able to get dhcp from default vlan but unable to get dhcp from clients vlan.

SOLVED
Go to solution
boziah
Advisor

able to get dhcp from default vlan but unable to get dhcp from clients vlan.

I have a procurve switch 2626 j4900B,

I have default vlan which works fine and all untagged ports get dhcp from my dhcp server

however i am not able to get dhcp from  vlan 96 (named clients)

below is my config.Any help is great appreciated.

 

 ProCurve Switch 2626# show conf

Startup configuration: ; J4900B Configuration Editor; Created on release #H.10.31

hostname "ProCurve Switch 2626"

snmp-server contact "Josiah Rasugu" snmp-server location "My Crib"

time timezone -360

time daylight-time-rule Continental-US-and-Canada

mirror-port 20

console baud-rate 9600

console inactivity-timer 60

interface 2

name "domain controller"

exit

ip default-gateway 10.76.12.1

sntp server 128.101.101.101

ip routing

timesync sntp

sntp unicast

vlan 1

name "kenya"

tagged 1, 25-26

 

untagged 2-15

ip address 10.76.12.2 255.255.255.0

ip helper-address 10.76.12.15

exit

vlan 96

name "clients"

tagged 1,25-26

untagged 16-24

ip address 10.76.96.1 255.255.255.0

ip helper-address 10.76.12.15

exit

 

 

no tftp client

password manager

password operator 

16 REPLIES
Fredrik Lönnman
Honored Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

The config is fine, probably the problem lies elsewhere. Does the DHCP server know how to find its way back to the 10.76.96.0 network?

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

Jeff Carrell
Honored Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Concur with other poster, you may need a static route in your 10.76.12.1 router to find 10.76.96.1 via 10.76.12.2

 

 

hth...Jeff

boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Please explain what you mean by DHCP server know hot to find its way back to the 10.76.96.0 network?
boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

I am not sure how to do this can you explain further?
EckerA
Respected Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Hi,

have you made a traceroute from your DHCP server to 10.76.96.1?
As your DHCP-Server has the IP 10.76.12.15 it needs to route the traffic to 10.76.96.0.
We assume it uses 10.76.12.1 as it's default gateway.
But does the router 10.76.12.1 know a route to the 10.76.96.0 subnet? If not, the server can't reach the clients in that subnet..this means the server gets the DHCP requests, and answers, but the packets are dropped at the router or somewhere else.. but the switch is configured ok.
basically the router 10.76.12.1 needs a route:
ip route 10.76.96.0 255.255.255.0 10.76.96.2

hth
alex
Fredrik Lönnman
Honored Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

ip route 10.76.96.0 255.255.255.0 10.76.12.2

 

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

when i tried ip route 10.76.96.0 255.255.255.0 10.76.12.2.i received msg 10.76.12.2 can not be switch IP address and route gateway at the same time.I did this on the hp switch 2626
Fredrik Lönnman
Honored Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

You should type that command on the switch/router that is default gateway in vlan1, probably 10.76.12.1.

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

my ISP router (fortinet) has the ip 10.76.12.1
boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

below is the result when i type it into vlan 1
hostname "ProCurve Switch 2626"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "kenya"
untagged 1-12,25-26
ip address 10.76.12.2 255.255.255.0
no untagged 13-24
exit
vlan 96
name "clients"
untagged 13-24
ip address 10.76.96.1 255.255.255.0
ip helper-address 10.76.12.15
exit
ip route 10.76.96.0 255.255.255.0 10.76.12.1
ip route 0.0.0.0 0.0.0.0 10.76.12.1
password manager
password operator

ProCurve Switch 2626# conf t
ProCurve Switch 2626(config)# vlan 1
ProCurve Switch 2626(vlan-1)# ip route 10.76.96.0 255.255.255.0 10.76.12.2
Invalid input: route
ProCurve Switch 2626(vlan-1)# ip route 10.76.96.0 255.255.255.0 10.76.12.0
Invalid input: route
ProCurve Switch 2626(vlan-1)#

Fredrik Lönnman
Honored Contributor
Solution

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

You'll have to put the route in the Fortinet fw then, NOT in the 2626.
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Thank you.
Rburns
Visitor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

There is really no need for an extra route to be added anywhere. The DHCP server sits on VLAN 1, and his hosts sit on VLAN 96. Both VLAN's are on the same switch, the switch has ip routing enabled, and has an IP address assigned in each VLAN. The default gateway does not even come into play here, as this switch will route between the VLAN's just fine...no need for an extra router to be involved, unless the DHCP server has the wrong gateway address set (see below).

 

The problem, by my guess, is likely on the DHCP server- either the 10.76.96.0 scope is not defined properly, or maybe the server does not have its' default gateway set properly (as mentioned above, try pinging or tracerouting from the DHCP server to 10.76.96.1 to see if it can find that subnet. If not, perhaps set its' gateway address to 10.76.12.2). 

 

One more note- you don't need the "ip helper-address 10.76.12.15" command on VLAN 1...the DHCP server is on that VLAN so it will see DHCP requests on that VLAN...no need to forward them as unicasts.

Fredrik Lönnman
Honored Contributor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.


Rburns wrote:

There is really no need for an extra route to be added anywhere. The DHCP server sits on VLAN 1, and his hosts sit on VLAN 96. Both VLAN's are on the same switch, the switch has ip routing enabled, and has an IP address assigned in each VLAN. The default gateway does not even come into play here, as this switch will route between the VLAN's just fine...no need for an extra router to be involved, unless the DHCP server has the wrong gateway address set (see below).

 


Obviously the default router in VLAN1 isnt the 2626 switch itself, but the Fortinet, and the DHCP server has its default gw pointed at the Fortinet, that doesnt know about the vlan 96 beeing routed in the 2626. My last post obviously fixed the issue, right?

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

Rburns
Visitor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Sorry  if you took my post to be an attack on your expertise, Fredrick...yes, adding the route into the Fortinet gateway is one way to fix the issue. My point is that it is not necessarily the most optimal way. Sending traffic between two VLAN's  on the same switch by routing it out to the Fortinet and then back again to the switch is a waste of time and bandwidth in my eyes (2 unnecessary hops). If the switch really is the center of the network (and I suspect it is, seeing as he is creating the separate networks on it), let it be the gateway for ALL internal subnets and only use the Fortinet for subnets outside of the building (like the Internet). That is planning for the future too, as maybe there will be more VLAN's going forward???

 

So, to summarize, the BEST solution to the problem in my eyes is not to add a route to the Internet gateway, but rather to set the defalt gateway on both VLANs to be the 2626 switch. But you don't need to list me as the solution- Fredrick has already grabbed that prize (and I am not an Honoured Contributor).

 

Routing should be as simple as possible, and I think avoiding involving an external vendor to make a change for you is always a good idea...again, I am guessing that he does not configure his own Internet gateway.

 

boziah
Advisor

Re: able to get dhcp from default vlan but unable to get dhcp from clients vlan.

Yes it fixed it.