Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

bl 460c cisco teaming

AviAzerrad
Occasional Advisor

bl 460c cisco teaming

hi,
we are using bl 460c blades with built-in 4 cisco ethernet switches..
each blade has 4 nic cards by default and each nic is directly connected to the cisco switches (each nic to a specific cisco switch).
now,all the 4 cisco switches are directly connected (2 ports from every cisco switch in internal ports 17+18) to our backbone switch "catalyst 4506" ,here is the built-in cisco configuration:

"interface Port-channel1

interface GigabitEthernet0/17
channel-group 1 mode on
!
interface GigabitEthernet0/18
channel-group 1 mode on"

now here is our cisco backbone 4506 configuration :
interface Port-channel10
description Connect to HP_Blade_Center
switchport
switchport access vlan 110
switchport mode access

interface GigabitEthernet4/36
switchport access vlan 110
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet4/37
switchport access vlan 110
switchport mode access
channel-group 10 mode on"
so we configured those configuration from each built-in cisco switch to our backbone..
so now i am asking :
1. for best performance this is the best configuration between cisco built-in switch to our cisco 4506 backbone ?
2. why i cannot perform windows teaming ? every time when i am trying to add members to teaming i am getting flipping errors from the hp cisco switch and network errors and i may lose connections to me blades ? what is wrong ?
3.for best performance in windows env (best mb/sec) which method of teaming i need ?

respectfully,
avi azerrad

10 REPLIES
Pieter 't Hart
Honored Contributor

Re: bl 460c cisco teaming

Hi Avi,
I read your info as you try to configure a team across multiple (4) switches where each switch has a teamed uplink to the 4506?
the last thing is no problem.

but,
Read the "HP ProLiant Network Adapter Teaming" whitepaper.
to understand the different types of teams:
fault tolerant; load balancing, etc

I think you may have configured the team as faul-tolerant with load balancing (i think this is the default when creating a team). The host wants to use all nics for traffic. So the switches must also support this (load balancing team across multiple switches). They probably don't!, look in the documentation of the switches.

You can configure the team as fault tolerant only (one nic active at a time). this probably will work better, but then you have only one of three nics active.
An alternative is building two teams of two nic's each, connected to the same switch.

hope this help
Pieter
Adrian Clint
Honored Contributor

Re: bl 460c cisco teaming

See attached pdf when read with Pieters email. It shows when you need switch support.
André Beck
Honored Contributor

Re: bl 460c cisco teaming

Hi Avi,

you cannot have more than fault tolerance teaming against separate switches, as others already explained. So the question comes down to *which* Cisco switch modules you have in your blade system. With the 3020 model, I see no way to get anything beyond fault tolerance. What you probably want is the 3120 class, which establishes a single switch identity using VBS (virtual blade switch) that essentially seems to be an integration of StackWise (known from the 3750(E) class) into these devices. Given they stem from the 3750 line, they are finally L3 switches, too.

With all the blade switches of a blade system stacked into a single identity, multi-member port channels will be no problem, so you would then run LACP aggregation based teams.

Andre.
AviAzerrad
Occasional Advisor

Re: bl 460c cisco teaming

dear friends,
the built-in (in the blade case) switch is "Model number : WS-CBS3020-HPQ"
and i want to use only 2 nics from each blade for teaming ,but what i am trying to say is that i tried all the teaming methods and each method cause to "fliping" messages in the switch and to lose connection with my servers ,so you saw my etherchannel configuration between those 2 switches ,its ok or something wrong ?
something is little fishy because when i am not using teaming everythis is working fine...

respectfully,
avi azerrad
AviAzerrad
Occasional Advisor

Re: bl 460c cisco teaming

as ypu said ,i need to configure all the 4 internal built-in cisco port to use LACP and only then to perform teaming ?
someone can write for me or fix for me the configuration as i wrote in the beginnig ?

respectfully
avi azerrad
Pieter 't Hart
Honored Contributor

Re: bl 460c cisco teaming

look at this from your 4506 config :
interface GigabitEthernet4/36
switchport access vlan 110
switchport mode access
You do not configure an access-port on the built-in switch!

As the WS-CBS3020-HPQ comes from cisco, you better configure links between the 3020 and the 4506 as "vlan-trunks".
Specifically trunks in cisco-terms, which means multiple vlans can be transported on this link.
Then you allready configured port-groups, etherchannels, which some also refer to as port-trunking (this is different from the vlan-trunk).

If needed configure the access-port on the link to the blades.

hope this clarifies
Pieter
AviAzerrad
Occasional Advisor

Re: bl 460c cisco teaming

hi,
the cisco 4506 isnt built-in switch,it is my backbone and only in this switch i configured the vlan access (110) ,and i am using only in one vlan (110) so i dont need to transfer vlans,thats why i am using etherchannel....

respectfully,
avi azerrad
Pieter 't Hart
Honored Contributor

Re: bl 460c cisco teaming

see document :
http://www.cisco.com/en/US/prod/collateral/switches/ps6746/ps6748/ps6765/design_guide_c07-468192.pdf
pages 24+ for details on vlan-trunk and port-trunk (lacp)

make sure you combine the right nic's in a team (connected to the same switch)
see image in attachment or page4 of the .pdf for details of internal connections.
Pieter 't Hart
Honored Contributor

Re: bl 460c cisco teaming


the cisco 4506 isnt built-in switch,it is my backbone


that's not what i tried to make clear.

I said that at the backbone-switch (GigabitEthernet4/36) you configure an access-port.

interface Port-channel10
description Connect to HP_Blade_Center
switchport
switchport access vlan 110
switchport mode access


but on the built-in switch you don't

"interface Port-channel1

interface GigabitEthernet0/17
channel-group 1 mode on
....


You better configue both port-channels either as trunk or as access-port.

In your current configuration locally inside the built-in switches all is treated as VLAN-1, and you connect the uplink to te core on an access-port in VLAN-110.
Vlan-1 is a special vlan wich cannot be disabled totally because some management protocols (vtp, stp) depend on this.
but it is very a good idea to get all non-network devices out of vlan-1

Even when you need only one vlan, you better leave vlan-1 as it is.
so the link between switches is a vlan-trunk wich transports vlan1 and vlan110.
and the access-ports are configured on the link to the blades in vlan110.

=============

i dont need to transfer vlans,thats why i am using etherchannel

Using etherchannel has nothing to do with vlan's, it's something totally different.
Etherchannel brings you redundant links with possible load balancing.
Vlan's can be transported over etherchannels.

hope this clarifies?
Pieter
André Beck
Honored Contributor

Re: bl 460c cisco teaming

Re Avi,

> as you said ,i need to configure all the 4
> internal built-in cisco port to use LACP and
> only then to perform teaming ?

I'm afraid you can't do this with 3020s.

The way I remember how these blade systems and switch modules work, every individual backplane port of a certain blade comes out at a different backplane module. So for a blade with 4 interfaces of 1000Base, the first interface will come out on switch module one, the second on switch module two, &c. Given the individual switch nature of each 3020 module, you (AFAIK) cannot use LACP or any similar teaming concept. An LACP team has to be terminated by a single switch, and this is only possible with 3120 switch modules (when configured to stack).

Your only option is fault tolerance teaming. That means one interface is active and the other(s) is/are standby. You will not set up any etherchannel or similar aggregates on the switches for that, the interfaces simply plug into the same broadcast domain on different switches. The whole thing works by the teaming software using only one of the links and switching to the other if the primary one fails (maybe using explicit link drop and moving a virtual MAC to the other link [or even by simply doing a gratuitous ARP and expecting the IP to become reachable via another physical MAC]).

In short, with your hardware, there's IMO no way to load balance on L2. You could load balance on L3, though - but that's usually not supported well in typical OSes you are probably using when you use the term "teaming" and hacking it together in Linux is nontrivial either.

HTH,
Andre.