Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

config 3500yl ToIP AASTRA with 3 VLANS

Harry92
Occasional Advisor

config 3500yl ToIP AASTRA with 3 VLANS

Hi everybody,

I have 3 VLAN :
- VLAN 3 : DHCP SERVER
- VLAN 4 : IPBX
- VLAN 5 : IPPHONES

i have tagged iphones on the VLAN 5
i have untagged IPBX on the VLAN 4
and i have untagged DHCP SERVER on the VLAN 3
but my ipphones not obtain a IP address by dhcp ??

(i have enable ip routing on the switch )

i begin in hp switching and i need your help.

THANK YOU VERY MUCH
19 REPLIES
cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

you can write ip helper address command on vlan 5

vlan-5)# ip helper-address [dhcp server address]


and dhcp server default gateway address must be vlan 3 ip address

ipBX device default gateway address must be vlan 4 ip addresss

ip phone ip default gateway address must be
vlan 5 ip address




cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

thanks for your response,

I have already put dhcp relay in vlan interface.

how should configure the DHCP server port (tagged on all vlans ? or just untagged in vlan server ) on the switch?

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

dhcp server must be connect vlan 3 untag port

please send sh run pirnt
cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

Ok, thanks,

Sh running conf :
module 1 type J86yyA
module 2 type J86xxA
ip routing
snmp-server community "public" Unrestricted
vlan 3
name "SERVEUR_DHCP"
untagged 6
ip address 192.168.3.254 255.255.255.0
exit
vlan 4
name "IPBX"
untagged 1-5
ip address 192.168.2.254 255.255.255.0
exit
vlan 5
name "IPPHONES"
qos priority 7
ip helper-address 192.168.3.13
ip address 192.168.4.254 255.255.255.0
tagged 1-5,7,10-27,47-48
exit
spanning-tree
spanning-tree priority 0 force-version RSTP-operation


Thank you for your help
cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

your switch config is true

1-check your dhcp server ip address
dhcp server default gateway address must be
192.168.3.254

2-check your on dhcp server dhcp scobe ip and default gateway address
scobe range must be 192.168.4.1 ---to--253
scobe default gateway address 192.168.4.254

3-check your IPBX device address default gateway address must be 192.1682.254

4-check your ip phone ip vlan status
your ip phone must be vlan enable and vlan id 5




cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

requires that the Ipphones are in full dhcp, so i don't indicate on phones the vlan id.

My config is true even if iphones are full dhcp?

The vlan ID is indicate on the dhcpd.conf

Thanks
cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

which model use aastra ip phone

some aastra ip phone unable vlan tag ing

if your ip phone unable vlan taging at that time we can change switch config
cenk

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

ip phone connection port your switch (1-5,7,10-27,47-48) tagging on vlan 5

therefore your ip phone must be support 802.1q standart

if don't support 802.1q standart your ip phone
you change switch config

ip phone must connect vlan 5 untag port

you can use this config

Sh running conf :
module 1 type J86yyA
module 2 type J86xxA
ip routing
snmp-server community "public" Unrestricted
vlan 3
name "SERVEUR_DHCP"
untagged 6
ip address 192.168.3.254 255.255.255.0
exit
vlan 4
name "IPBX"
untagged 1-5
ip address 192.168.2.254 255.255.255.0
exit
vlan 5
name "IPPHONES"
qos priority 7
ip helper-address 192.168.3.13
ip address 192.168.4.254 255.255.255.0
untagged 7-12
exit
spanning-tree
spanning-tree priority 0 force-version RSTP-operation

ip phone connect int 7-12
cenk

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

for short

your switch config is true

check your ip phone 802.1q support

if your ip phone support 802.1q protocol you can define vlan id on ip phone

if don't support 802.1q your ip phone at the time you must be connect vlan 5 untag port with my config
cenk

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

for example

http://www.voiplink.com/Aastra_57i_IP_Phone_Four_Lines_Two_Ethernet_p/aastra-57i.htm

this phone support 802.1q vlan tag ing
you can connect taging port this phone and if you attach pc this phone


but this phone don't support 802.1q do not connect taging port this phone this phone must connect on ip phone vlan untag port
and don't use pc same port

http://www.voiplink.com/Aastra_9112i_IP_Phone_One_Line_p/aastra-9112i.htm
cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

aastra phone are SIP 53i and support 802.1q.

The client want that DHCP server give the vlan ID at this phones because there is 200 phones to deploy...

thanks
Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

There is a pc (untagged in vlan data )connect to phones

thanks for your links
Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

if my config is true, i think that there is a pb on DHCP server?

It's not me who configure the server, and the administrator of server said me ; the pb is because of untagged or tagged on your switch..

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

dhcp server don't give vlan id on client

for give dynamic vlan id on ip phone
you can use 802.1x &dynamic vlan config

when connect on ip phone on your network switch this port turn vlan 5 member(with radius server) for ip phone therefore your ip phone support 802.1x protocol

if don't use 802.1x on your network you must manuel config each ip phone
cenk

cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

dhcp server connect must be untag port on vlan 3
IPBX device connect must be untag port on vlan 4

ip phone device connect must be taging port on vlan 5

you must define vlan id each ip phone device manually
cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

Ok,
but my client said me it's possible of deliver vlan ID by DHCP without to use 802.1X
cenk sasmaztin
Honored Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

802.1x is authentication protocol for security
we can use radius server (Microsoft IAS)
radius server remote active directory rule give vlan id on switch port

if your device support 802.1x protocol you can give dynamic vlan your network device

please see this demo

http://s1.dosya.tc/802.1x_dynamicvlan.rar.html
cenk

Harry92
Occasional Advisor

Re: config 3500yl ToIP AASTRA with 3 VLANS

Ok thanks
I try Monday

Mark Wibaux
Trusted Contributor

Re: config 3500yl ToIP AASTRA with 3 VLANS

Assigning a VLAN to an IP phone via DHCP depends purely on the phone supporting it. Not all IP phones do.
For example with an Avaya phone you need to setup 2 DHCP scopes on your server.
Each port connecting to your phones needs to be "untagged" in one VLAN and "tagged" in the voice VLAN.

The first scope is in the "untagged" VLAN range, when the phone first boots it starts up without VLAN tagging enabled which means that its DHCP request goes out on the ports untagged VLAN. The DHCP server responds with an IP address from that scope. The response contains additional DHCP options (other than Gateway, DNS etc), in the case of Avaya phones you setup a custom option 176 which contains a string that tells the phone what is the default VLAN and what is the voice VLAN (option for Avaya phones looks like this "L2Q=1,L2QVLAN=7" where VLAN 7 is the voice VLAN).
The phone reads this string and reconfigures itself for the Voice VLAN and then reissues a new DHCP request on this VLAN. The DHCP server then responds with an IP address from its other scope. In the case of Avaya phones this has a new option 176 string that completes the setup of the phone.
You need to check and see if your phones actually support VLAN configuration via DHCP and if they do what are the DHCP options you need to setup to achieve this.