Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

connecting vlans to speck to each other

fadi-najajreh
Occasional Visitor

connecting vlans to speck to each other

I have a network contains HP switches for the core switch and edage switches. i have three vlans as follwoing:

- vlan 5 for servers with ip address        172.16.114.1    255.255.255.0

- vlan 6 for computers with ip address 172.16.112.1    255.255.255.0

- vlan 7 for micros with ip address          172.16.113.1    255.255.255.0

 

 

i was trying to comunicate between all above vlans but unfortuntly without success. i mean that i nead to ping between computers and servers. i need your help taking in mind that core switch is layer 3, 8206 serise and edge switchs are 2910 POE.

7 REPLIES
Vince_Whirlwind
Trusted Contributor

Re: connecting vlans to speck to each other

The 8206 should have:

interface vlan 5  ip address 172.16.114.1    255.255.255.0

interface vlan 6  ip address 172.16.112.1    255.255.255.0

interface vlan 7  ip address 172.16.113.1    255.255.255.0

 

and it will route between VLANs.

rvasquez
Visitor

Re: connecting vlans to speck to each other

I have the same problem, i use HP A-5500-24G as SWITCH CORE and HP A-5120-48G as ACCESS SWITCH. I have 3 vlans and config the ports as TRUNK and permit vlan´s:

 

SWITCH A-5500:

#

vlan 1

#
vlan 10
#
vlan 20

#

interface GigabitEthernet1/0/24
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 10 20

 

SWITCH A-5120-48G:

#

vlan 1
#
vlan 10
#
vlan 20

#

interface GigabitEthernet1/0/47
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 10 20

 

After that the config in both ports and connect both switch the config change to:

 

 

SWITCH A-5500-24G

#
interface GigabitEthernet1/0/24
port link-mode bridge
port link-type hybrid
port hybrid vlan 1 tagged

 

SWITCH A-5120-48G

#
interface GigabitEthernet1/0/47
port link-mode bridge
port link-type hybrid
port hybrid vlan 1 tagged

 

which is the correct configuration?

 

Thanks.

Vince_Whirlwind
Trusted Contributor

Re: connecting vlans to speck to each other

Where are your router addresses?

 

Why use "hybrid"?

rvasquez
Visitor

Re: connecting vlans to speck to each other

Hello Vince, I config Trunk ports but when connect the switchs the config change to hybrid port... The SWITCH A-5500-24G has DHCP SERVER enable and has Vlan-Interface to each vlan, but if i connect 2 pc´s with static ip address in port´s at same vlan don´t see the other pc.

 

...

 

Vince_Whirlwind
Trusted Contributor

Re: connecting vlans to speck to each other

WHat IPs are on the VLAN interfaces?

WHat VLAN numbers?

What VLAN config on the ports the PCs are attached to?

rvasquez
Visitor

Re: connecting vlans to speck to each other

WHat IPs are on the VLAN interfaces?
#
interface Vlan-interface1
ip address 172.16.0.39 255.255.255.0
#
interface Vlan-interface10
ip address 172.16.10.39 255.255.255.0
dhcp-server 1
address-check enable
#
interface Vlan-interface20
ip address 172.16.20.39 255.255.255.0
dhcp-server 1
address-check enable

WHat VLAN numbers?
#
vlan 1
igmp-snooping enable
#
vlan 10
description ADMON
#
vlan 20
description MTO

What VLAN config on the ports the PCs are attached to?

SWITCH HP A-5500-24G:
#
interface Ethernet1/0/8
stp edged-port enable
broadcast-suppression pps 3000
port access vlan 10
undo jumboframe enable
apply qos-profile default

SWITCH HP A-5120-48G:
#
interface Ethernet1/0/3
stp edged-port enable
broadcast-suppression pps 3000
port access vlan 10
undo jumboframe enable
apply qos-profile default

Interface tha connect both switchs:
SWITCH A-5500:
#
vlan 1
#
vlan 10
#
vlan 20
#
interface GigabitEthernet1/0/24
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 10 20

SWITCH A-5120-48G:
#
vlan 1
#
vlan 10
#
vlan 20
#
interface GigabitEthernet1/0/47
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 10 20

The cuestion is:
Which configuration to be done to connect 2 Switch´s using a port as trunk and passing several vlans (1, 10, 20)?

The software versión is:
HP A-5500-24G: Version 5.20, Release 2208P01
HP A5120-48G: Version 5.20, Release 2208P01
Vince_Whirlwind
Trusted Contributor

Re: connecting vlans to speck to each other

That looks fine. Connect those two trunk ports and everything should be hunkydory.