Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp relay-config

PIC_1
Occasional Advisor

dhcp relay-config

Hello,
We have a Mitel 3300ICP, below is our switch config. We are currently having jitter, delay, and echos. Although we know what needs to be config to correct the above faults but the problem is that when we make the change we are not able to access the via the browse to manage the 3300ICP. We were told by the Mitel team that we need to enable dhcp-relay on the our switch. It is but I am not sure how to begin configuring for the relay to work correctly. Any assistance will be great.

Thanks

hostname "PBX-5406zl"
snmp-server contact "Support"
snmp-server location "PBX Room"
web-management management-url ""
module 1 type J8702A
module 2 type J8702A
module 3 type J8705A
ip routing
snmp-server community "public" Unrestricted
snmp-server host 192.168.3.25 "public"
snmp-server host 192.168.3.164 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C24
ip address 192.168.3.240 255.255.255.0
exit
vlan 30
name "VOIP"
qos priority 6
ip address 172.168.30.254 255.255.255.0
tagged A1-A24,B1-B24,C1-C24
exit
no ip ssh
spanning-tree
password manager
password operator
12 REPLIES
Patrick Terlisten
Honored Contributor

Re: dhcp relay-config

Hello,

login to the CLI and change to the config mode.

Then:

ProCurve Switch(config)# dhcp-relay

Switch to the VLAN where do you want to use DHCP.

ProCurve Switch(config)# vlan 1
ProCurve Switch(vlan-1)# ip helper-address

The VLAN 1 needs a valid ip interface configured.

Then write config to mem and everything's fine.

Hope this helps.

Best regards,
Patrick
Best regards,
Patrick
PIC_1
Occasional Advisor

Re: dhcp relay-config


























Hello Patrick,
We tried your suggestion but it didn't work, i am thinking it's i that have made the wrong configuration. so for testing purpose we create a new vlan, id 10, we then TAGGED A9,A10 but now address from the dhcp server that is on vlan 1 was given. I set the ip-helper address on Vlan 10 to the address of the dhcp is on Vlan 1.
Any other suggestion?

Startup configuration:

; J8697A Configuration Editor; Created on release #K.13.51

hostname "MIS"
snmp-server contact "Support"
snmp-server location "I.T. Office"
web-management management-url ""
time timezone 10
module 1 type J8702A
module 2 type J8702A
module 5 type J8706A
ip routing
no timesync
snmp-server community "public" Unrestricted
snmp-server host 192.168.3.25 "public"
snmp-server host 192.168.3.164 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,A6-A8,A11-A24,B1-B24,E1-E24
ip address 192.168.3.245 255.255.255.0
no untagged A5,A9-A10
exit
vlan 30
name "VOIP"
qos priority 6
tagged A1-A4,A6-A8,A11-A24,B1-B24,E1-E22,E24
no ip address
exit
vlan 50
name "Public"
untagged A5
tagged E23
no ip address
exit
vlan 10
name "Test"
ip helper-address 192.168.3.252
tagged A9-A10
no ip address
exit
no ip ssh
spanning-tree
password manager
password operator
Patrick Terlisten
Honored Contributor

Re: dhcp relay-config

Hello,

can you provide the output of "show dhcp-relay"?

Best regards,
Patrick
Best regards,
Patrick
PIC_1
Occasional Advisor

Re: dhcp relay-config











MIS# show dhcp-relay
DHCP Relay Agent : Enabled
DHCP Request Hop Count Increment : Enabled
Option 82 : Disabled
Response validation : Disabled
Option 82 handle policy : append
Remote ID : mac


Client Requests Server Responses

Valid Dropped Valid Dropped
---------- ---------- ---------- ----------
0 0 0 0
MIS#
Patrick Terlisten
Honored Contributor

Re: dhcp relay-config

Hello,

you need a valid ip-address in the VLAN from which are the dhcp requests will be redirected. This is needed by the giaddr filed in the header. The DHCP server will be able to detect from which scope it should take an ip for the incoming request. An ip-helper entry without a ip-interface will not work.

Best regards,
Patrick
Best regards,
Patrick
PIC_1
Occasional Advisor

Re: dhcp relay-config

okay, how do we set the ip for the interface and is this done on vlan 10 instead of vlan 1 where the dhcp is on?
Pieter 't Hart
Honored Contributor

Re: dhcp relay-config

enable dhcp-relay to allow web-based management ????
sounds very strange to me.

At this time does the mittel gets an adress in vlan1 or vlan30?
you need to change the dhcp-scope so the vlan-id is added to the options send to the dhcp-client?

the 5406 knows a "interface vlan VLAN-ID voice" command.
this designates the vlan as being used for ip-phones and set extra characteristics.
Patrick Terlisten
Honored Contributor

Re: dhcp relay-config

Hi,

you need to set the ip on VLAN 10. It must be from the scope which should be used in VLAN 10 and for which the DHCP should serve ip-addresses. You can set the ip by

ProCurve Switch(config)# vlan 10
ProCurve Switch(vlan-1)# ip address xxx.xxx.xxx.xx yyy.yyy.yyy.yyy

xxx = ip-address
yyy = subnetmask

Best regards,
Patrick
Best regards,
Patrick
Pieter 't Hart
Honored Contributor

Re: dhcp relay-config

vlan 10
name "Test"
ip helper-address 192.168.3.252
tagged A9-A10
no ip address
exit

in adtion to patricks posts.
- for dhcp-relay to work, routing must be corectly configured.
so
- both vlan's need their own ip-adress/subnet.
vlan 1
name "DEFAULT_VLAN"
ip address 192.168.3.240 255.255.255.0
exit
vlan 10
name "TEST"
ip address 172.168.10.254 255.255.255.0
exit
- routing needs to be enabled
ip routing
- hosts in vlan-1 must have their default-gateway set to 192.168.3.240 (either manually or by dhcp-scope)
- create a second scope on the dhcp-server
for subnet 172.168.10.0/24
with scope-option "default gateway" set to the switch 172.168.10.254
- enable dhcp-relay on the testnetwork
vlan 10
ip helper-address 192.168.3.252
exit
- i would start testing with a normal workstation in your testvlan first
vlan 10
untagged B1
exit
- connect a pc to B1 and test dhcp operation.
the pc should get a 172.168.10.0 adress

if this works then it's time to advance to a port for the ip-phone (in multiple vlan's tagged-10 + untagged-1)
PIC_1
Occasional Advisor

Re: dhcp relay-config

Hello Guys, can you please check if the our configuration is correct? We created another scope on the dhcp server "172.168.10.0" with "default router" of 172.168.10.254.

We were still not able to get an address from the dhcp (172.168.10.0). I am sure its due to me beening a new be to this.



Startup configuration:

; J8697A Configuration Editor; Created on release #K.13.51

hostname "MIS"
snmp-server contact "Support"
snmp-server location "I.T. Office"
web-management management-url ""
time timezone 10
module 1 type J8702A
module 2 type J8702A
module 5 type J8706A
ip routing
no timesync
snmp-server community "public" Unrestricted
snmp-server host 192.168.3.25 "public"
snmp-server host 192.168.3.164 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,A6-A8,A11,A13-A24,B1-B24,E1-E24
ip address 192.168.3.245 255.255.255.0
no untagged A5,A9-A10,A12
exit
vlan 30
name "VOIP"
qos priority 6
tagged A1-A4,A6-A24,B1-B24,E1-E22,E24
no ip address
exit
vlan 50
name "Public"
untagged A5
tagged E23
no ip address
exit
vlan 10
name "Test"
untagged A12
ip helper-address 192.168.3.252
ip address 172.168.10.254 255.255.255.0
tagged A9-A10
exit
no ip ssh
spanning-tree
password manager
password operator

MIS#
EckerA
Respected Contributor

Re: dhcp relay-config

Hi,
your config looks fine.
first i would try if a client in Vlan 10 with static ip and gateway 172.168.10.254 can ping the switch and then the dhcp server.
if this works check the dhcp server. if not,
try to ping the switch from the dhcp server. check if your dhcp-server knows his way to vlan 10. What's the default gateway of the dhcp-server?
you can enable "dhcp-snooping" on the switch and "debug dhcp-snooping" with "debug destination session". then you can see if there are any dhcp-requests and replays.
hth
alex
PIC_1
Occasional Advisor

Re: dhcp relay-config

i am able to ping 172.168.10.254, dfgw on the dhcp is set to the above address