Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

do these port counters look ok ?

billmx
Occasional Contributor

do these port counters look ok ?

We are having an intermittent network problem where things grind to a halt. By this i mean I can't ping the lan interface of our router, can't access any internal or external IP addresses. After 5-10 minutes the problem resolves and this is happening maybe 3 times a month.  We have one managed switch (2848)  that 3 additional switches plugged into it on ports 46, 47,48. 

 

Can anyone with more insight look at the port counter data that I attached and let me know if the numbers might indicate a problem ? Also this switch was power cycled 4-5 days ago so the counts are from that time.

 

Thanks,

Bill

 

 

6 REPLIES
Vince_Whirlwind
Trusted Contributor

Re: do these port counters look ok ?

Others may disagree, but I personally don't believe those port counters tell you anything at all.

 

Do a "show log -r" after such an event and see what it says.

Do a "show lldp inf rem" and see what you can see.

Enable spanning-tree.

Enable loop-protect.

Enable ip igmp, per VLAN.

 

Give us a look at your switch configs so we can get an idea of what they are supposed to be doing.

 

billmx
Occasional Contributor

Re: do these port counters look ok ?

Thanks for your help on this. I will look tomorrow at enabling the options that you suggested.

 

 

Here is our config. One issue I have never been clear on is if the vlan's are infact providing any benefit in terms of segmentation, due to the command ----> 

ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

Any suggestions are appreciated.

 

=======================================

ProCurve Switch 2848# show running

Running configuration:

; J4904A Configuration Editor; Created on release #I.08.98

hostname "ProCurve Switch 2848"
ip default-gateway 192.168.1.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 192.168.1.77 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-18,30-31,33-35,38-40,42-45,47
ip address 192.168.1.251 255.255.255.0
no untagged 19-29,32,36-37,41,46,48
exit
vlan 10
name "VLANCorp"
untagged 19-29
ip address 10.10.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
vlan 2
name "VLANEng"
untagged 37,46
ip address 10.20.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
vlan 3
name "VLANMnf"
untagged 36,48
ip address 10.30.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
vlan 4
name "VLANApps"
ip address 10.40.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
vlan 5
name "VLANThermal"
untagged 41
ip address 10.50.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
vlan 6
name "VLANPub"
untagged 32
ip address 10.60.0.2 255.255.0.0
ip helper-address 192.168.1.28
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
gvrp
ip route 0.0.0.0 0.0.0.0 192.168.1.1
filter source-port "32" drop 1-31,33-43,45-48
password manager

ProCurve Switch 2848#

Vince_Whirlwind
Trusted Contributor

Re: do these port counters look ok ?

Looks fine.

 

Your default route also looks fine, and has no impact on your VLAN separation.

 

Can you clarify this for me?

 

name "VLANEng"
untagged 37,46
ip address 10.20.0.2 255.255.0.0
ip helper-address 192.168.1.28

 


For the "Eng" area, do your hosts use 10.20.0.2 as their default gateway address? (I presume they do)

 

Do you have a single switch patched back to this switch on *both* ports 37 & 46?

Or does each port go to a different switch?

If it's 2 switches, are those switches interconnected?

 

billmx
Occasional Contributor

Re: do these port counters look ok ?

Correct - the eng vlan hosts use 10.20.0.2 as their default gateway.

 

Also, port 37 is not in use. Nothing is plugged into that port. I think the eng vlan was moved from 37 to 46 at some point. 

 

I was planning to enable spanning-tree on the switch with the following commands:

 

config t

spanning-tree

write mem

 

Is there any chance this could cause problems ? (ie. should i test this off hours)

 

Thanks,

Bill

 

 

 

 

 

Vince_Whirlwind
Trusted Contributor

Re: do these port counters look ok ?

This change would be assessed as non-impacting with a low risk of anything untowaqrd happening.

 

Always do your changes out-of-hours.

 

Prepare:

 - do "sh lldp inf rem" on each switch so you can see exactly which ports are connected to other switches. Document this.

 - make sure your switches are logging. "logging severity warning" I think is enough. Syslog preferably.

 - setup a continuous ping to a host on each of your switches.

 

Then apply "spanning-tree", and "spanning-tree priority 2" (or 0, 1, or 3, whatever).

 

Now check all your switch logs and see if there are any spanning-tree events.

Check all your continuous pings and see if any were interrupted. If any were, you need to have a careful second look at the topology of the network to reacdh that device.

Then go to each switch, do a "Show spanning-tree" and check each inter-switch interface as you previously documented is forwarding. Check to see if any ports are blocking.

billmx
Occasional Contributor

Re: do these port counters look ok ?

I did enable spanning tree last night. We had our network problem around 2:15 today. Here are the logs I was able to capture during the problem. Unfortunately I unplugged the switch to try and resolve things, and I lost the earlier logs when the problem began, and also the date was reset.

 

We have a sonicwall router that the HP is connected to on Port 44. I unplugged that and also rebooted the sonicwall. Eventually the problem subsided but i'm not clear if it was anything I did, or if some process just ended.

 

 

These logs are from after the switch was powered down:

 

ProCurve Switch 2848# sh log
 Keys:   W=Warning   I=Information
         M=Major     D=Debug
----  Event Log listing: Events Since Boot  ----
M 01/01/90 00:00:14 sys: 'System reboot due to Power Failure'
I 01/01/90 00:00:14 system: --------------------------------------------------
I 01/01/90 00:00:14 system: System went down without saving crash information
I 01/01/90 00:00:56 lacp: Passive Dynamic LACP enabled on all ports
I 01/01/90 00:00:56 stack: Stack Protocol enabled
I 01/01/90 00:00:56 udpf: DHCP relay agent feature enabled
I 01/01/90 00:00:56 gvrp: GVRP Protocol enabled
I 01/01/90 00:00:56 stp: Spanning Tree Protocol enabled
I 01/01/90 00:00:57 tftp: Enable succeeded
I 01/01/90 00:00:57 system: System Booted.
I 01/01/90 00:00:57 cdp: CDP enabled
I 01/01/90 00:00:57 lldp: LLDP - enabled
I 01/01/90 00:00:58 ports: port 45 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 19 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 22 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 24 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 26 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 28 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 31 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 3 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 10 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 25 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 27 is Blocked by LACP
I 01/01/90 00:01:00 ports: port 41 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 23 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 42 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 46 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 47 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 48 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 45 is Blocked by STP
I 01/01/90 00:01:01 ports: port 45 is now on-line
I 01/01/90 00:01:01 vlan: DEFAULT_VLAN virtual LAN enabled
I 01/01/90 00:01:01 ip: DEFAULT_VLAN: network enabled on 192.168.1.251
I 01/01/90 00:01:01 ports: port 15 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 43 is Blocked by LACP
I 01/01/90 00:01:01 ports: port 44 is Blocked by LACP
I 01/01/90 00:01:02 ports: port 1 is Blocked by LACP
I 01/01/90 00:01:02 ports: port 4 is Blocked by LACP
I 01/01/90 00:01:02 ports: port 29 is Blocked by LACP
I 01/01/90 00:01:02 ports: port 36 is Blocked by LACP
I 01/01/90 00:01:03 ports: port 19 is Blocked by STP
I 01/01/90 00:01:03 ports: port 22 is Blocked by STP
I 01/01/90 00:01:03 vlan: VLANCorp virtual LAN enabled
I 01/01/90 00:01:03 ports: port 24 is Blocked by STP
I 01/01/90 00:01:03 ports: port 26 is Blocked by STP
I 01/01/90 00:01:03 ports: port 28 is Blocked by STP
I 01/01/90 00:01:03 ports: port 31 is Blocked by STP
I 01/01/90 00:01:03 ports: port 19 is now on-line
I 01/01/90 00:01:03 ports: port 22 is now on-line
I 01/01/90 00:01:03 ports: port 24 is now on-line
I 01/01/90 00:01:03 ports: port 26 is now on-line
I 01/01/90 00:01:03 ports: port 28 is now on-line
I 01/01/90 00:01:03 ports: port 31 is now on-line
I 01/01/90 00:01:03 ip: VLANCorp: network enabled on 10.10.0.2
I 01/01/90 00:01:03 ports: port 3 is Blocked by STP
I 01/01/90 00:01:03 ports: port 10 is Blocked by STP
I 01/01/90 00:01:03 ports: port 25 is Blocked by STP
I 01/01/90 00:01:03 ports: port 27 is Blocked by STP
I 01/01/90 00:01:03 ports: port 41 is Blocked by STP
I 01/01/90 00:01:03 ports: port 3 is now on-line
I 01/01/90 00:01:03 vlan: VLANThermal virtual LAN enabled
I 01/01/90 00:01:03 ports: port 10 is now on-line
I 01/01/90 00:01:03 ports: port 25 is now on-line
I 01/01/90 00:01:03 ports: port 27 is now on-line
I 01/01/90 00:01:03 ports: port 41 is now on-line
I 01/01/90 00:01:03 ip: VLANThermal: network enabled on 10.50.0.2
I 01/01/90 00:01:04 ports: port 23 is Blocked by STP
I 01/01/90 00:01:04 ports: port 42 is Blocked by STP
I 01/01/90 00:01:04 ports: port 46 is Blocked by STP
I 01/01/90 00:01:04 ports: port 47 is Blocked by STP
I 01/01/90 00:01:04 vlan: VLANEng virtual LAN enabled
I 01/01/90 00:01:04 ports: port 48 is Blocked by STP
I 01/01/90 00:01:04 ports: port 23 is now on-line
I 01/01/90 00:01:04 vlan: VLANMnf virtual LAN enabled
I 01/01/90 00:01:04 ports: port 42 is now on-line
I 01/01/90 00:01:04 ports: port 46 is now on-line
I 01/01/90 00:01:04 ports: port 47 is now on-line
I 01/01/90 00:01:04 ports: port 48 is now on-line
I 01/01/90 00:01:04 ip: VLANEng: network enabled on 10.20.0.2
I 01/01/90 00:01:04 ip: VLANMnf: network enabled on 10.30.0.2
I 01/01/90 00:01:04 ports: port 15 is Blocked by STP
I 01/01/90 00:01:04 ports: port 43 is Blocked by STP
I 01/01/90 00:01:04 ports: port 44 is Blocked by STP
I 01/01/90 00:01:04 ports: port 15 is now on-line
I 01/01/90 00:01:04 ports: port 43 is now on-line
I 01/01/90 00:01:04 ports: port 44 is now on-line
I 01/01/90 00:01:05 ports: port 1 is Blocked by STP
I 01/01/90 00:01:05 ports: port 4 is Blocked by STP
I 01/01/90 00:01:05 ports: port 29 is Blocked by STP
I 01/01/90 00:01:05 ports: port 1 is now on-line
I 01/01/90 00:01:05 ports: port 4 is now on-line
I 01/01/90 00:01:05 ports: port 29 is now on-line
I 01/01/90 00:01:05 ports: port 36 is Blocked by STP
I 01/01/90 00:01:05 ports: port 36 is now on-line
I 01/01/90 00:01:11 ports: port 44 is now off-line
I 01/01/90 00:01:15 ports: port 44 is Blocked by LACP
I 01/01/90 00:01:16 ports: port 30 is Blocked by LACP
I 01/01/90 00:01:18 ports: port 44 is Blocked by STP
I 01/01/90 00:01:18 ports: port 44 is now on-line
W 01/01/90 00:01:18 FFI: port 22-Excessive jabbering. See Help
W 01/01/90 00:01:18 FFI: port 22-Excessive CRC/alignment errors. See help.
W 01/01/90 00:01:18 FFI: port 24-Excessive jabbering. See Help
W 01/01/90 00:01:18 FFI: port 24-Excessive CRC/alignment errors. See help.
W 01/01/90 00:01:18 FFI: port 26-Excessive CRC/alignment errors. See help.
I 01/01/90 00:01:19 ports: port 30 is Blocked by STP
I 01/01/90 00:01:19 ports: port 30 is now on-line
I 01/01/90 00:01:36 ports: port 43 is now off-line
I 01/01/90 00:01:40 ports: port 43 is Blocked by LACP
I 01/01/90 00:01:43 ports: port 43 is Blocked by STP
I 01/01/90 00:01:43 ports: port 43 is now on-line
I 01/01/90 00:03:15 ports: port 36 is now off-line
I 01/01/90 00:03:17 ports: port 36 is Blocked by LACP
I 01/01/90 00:03:18 ports: port 36 is now off-line
I 01/01/90 00:03:21 ports: port 36 is Blocked by LACP
I 01/01/90 00:03:21 ports: port 36 is Blocked by STP
I 01/01/90 00:03:21 ports: port 36 is now on-line
W 01/01/90 00:03:52 FFI: port 31-High collision or drop rate. See help.
I 01/01/90 00:04:25 ports: port 44 is now off-line
I 01/01/90 00:04:28 ports: port 44 is Blocked by LACP
I 01/01/90 00:04:31 ports: port 44 is Blocked by STP
I 01/01/90 00:04:31 ports: port 44 is now on-line
I 01/01/90 00:06:39 ports: port 43 is now off-line
I 01/01/90 00:06:43 ports: port 43 is Blocked by LACP
I 01/01/90 00:06:46 ports: port 43 is Blocked by STP
I 01/01/90 00:06:46 ports: port 43 is now on-line
I 01/01/90 00:06:51 ports: port 44 is now off-line
I 01/01/90 00:07:06 ports: port 43 is now off-line
I 01/01/90 00:08:35 ports: port 44 is Blocked by LACP
I 01/01/90 00:08:38 ports: port 44 is Blocked by STP
I 01/01/90 00:08:38 ports: port 44 is now on-line
W 01/01/90 00:09:46 FFI: port 30-High collision or drop rate. See help.
W 01/01/90 00:09:46 FFI: port 31-High collision or drop rate. See help.
W 01/01/90 00:22:45 auth: Invalid user name/password on TELNET session
I 01/01/90 00:23:52 mgr: SME TELNET from 10.30.0.119 - MANAGER Mode