Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

gbe2c VLAN

Zeee
Occasional Contributor

gbe2c VLAN

I posted this on the Bladeserver forum, posting here too in case that is the incorrect place.

Hi

I am trying to trunk VLAN information to a BL460 blade in a C7000 chassis. We have a gbe2c switch. Not used the C7000 or gbe2c before so pls bear with me

Need to allow untagged traffic (VLAN1) and two tagged VLANs (101 and 102) which are also defined on an external switch (a Powerconnect 6224).

I have port 21 from each gbe2c uplinked to a trunk port on the Powerconnect. Blade 5 needs to see untagged (VLAN1), vlan 101 and vlan 102 traffic. So I have added ports 5,17,18 and 21 as a member of VLAN 1, 101 and 102. The VLANs are each in a seperate STP group (I have tried turning off STP).

Config:

/* Enclosure: 403320-B21, EnclosureName: ENCLOSURE1
/* Slot: 2
/c/port 5
tag ena
/c/port 17
tag ena
/c/port 18
tag ena
/c/port 21
tag ena
/c/l2/vlan 101
ena
name "Storage1"
def 5 17 18 21
/c/l2/vlan 102
ena
name "Storage2"
def 5 17 18 21
/c/l2/stp 1/port 5/on
/c/l2/stp 2/clear
/c/l2/stp 2/add 101
/c/l2/stp 3/clear
/c/l2/stp 3/add 102
/c/l3/if 1
* ena
* addr
/c/l3/gw 1
* ena
* addr
/c/l3/dns
* prima
* secon
/
script end /**** DO NOT EDIT THIS LINE!

I have added three VLANs in NCU on the blade: 1, 101 and 102. VLAN 1 works fine although I think this is just the PVID working.

Does anything jump out above as incorrect? Currently I can't see VLAN 101 or 102, i.e. I can't ping the IP address set for either of these VLANs on the Powerconnect from the virtual NIC created by NCU with above config.

Any help appreciated - like I said above first experience with a HP Blade chassis.

TIA

Zee
4 REPLIES
JedE
Occasional Advisor

Re: gbe2c VLAN

Zee,

This looks correct assuming you are using ports 17 and 18 correctly. These are reserved as cross links so assume you have two GbE2c switches interlinked and a single blade in chassis slot 5. I assume the config is the same on both switches?

Are you happy you've got the BL860 in the correct slot and it connects to the GbE2c over the backplane correctly as the port connectivity is statically configured. The /info commands below should help you confirm this.

You said you tried disabling STP, I assume this failed as you have a loop going through the GbE2c switchs back to the 6224?

Have you been through some of the basic troubleshooting steps:

1) Check configs using /info commands to see it is applied correctly (possible to forget to use the 'apply command !)
2) Checked the links are up and running with no errors (/info/link & /stat commands)
3) Checked /info/l2/fdb to see if the MAC addresses are as expected
4) Checked VLANs are correct with /info/port. Useful for checking PVID too.
5) Tried allocating IP address to the GbE2c switch in VLANs 101 and 102 and run ping checks to/from the switch.
6) Disabled one switch to simplify troubleshooting (disable port 5 and 21)

Jed

Zeee
Occasional Contributor

Re: gbe2c VLAN

Thanks Jed for your reply.

As far as I can make out only one of the two switches is active, it's not possible to change anything on the other. Ports 21 on each side only are uplinked into the Dell switch - I'll worry about LACP etc when I have the basics working.

I have ports 17 and 18 enabled. I'll try disabling STP right the way through since I couldn't tell you for certain if I had it disabled properly before.

The blade server is definately in slot 5 and it's definately port 5 which it sees.

I'll try running those commands now. I did note that the software on the switch is very old indeed (1.0.0), I'll upgrade that to latest too.

Thanks again

Zee
Zeee
Occasional Contributor

Re: gbe2c VLAN

Hi again

Output from the info menu:

Port info (truncated to relevant):

Port Tag RMON PVID NAME VLAN(s)
---- --- ---- ---- -------------- -------------------------------
5 y d 1*Downlink5 1 101 102
17 y d 1*Xconnect1 1 101 102
18 y d 1*Xconnect2 1 101 102
21 y d 1*Uplink2 1 101 102

Everything else is:

10 n d 1*Downlink10 1

Link info (17,18 should these be down?)

------------------------------------------------------------------
Port Speed Duplex Flow Ctrl Link
----- ----- -------- --TX-----RX-- ------
5 1000 full no no up
17 any full yes yes down
18 any full yes yes down
21 1000 full no no up

STP:

Port Priority Cost FastFwd State Designated Bridge Des Port
---- -------- ---- -------- ------- --------------------- --------
5 128 4 n FORWARDING 8000-00:17:ef:7f:82:00 8005
17 128 4 n DISABLED
18 128 4 n DISABLED
21 128 4 n FORWARDING 8000-00:16:e0:90:03:80 800d
* = STP turned off for this port.

Thanks
JedE
Occasional Advisor

Re: gbe2c VLAN

It sounds like you have the two GbE2c switches not interconnected as ports 17 and 18 are not up so there should be no STP loop. As such disabling or enabling STP should have no real impact, although I'd disable it if there's definitely no loop. GbE2c has had some STP issues in earlier releases although more than likely very stable by now.

When you turn STP off you can see it's off in the /port output, I seem to recall it's something simple like /c/stp/off.

The current GbE2c release is 2.0.60, upgrade is fairly straight forward.

The other ports look to be configured ok.

You won't be able to setup a single LACP trunk from the two GbE2c switches to the Dell, only if you have multiple uplinks to bundle from one GbE2c to the Dell switch. LACP is single switch to single switch.

Try the IP address allocation suggestion to see which links are working correctly.

Try removing the trunking and work over a single VLAN to see if it's the trunking that's the issue.

Check the log file to see if that tells you anything useful.

Jed