Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

hp 2910al switch trunking and basic understanding

SOLVED
Go to solution
hpneed
Occasional Visitor

hp 2910al switch trunking and basic understanding

Hi All,
I've attached diagram that I want to setup in my client network. I have never done HP switch configuration before and want to configure it as you can see in the diagram. I want to setup following things on the Switch 1 and 2.

1. Configure 2 vlans on both switches so they can communicate with each others. How would I configure trunk ports on both switches.

2. How do I setup DHCP on switch-2. Switch-1 does not need to have DHCP at all as it has server with DHCP scope.

3. How would I configure routing for both VLANS on both switches ?

Would you please guide me through AS soon As you can...
12 REPLIES
hpneed
Occasional Visitor

Re: hp 2910al switch trunking and basic understanding

Someone can respond to my questions pls.. its quite urgent..
EckerA
Respected Contributor
Solution

Re: hp 2910al switch trunking and basic understanding

ok,
let's see:

conf t
trunk 1,2 trk1 trunk //<--Uplink between the switches
vlan 1
ip address 180.10.1.1(2)/24//.1 at switch 1 and .2 at switch 2
tagged trk1
untagged 3-10// native ports of vlan 1
exit
vlan 2
ip address 180.10.2.1(2)/24//.1 at switch 1 and .2 at switch 2
tagged trk1
untagged 11-24// native ports of vlan 2
exit
wr mem

thats basically the config for both switches


on switch 1

conf t
ip routing
ip route 0.0.0.0 0.0.0.0
wr mem


on switch 2
conf
ip default gateway 180.10.1.1
wr mem

in this setup you don't need routing at switch 2!
at the clients of vlan 1 you apply 180.10.1.1 as default gateway and on vlan 2 you apply 180.10.2.1 as default gateway.

at your fw you need a route like:

ip route 180.10.2.0 255.255.255.0 180.10.1.1//ip of switch 1 in vlan 1


the HP switche can't act as DHCP-Server, you only can apply a dhcp-relay

on switch 1
conf
vlan 2
ip helper-address
exit
wr mem

hth
alex
Pieter 't Hart
Honored Contributor

Re: hp 2910al switch trunking and basic understanding

Your configuration is commonly used.
There are many posts allready present on this forum.
If it's that urgent try a search first.

In adition to Alex's post:
Switch-2 does not need to be setup for DHCP.
DHCP-requests within a vlan are broadcasted among the whole vlan, so it's also received at switch-1.
If it's on the same vlan as the dhcp-server, it's also recieved by this server, so no problem there.
If it's on another vlan, then switch-1 must route it to the vlan where the dhcp-server resides, that's done by the ip-helper setting as described by Alex.

your dhcp-server must be configured with multiple scopes, one for each vlan/subnet!
You may need to look into that.

The scope for vlan-1 must have the default-gateway set to switch-1's ip-address for vlan-1, and the scope for vlan-2 must have it set to switch-1's address for vlan-2, etc.

regards,
Pieter
hpneed
Occasional Visitor

Re: hp 2910al switch trunking and basic understanding

Thank you very much for your replies..

My DHCP is server is sitting behind the VLAN-1 scope for VLAN-2 so I will configure ip-helper command as mentioned here.

Do I need to write route on both switches to reach to each others subnets ?
such as
on switch1 :

route 180.10.2.x 255.255.255.0 180.10.2.242 ( Switch 2 Vlan 2 IP address )

and on Switch 2 :

route 180.10.1.x 255.255.255.0 180.10.1.241 ( Switch 1 Vlan 1 IP Address )

Can you pls advise me this ..

Thanks,
EckerA
Respected Contributor

Re: hp 2910al switch trunking and basic understanding

Hi,

no you don't need to add those routes.
on switch 1, which is doing all the intervlan routing, it will be added automatically.

hth
alex
Ezugo
Advisor

Re: hp 2910al switch trunking and basic understanding

if a VLAN on a switch is given an IP range - does any device connecting to it automatically recieve an IP from that range?
hpneed
Occasional Visitor

Re: hp 2910al switch trunking and basic understanding

NO, I dont think VLAN can assign IP address automatically to any other device.. You need to have DHCP scope to get IP address automatically.
If someone else can throw some light on this too pls.
Pieter 't Hart
Honored Contributor

Re: hp 2910al switch trunking and basic understanding

To Ezugo (I think it should have been a new thread)
A vlan only serves to group some ports as if they are in a different LAN.
It basically has no knowledge of ip-adresses.
You can do any protocol other than tcp/ip on such (V)LAN.

You assign an ip-address to the switch for management purposes, or if the switch must function as tcp/ip-router.
You can use any adress on any (v)lan even duplicate adresses on different vlans as long as they don't need to communicate with one another..

Assigning an address to a vlan on a switch is not enough.
Ip-adresses kan be dynamically assigned by a DHCP-server. In smaller networks some network-device (like ADSL-router) can do this, but mostly it is a separate server (windows, unix, etc).
hpneed
Occasional Visitor

Re: hp 2910al switch trunking and basic understanding

Hello Guys,

I have a different feeling here. I am wondering that why would I use 2 VLANs here. let me tell you my scenario again. I am so confused and need your assistance for designing 2 procure 2910al-24G switch.

1. Switch-1 subnet 180.10.1.0/24
2. Switch -2 subnet 180.10.2.0/24
3. How would I configure Switch-2 to talk with Switch-1 subnet.

MY Plan:

I am planning on configuring 1 vlan on both side and assign IP address on switch-1 port 24 : 180.10.2.241/24 and Switch-2 port 24 : 180.10.2.242/24 and configure there both switch port as trunk port. And configure switch-2 default gateway as 180.10.2.241 and Switch-1 default gateway will be my firewall IP and firewall will have a return route for 180.2.10.0/24 network.

Can someone guide me whether this is going to work or not.

Your assistance will be much more helpful...
Pieter 't Hart
Honored Contributor

Re: hp 2910al switch trunking and basic understanding

Most info is allready in the previous answers.

3. How would I configure Switch-2 to talk with Switch-1 subnet.
you need a router to enable communication between different subnets.
when both subnets are used on different vlans, this router must have two interfaces, one in each vlan/subnet.

this can be done by the firewall, or by one of the switches

If you use switch-1 for this, switch-2 does not do any routing and only needs an ip-adress for management.

you need to make switch-2's vlan avalable on switch-1
you do this by configuring the vlans on the ports that connect the switches
(untagged/tagged or both tagged)
lets say port 24 both switches
>>>
vlan1
untagged 24
vlan2
tagged 24
<<<
you configure the ip-adress not on the interface, but on the vlan.
switch-1
>>>
vlan1
ip adress 180.10.1.1/24
vlan2
ip adress 180.10.2.1/24
ip helper (for dhcp-relay)
<<<
switch-2
>>>
vlan1
ip adress 180.10.1.2/24
vlan2
ip adress 180.10.2.2/24 (not really necessary)
<<<
and enable routing on switch-1
>>>
ip routing
ip route 0.0.0.0 0.0.0.0
<<<
+ firewall will have a return route for 180.2.10.0/24 network. to switch-1
Deeps
Occasional Visitor

Re: hp 2910al switch trunking and basic understanding

Can any one help me. what type of cable is required for trunking between two switches ?

Arimo
Respected Contributor

Re: hp 2910al switch trunking and basic understanding

Hi Deeps

 

Doesn't matter. The rules for trunking (Link Aggregtion) are simple.

 

- the members of the trunk must be same speed/duplex - no trunking 100Mb/s port with a Gig port

- the members of the trunk must be same media type - no trunking Fiber with Copper

- the members of the trunk must be co-terminating - no connecting Switch A port 1 to Switch B and Switch A port 2 to Switch C

 

I assume we're talking about normal Link Aggregation, not Distributed Trunking. If you're doing DT the third rule doesn't exist.


HTH,

Arimo
HPE Networking Engineer