Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

hpSwitchPortTrunkLACPStatus mib

SOLVED
Go to solution
Andrea Francesconi
Occasional Contributor

hpSwitchPortTrunkLACPStatus mib

Hi.
My config over HP 2848:

HP2848# show lacp

LACP

PORT LACP TRUNK PORT LACP LACP
NUMB ENABLED GROUP STATUS PARTNER STATUS
---- ------- ------- ------- ------- -------
1 Passive 1 Up No Success
2 Passive 2 Up No Success
3 Active Trk1 Up No Success
4 Active Trk1 Up No Success

HP2848# show trunks

Load Balancing

Port | Name Type | Group Type
---- + -------------------------------- --------- + ----- -----
3 | 100/1000T | Trk1 LACP
4 | 100/1000T | Trk1 LACP

#sh running
...
trunk 3-4 Trk1 LACP
...
This walkmib return me:
HP2848# walkmib hpSwitchPortTrunkLACPStatus
hpSwitchPortTrunkLACPStatus.1 = 3
hpSwitchPortTrunkLACPStatus.2 = 3
hpSwitchPortTrunkLACPStatus.3 = 1
hpSwitchPortTrunkLACPStatus.4 = 1

but if I look in mib file (hpSwitchConfig.mib):

hpSwitchPortTrunkLACPStatus OBJECT-TYPE
SYNTAX INTEGER {
disabled(1),
active(2),
passive(3)

Why walkmib command report 1 instead 2?
Thank you,
fRANz
2 REPLIES
Ardon
Trusted Contributor
Solution

Re: hpSwitchPortTrunkLACPStatus mib

Hi Franz,

First of all your LACP Trunk Ports are connected to what other kind of Switch as obviously the Trunk does not initialize. Your port #1 & #2 are configured for Active LACP so the connecting Switch should have ports that run either Passive OR Active LACP.
Say the remote switch ports run LACP Passive the Show Trunk output will look like this:

ProCurve Switch 5406zl# sh trunk

Load Balancing

Port | Name Type | Group Type
---- + -------------------------------- --------- + ----- -----
A10 | 100/1000T | Dyn1 LACP
A11 | 100/1000T | Dyn1 LACP

So it looks like you remote switch does not have LACP (Passive or Active) running.

Regarding you MIB question:

I just tested shortly and found out that the WalkMib hpSwitchPortTrunkLACPStatus results depend on HOW you configure the LACP Trunk.
If you configure it from the CLI using the command "(config)# trunk a2-a3 trk2 lacp" and the issue the "walkmib hpSwitchPortTrunkLACPStatus" it will return a value of 1 (Disabled) for the LACP Trunk:

walkmib hpSwitchPortTrunkLACPStatus
hpSwitchPortTrunkLACPStatus.1 = 3
hpSwitchPortTrunkLACPStatus.2 = 1
hpSwitchPortTrunkLACPStatus.3 = 1

if you however just enter the Interface Configuration Level and issue the "lacp active" command and then issue a walkmib hpSwitchPortTrunkLACPStatus a value of 2 will be returned as this is a real Dynamic Trunk while the other one is a Static Trunk.

Hope this helps.

Regards, Ardon
ProCurve Networking Engineer
Andrea Francesconi
Occasional Contributor

Re: hpSwitchPortTrunkLACPStatus mib

Hi Ardon,

thank you for your reply.

> First of all your LACP Trunk Ports are
> connected to what other kind of Switch
> as obviously the Trunk does not initialize.
> Your port #1 & #2 are configured for
> Active LACP so the connecting Switch
> should have ports that run either Passive
> OR Active LACP.

> So it looks like you remote switch does
> not have LACP (Passive or Active) running.

Connected to my Procurve there isn't another switch, but an VMware ESX with an Ethernet Trunk. Now, I don't know if my config is perfectly, but in this situation trunk seems work correctly (I can see traffic in both ports, and if one link goes down, every connection switch to the other one). Which differences between Active or Passive LACP trunk with VMware? Other users, in VMware forums, config trunk like me.

> Regarding you MIB question:

> if you however just enter the Interface
> Configuration Level and issue the "lacp
> active" command and then issue a
> walkmib hpSwitchPortTrunkLACPStatus a value > of 2 will be returned as this is a real
> Dynamic Trunk while the other one is a
> Static Trunk.

Sorry Ardon, you see what I do but you don't know what I want. =)
Sometimes, when I reboot ESX, trunk don't correctly startup, and when I do a 'show lacp' return me that there's an error, everytime I disable one of port, than I re-enable it, and trunk goes active. I'm looking for a mib that guerantee me trunk is up (and correctly work).

Thank you again,
-f