Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

hpux 10.20 100Mbs NIC fails periodically after network move

Peter Rupp_2
Occasional Contributor

hpux 10.20 100Mbs NIC fails periodically after network move

Hi folks,
We're stumped here, and hoping somebody could lend us some advice.

We have several HPUX 10.20 systems on older H/I/G equipment that use the A3495A 10/100Mbs nic that is configured via the file /etc/rc.config.d/hpbasetconf.

Previously, these systems were living in a remote data center connected older Bay Networks switche -- The A3495A and network port-switch were both locked down at 100Mbs/FDX, and everything ran fine for years.

We moved the systems to a new location using Cisco 6500 equipment and setup the ports the exact same way (locked down at 100/FDX), and the cards as well....thats when the problems started:

On half the systems, when HPUX is booted, or at some undetermined amount of time after boot...the A3495A's "self test" amber light comes on - indicating a hardware failure. Then the netork comes down. Sometimes the server bootes with no problems (self test light off), and networking works, other times it fails...completely random.

We tried setting both card and switch to AUTO negotiate, and the same inconsistent behaviors - sometimes the card works, and unexplainabley fails.

The only errors we get are during bootup, we simply get "FAILED TO INITIALIZE CARD" message.

In some cases, we can activate the card via repeatidly executing: /sbin/init.d/hpbaset start.

Sometimes the card works, or in other cases the card completely vanishes from the ioscan, and lanscan displays!

We tried replacing the cable, which appeard to work...for a while, then the same problem occured again.

I don't know how the card's are initialized, but for some reason, they cannot seem to talk to the newer CISCO 6500 switches.

If there's any advice you have, I would really apprecaite it.

Thanks for your help.
2 REPLIES
claramunt_1
Advisor

Re: hpux 10.20 100Mbs NIC fails periodically after network move

It's seems to be a hw problem. I'll try to swap two cards between a system that works fine and a system that fails or replace a failed hard.
Thomas Bianco
Honored Contributor

Re: hpux 10.20 100Mbs NIC fails periodically after network move

older HP network cards are notoriously bad at autonegotiation, i'd hard set speed and duplex on both the server and switchport.

however, the beheviour your describing isn't due to a duplex problem, it seems to be an issue with the card itself. if you have spare cards, swap them out and see if that works.
There have been Innumerable people who have helped me. Of course, I've managed to piss most of them off.