Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

intermittent connection between switches

SOLVED
Go to solution
John Orme
Frequent Advisor

intermittent connection between switches

Hi,

I have a network consisting of 10 switches, 2 4108s and 8 2524s.
Recently I have started having connection issues between the switches. I may lose 1 packet in 4 when pinging, there seems to be no pattern.

I used to have the 4108s set up with a 4 port trunk but that doesnt work anymore, despite the settings being corect. I now have them connected with a single gigabit link.

Can anyone help? I just dont know where to start.

Thanks
11 REPLIES
John Orme
Frequent Advisor

Re: intermittent connection between switches

I have updated the firmware on the 2 4108s and the 2524 that is experiencing problems. This switch is connected with a 2 port trunk. It would seem that it is only trunks that have problems.


PC A ----- Switch A 4108 ------Switch B 2524

If I ping switch B from PC A I get intermittent results but if I ping switch B from Switch A, I get perfect results.

Does this make sense?

Thanks
Mohieddin Kharnoub
Honored Contributor

Re: intermittent connection between switches

Hi

Make sure you don't have a network loop that causes some kind of storms affecting your traffic.

Also, if you can delete the trunk and just connect one cable then check the status of the network.

Make sure the configuration of the trunk is correct, and if you are using LACP, be aware that LACP by default is passive, and to form a dynamic LACP you need at least one side to be LACP active.

If that doesn't help, attach the configuration of your 4100 and 2524 here and you will find help.

Good Luck !!!
Science for Everyone
John Orme
Frequent Advisor

Re: intermittent connection between switches

Hi,

I have loops in the network where the switches connect for redundancy and all switches are using RSTP, as far as I can tell, it is ok but the traffic does seem heavy when looking at the switch indicators.

The trunk type is "TRUNK" LACP is not used.

When using a single cable with no trunking, the network is fine.

Next thing, how do I get the config from the switch?
Mohieddin Kharnoub
Honored Contributor

Re: intermittent connection between switches

Hi

Telnet to that switch OR connect by console cable and issue the command:

Switch#Show run

Or open the WEB interface of the switch, and from Diagnostics select Configuration Report.

copy the configuration and remove any sensitive info. then post it here.

Good Luck !!!
Science for Everyone
John Orme
Frequent Advisor

Re: intermittent connection between switches

Thanks,

4108 config:

Running configuration:

; J4865A Configuration Editor; Created on release #G.07.104

hostname "HP ProCurve Switch 4108GL"
snmp-server location "WC/1 (Server Room)"
cdp run
module 8 type J4864A
module 3 type J4908A
module 5 type J4908A
module 4 type J4908A
module 7 type J4908A
module 1 type J4908A
module 2 type J4908A
module 6 type J4908A
interface G13
no lacp
exit
interface G14
no lacp
exit
interface G15
no lacp
exit
interface G16
no lacp
exit
interface G19
no lacp
exit
interface G20
no lacp
exit
trunk G13-G16 Trk2 Trunk
trunk G19-G20 Trk1 Trunk
ip default-gateway 192.xxx.xx.1
snmp-server community "public" Unrestricted
snmp-server host 192.xxx.xx.xxx "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A22,B1-B22,C1-C22,D1-D22,E1-E22,F1-F22,G1-G12,G17-G18,G21-G22,H1-
H3,Trk1-Trk2
ip address 192.xxx.xx.xxx 255.255.255.0
exit
spanning-tree
no spanning-tree H1 edge-port
no spanning-tree H2 edge-port
no spanning-tree H3 edge-port
no spanning-tree Trk1 edge-port
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4

2524 Config:
WC/10 (xxxxxxxxxxxxx)(config)# show run

Running configuration:

; J4813A Configuration Editor; Created on release #F.05.61

hostname "WC/10 (xxxxxxxxxxxxxx)"
snmp-server contact "John Orme"
snmp-server location "WC/10 (xxxxxxxxxxxxxx)"
time daylight-time-rule Western-Europe
cdp run
console baud-rate 115200
interface 25
speed-duplex auto-1000
no lacp
exit
interface 26
speed-duplex auto-1000
no lacp
exit
trunk 25-26 Trk1 Trunk
ip default-gateway 192.xxx.xx.x
timesync sntp
sntp broadcast
no lacp
exit
interface 26
speed-duplex auto-1000
no lacp
exit
trunk 25-26 Trk1 Trunk
ip default-gateway 192.xxx.xx.1
timesync sntp
sntp broadcast
snmp-server community "public" Unrestricted
snmp-server host 192.xxx.xx.xxx "public" Not-INFO
vlan 1
name "DEFAULT_VLAN"
untagged 1-24,Trk1
ip address 192.xxx.xx.xxx 255.255.255.0
exit
no aaa port-access authenticator active
spanning-tree
no spanning-tree Trk1 edge-port
spanning-tree Trk1 priority 4
password operator


Thanks :)
Mohieddin Kharnoub
Honored Contributor
Solution

Re: intermittent connection between switches

Hi

I think you should add the following commands just to be sure that your 4100's are the root for your Spanning Tree topology:

On 1st 4100:
SW1(config)#span priority 0

and on the 2nd 4100:
SW2(config)#span priority 1

Also,
Delete the trunk TRK1, then re-create it again on both sides (4100 and 2500) and test your spanning tree topology with some show commands that will help you uderstand if there is an issue like big number for Topology changes :

Show span

Good Luck !!!
Science for Everyone
John Orme
Frequent Advisor

Re: intermittent connection between switches

I made those changes but it made no difference. It doesnt make sense as it pings fine from the 4108 but not from something connected to the 4108. It is as if the 4108 isnt forwarding packets to trunk ports.
John Orme
Frequent Advisor

Re: intermittent connection between switches

I have finally resolved this.

It seems that the 20 port 10/100/1000 module J4908A is not compatible with connections to the 1000mb module on the 2524.

I have remade the trunk using connections on the J4863A 6 port module and all seems well so far.

Thanks for your help
OLARU Dan
Trusted Contributor

Re: intermittent connection between switches

any news on this thread?
Mohieddin Kharnoub
Honored Contributor

Re: intermittent connection between switches

Hi OLARU

the news that the trunk was incorrectly configured and the ports were improperly chosen.

Good Luck !!!
Science for Everyone
John Orme
Frequent Advisor

Re: intermittent connection between switches

I put it down to a compatibility issue with the modules rather than a configuration issue.