Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

intraVlan routing

Roberto Cremasco
Occasional Advisor

intraVlan routing

i have a 5304 switch connected to a old Digital router, and OSPF is up and running.

on the 5304 i have 2 vlan with a relative ip address.

Why the switch doesn't see the second vlan as "connected"?
As you can see in the attached Sho ip route, the entry for the network 10.10.123.0 is not present.
The result is that the switch is not able to ping it self of 10.10.123.1.


attacher the configuration and the sho ip route.


----

ip default-gateway 10.113.0.1
sntp server 10.100.0.231
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A11-A24
ip address 10.113.1.1 255.255.0.0
no untagged A1-A10
exit
vlan 123
name "VCR-MIR"
untagged A1-A10
ip address 10.10.123.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 10.113.0.1
ip router-id 10.113.1.1
ip ssh
router ospf
area backbone
redistribute connected
redistribute static
exit
vlan 1
ip ospf area backbone
exit
vlan 123
ip ospf area backbone
exit
password manager
password operator

----

Show Ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 10.113.0.1 1 static 1 1
10.10.0.0/23 10.113.0.1 1 ospf IntraArea 13 110
10.10.2.0/23 10.113.0.1 1 ospf IntraArea 13 110
10.10.62.0/24 10.113.0.1 1 ospf IntraArea 13 110
10.10.63.0/24 10.113.0.1 1 ospf IntraArea 13 110
10.10.124.0/22 10.113.0.1 1 ospf IntraArea 13 110
10.10.128.0/23 10.113.0.1 1 ospf External2 1 110
10.112.0.0/16 10.113.0.1 1 ospf IntraArea 12 110
10.113.0.0/16 DEFAULT_VLAN 1 connected 0 0
10.115.0.0/16 10.113.0.1 1 ospf IntraArea 783 110
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
160.80.212.82/32 10.113.0.1 1 ospf External2 10 110

2 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: intraVlan routing

Hi

The Vlan IP Address won't be inserted in the Routing Table unless you have at least one link on this Vlan is UP.

And this simple rule reflects the idea of that, the IP address of this Vlan is in fact a Virtual Interface,
and that Interface should be UP to be inserted in the Routing table, and to make it UP as a Vlan, any link untagged or tagged to this Vlan should be UP.

Good Luck !!!
Science for Everyone
Roberto Cremasco
Occasional Advisor

Re: intraVlan routing

Thanks