Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ip-helper with Avaya phone system on 2650 switch

Mark Alderson_1
Occasional Advisor

ip-helper with Avaya phone system on 2650 switch

I'm having problems getting this working on a test system in preparation for rolling live. This config is fairly basic but based on what we have currently.3

hostname "ProCurve Switch 2650-PWR"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
no ip address
no untagged 1-50
exit
vlan 10
name "VOICE"
untagged 1,37
ip address 10.40.10.1 255.255.255.0
ip helper-address 10.30.10.2
tagged 2-47,49-50
exit
vlan 20
name "DATA"
untagged 2-48
ip address 10.30.10.1 255.255.255.0
tagged 49-50
exit
password manager

DHCP relay is started but the phones will not get an IP address from the server on port 48 and I can't see why. Phone is on port 37 just to avoid confusion. I'm probably missing something obvious but ....
20 REPLIES
KSimpson
Frequent Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Why are ports 2-37 untagged and Tagged on the 10 VLAN? Not sure if it will help before plug the phone into port 1. Ports 2-37 shouldnt be both untagged and tagged should they?

KSimpson
Frequent Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Plus port 48 isn't tagged for the vlan 10. The traffic will never be seen on port 48.
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

I'll give some background. Default config for this (which is currently running absolutely perfectly) has a DHCP server with 2 IP's, one running on each VLAN. I'm trying to bypass that with setting the ip helper-address. The current config has every port tagged for VOICE vlan (10) and the uplink ports only tagged for DATA vlan (20) with all other ports being untagged for data apart from the DHCP servers which are set to only communicate on their specific VLAN's.

Port 1 is missed simply as it's my test config, and the HP software has done one as it's reporting port 37 as being both tagged and untagged for vlan 10 which isn't possible, when in fact it is only tagged (I've reset the config to default and re-entered just to make sure).

I can make the config work by setting the DHCP server to have a NIC on each VLAN and allocate addresses accordingly BUT with the pressure to virtualise I'd only want a single NIC doing the work and have a secondary DHCP server sharing the addresses in event of failure.
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

.. and the phones have a port off the back to plug your PC into so hence the ports requiring 2 VLAN's to be assigned.
EckerA
Respected Contributor

Re: ip-helper with Avaya phone system on 2650 switch

How do the phones know which vlan they should use?
do they speak lldp-med? then you need to enable it on the switch with:
vlan 10
voice
exit
wr mem
hth
alex
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Phones get the VLAN settings from the DHCP server. They should connect on VLAN 10 and as part of the config you have to set specific options for the phones within the DHCP scope which works fine. Just to re-iterate, with the DHCP server set with 2 addresses on 2 NIC's for the two ranges that works fine with pretty much this configuration.
EckerA
Respected Contributor

Re: ip-helper with Avaya phone system on 2650 switch

Sorry,
i am not really good with voip, here is what i mean:
your phones need to know which vlan (10 or 20) to use before making any dhcp requests. As far as i know there are three ways to do so:
1.) configure on the phone <- lot of work in large enviroments
2.)cdp <- doesn't work on hp switches as this is a cisco protocoll
3.)lldp-med <- open protocoll and supported (invented?) by hp

as your are playing in the lab just try lldp-med

hth
alex
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

It's not required. The phone queries the DHCP server and is given a pointer if it doesn't know it's VLAN (which it remembers from it's last boot). The DHCP server can be seen on data VLAN with no grief so if I force a phone onto the data VLAN it get's the message back from DHCP telling it that it should be on VLAN 10 for voice and the phone drops the IP connection and reboots looking for the correct VLAN. That's when my problems start as it doesn't seem to be able to then find the DHCP server when on VLAN 10. I think it'll be specific to Avaya, there are a lot of official posts that have some of the information but certainly not everything. Sounds like routing to me but then ip routing is enabled so I'd expect it to be able to handle this. If I attach a laptop it goes for VLAN 20 as it should and grabs a DHCP lease so while this config is close it's not fully there. Should have some feedback from my supplier tomorrow but was wanting to see if anyone had any experience of this.
KSimpson
Frequent Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Sorry, Am I missing something?

vlan 10
name "VOICE"
untagged 1,37
ip address 10.40.10.1 255.255.255.0
ip helper-address 10.30.10.2
tagged 2-47,49-50
exit

DHCP server on port 48 ?

Port 48 Isn't tagged aware in vlan 10. Should it be?
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

According to the HP documentation no it should not be. The IP helper-address, when set correctly, is meant to be able to answer from an independent VLAN as long as IP routing is enabled, DHCP-relay is enabled etc ... Tagging port 48 causes DHCP-ACK errors on the phone which is documented as the VLAN being enabled when it shouldn't be. Tried it just to make sure. I'll hopefully have an answer tomorrow.
Pieter 't Hart
Honored Contributor

Re: ip-helper with Avaya phone system on 2650 switch

>>> with the pressure to virtualise I'd only want a single NIC doing the work <<<

There is no technical problem to bring multiple VLANS to the virtual DHCPserver each to a different virtualNIC.
Pieter 't Hart
Honored Contributor

Re: ip-helper with Avaya phone system on 2650 switch

apart from that,
>>>
Phone is on port 37
vlan 10
name "VOICE"
untagged 1,37
<<<

Normal configuration is to have the phone port untagged in data-vlan and tagged in voice vlan.

The first dhcp request is on the data vlan (untagged). then it must be recognized as phone either by lldp or by "dhcp option 82".
The voice vlan id is sent to the phone and
The phone sends a new "tagged" dhcp request on the voice vlan.

You'll need a dhcp relay for the second request configured on the voice vlan if you want the request forwarded to a dhcp server that's not on the voice vlan.

so you'll need (only phone port)
vlan 10
tagged 37
vlan 20
untagged 37

Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1276094532639+28353475&threadId=1101812

Seems to be the nearest to an answer. Still waiting on the supplier unfortunately but this is nearest I've found to a reply. Couldn't find searching on HP site but found through Avaya site ?!?!
KSimpson
Frequent Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Sorry, I have very little knowledge on VoIP so forgive me if I'm not making sense.

If a phone is voice, why does it need to be on a data vlan? I can understand if a computer will be plugged intoport 37 but it's not. Or will it? Will port 37 always be connected to a phone?

Why can't port 37 (phone) be untagged 10 and port 48 (dhcp) be tagged 10?

Does the phone need to be on the data (vlan 20) network at all? This will eliminate wrong network traffic.

KSimpson
Frequent Advisor

Re: ip-helper with Avaya phone system on 2650 switch

If both of rhese devices are connected to the same switch, why can't it be done this way.

vlan 1
name "DEFAULT_VLAN"
no ip address
no untagged 1-50
exit
vlan 10
name "VOICE"
untagged 1,37
tagged 48
ip address 10.40.10.1 255.255.255.0
ip helper-address 10.30.10.2
tagged 48-50
exit


vlan 20
name "DATA"
untagged 2-36,38-48
ip address 10.30.10.1 255.255.255.0
tagged 49-50
exit

Shadow13
Respected Contributor

Re: ip-helper with Avaya phone system on 2650 switch

In General if both a phone and a device will be connected to the same port then:

Untag the port on the DATA VLAN
Tag the port in the voice VLAN
the voice vlan should be configured with the "VOICE" command as below
#vlan 10
#voice
#write mem

this should work and also make sure that either to configure the voice vlan on the phones manually or check if the phone supports LLDP-MED, in this case the voice controller should do the vlan configuration for the phone.


please you can refer to the below document for more details:

http://h40060.www4.hp.com/procurve/uk/en/pdfs/application-notes/AN-C6_ProCurve-Avaya-phone-final-0904008.pdf


Follow as mentioned and it should work perfectly, also the document has the 802.1x configuration in case you want to add security to the ports.

The document is the office HP PorCurve interoperability with AVAYA phones.

Regards.
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

The phone is the primary device, this connects to the switch directly BUT the phone does have a port for data hence the tagged port for voice and the untagged port for data.

My problem isn't with the config of the switch particularly, I can make the config work by adding plugging in the voice DHCP server directly, but I'm trying to get the voice VLAN to see the DHCP server on the data VLAN by using ip-helper. If I create a secondary data VLAN and setup a port untagged to that VLAN then I can use the ip-helper command to point at the one and only DHCP server and it works. My issue seems to be with tagged vlans connecting to the DHCP server. I've got stacks of examples from both the HP and Avaya site but all of them have a configuration that is very different. As soon as I find the answer it'll be posted here.
Shadow13
Respected Contributor

Re: ip-helper with Avaya phone system on 2650 switch

it should work normally, just make sure you define the voice vlan on the phone itself that way the phone will request IP from the correct subnet using that same server.

is the server connected to the same switch ?

Can you post ur latest configuration so i can check it.
Mark Alderson_1
Occasional Advisor

Re: ip-helper with Avaya phone system on 2650 switch

Current config with the test DATA VLAN

; J8165A Configuration Editor; Created on release #H.10.83

hostname "ProCurve Switch 2650-PWR"
qos dscp-map 010101 priority 2
qos dscp-map 101001 priority 4
qos dscp-map 101010 priority 4
qos dscp-map 101011 priority 4
qos dscp-map 101110 priority 5
interface 11
name "Secondary DATA VLAN for test"
exit
interface 37
name "VOIP phone for test"
exit
interface 48
name "DHCP Server"
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
no ip address
no untagged 1-50
exit
vlan 10
name "VOICE"
ip address 10.40.10.1 255.255.255.0
ip helper-address 10.30.10.2
tagged 1-47,49-50
exit
vlan 20
name "DATA"
untagged 1-10,12-48
ip address 10.30.10.1 255.255.255.0
tagged 49-50
exit
vlan 30
name "DATA2"
untagged 11
ip address 10.41.10.1 255.255.255.0
ip helper-address 10.30.10.2
exit
qos type-of-service diff-services
password manager

As requested
rickywillson
Occasional Visitor

Re: ip-helper with Avaya phone system on 2650 switch

Mostly in businesses they go for Avaya phone system to cut their heavy conventional telephone bills. In this Avaya phone system quote San Diego they donâ t have need of geographical routing, also saving long distance charges and easily connect with long distance calls.


Avaya phone system quote San Diego
http://voipphonesystemquote.com/