Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ip proxy-arp ??

SOLVED
Go to solution
Tom Hardy
Frequent Advisor

ip proxy-arp ??

Guys,

I am looking for the command to setup proxy-arp for my vlans but cant seem to find it. i dont have ip routing enabled.

Do you have to have ip routing enabled to use that feature?

If so, does enabling it mess up anything else ??

Thanks
12 REPLIES
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Found it. So i had to go into config and then the vlan. I went ahead and enabled it on all the vlans. I also enabled ip routing.

====================================
Startup configuration:

; J8697A Configuration Editor; Created on release #K.11.11

hostname "vmdCore"
snmp-server location "nocRack"
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
mirror-port C11
interface A9
power Critical
exit
ip default-gateway 192.168.30.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "dataVlan"
untagged A10-A24,B2-B24,C1-C24
qos priority 5
ip address 192.168.30.2 255.255.255.0
ip address 192.168.250.2 255.255.255.0
no untagged A1-A9,B1
ip proxy-arp
exit
vlan 2
name "voiceVlan"
untagged B1
qos priority 7
ip address 192.168.0.254 255.255.255.0
tagged B2-B23,C1-C24
ip proxy-arp
exit
vlan 4
name "trixbox"
untagged A1-A9
ip address 192.168.10.1 255.255.255.0
ip proxy-arp
exit
interface A24
monitor
exit
qos device-priority 204.x.x.x priority 7
qos type-of-service diff-services
spanning-tree force-version RSTP-operation
ip route 204.x.x.x 255.255.255.255 192.168.0.1
password manager

==============================

Problem is that if i have a computer in vlan4 using 192.168.10.2 255.255.255.0 with a gw of 182.168.10.1, it can ping vlan1 gw 192.168.30.2 and vlan2 gw 192.168.0.254 but none of the devices behind these two vlans.

Is there something i am doing wrong?

Thanks for the help in advance :)
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Anyone :)
Jeff Carrell
Honored Contributor

Re: ip proxy-arp ??


sounds as if the def g/w for those devices on vlan1 & vlan2 do not have their def g/w setup...or if they do, are they the ip addr of this switch vlan1 or vlan2 respective addresses?

if the pc can ping the other vlan address, routing is working and this pc does have the correct def g/w...

what about a device on vlan1 or vlan2, can it ping across the vlans?

let us know...jeff
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Thanks again for the reply.

Yes vlan1 can ping vlan2's gateway (192.168.0.254) but cannot ping anything behind the vlan which are voip polycom phones in this case. Here are gateway's im using for the devices in the 3 vlans:

def gw vlan1: 192.168.30.2
def gw vlan2: 192.168.0.254
def gw vlan3: 192.168.10.1




Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Hi Jeff,

Turns out that the gateway on the vlan1 device was wrong. I corrected it and now i can ping the machines from one vlan to the other.

Still cant out on vlan4 (192.168.10.0/24) though.

vlan4 ip gateway is: 192.168.10.1
vlan1 gateway is:192.168.30.2
Default gateway is: 192.168.30.1
My cisco's router lan ip is 192.168.30.1

And here are the static routes that i have:

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 192.168.30.1 1 static 1 1
127.0.0.0/8 reject static 0 0
127.0.0.1/32 connected 1 0
192.168.0.0/24 voiceVlan 2 connected 1 0
192.168.10.0/24 trixbox 4 connected 1 0
192.168.30.0/24 dataVlan 1 connected 1 0
204.14.39.36/32 192.168.0.1 2 static 1 1

===================================
ip route 0.0.0.0 0.0.0.0 192.168.30.1
ip route 192.168.10.0 255.255.255.0 192.168.30.2
ip route 192.168.30.0 255.255.255.0 192.168.10.1
ip route 204.14.39.36 255.255.255.255 192.168.0.1

Thanks for your help Jeff.


Jeff Carrell
Honored Contributor

Re: ip proxy-arp ??

well, some of your static route definitions are not making sense:

ip route 0.0.0.0 0.0.0.0 192.168.30.1
this says, if i (5400) don't know how to get to an addr, goto 192.168.30.1 - perhaps that device will know how....this is generally called the route of last resort (kinda of like def g/w to a layer2 switch)...you want this route statement...

ip route 192.168.10.0 255.255.255.0 192.168.30.2
this says, if i (5400) need to get to 192.168.10.x, go thru 192.168.30.2......this router already knows how to get to 192.168.10.x as it is local to it (vlan4)....therefore this route is not needed...

ip route 192.168.30.0 255.255.255.0 192.168.10.1
this says, if i (5400) need to get to 192.168.30.x, go thru 192.168.10.1......this router already knows how to get to 192.168.30.x as it is local to it (vlan1)....therefore this route is not needed...

ip route 204.14.39.36 255.255.255.255 192.168.0.1
this says, if i (5400) need to get to 204.14.39.36, go to 192.168.0.1....this works, as the router knows about 192.168.0.1 as it is local to it on vlan2...


so the 1st & 4th route statements are ok...delete the 2nd & 3rd route statements...


btw, the 'ip default-gateway 192.168.30.1' in your config is not being used since routing is enabled...its a left-over from the layer2 config...


btw2, there is newer code available for the 5400, came out last week or so - k.13.03...the code you are running k.11.11 was the original release code (almost 2 years old), and altho it should be working for your needs ok....

if this were my switch, i would upgrade to at least k.12.57...but you might as well goto the newest (i've been running k.13.03 in my lab with 3 vlans, voip, routing, 802.1x, dhcp helper, etc., w/o any issues)...


now, why can't a vlan4 device ping a vlan1 or vlan2 device?? i can't see a reason in the config...it still sounds as if there is a def g/w config issue on the vlan4 devices...

so, following what tech support would say, upgrade to newer code, and then see what your results are...i know its not the best answer, but it can't/shouldn't hurt either...

hth, let us know :-)

cheers...jeff
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Thanks for your reply again Jeff.

I am able to ping across all vlans now. The problem is that vlan4 cant get to the internet. You think changing the routes as you suggested might fix the issue or do i need to add something you think?

Jeff Carrell
Honored Contributor
Solution

Re: ip proxy-arp ??

you definitely need to delete the 2 route statements i mentioned...

in your cisco router, you may need need a route statement that is:

192.168.10.0 255.255.255.0 192.168.30.2

which means: if i (cisco rtr) need to get to 192.168.10.x, goto my neighbor at 192.168.30.2, and maybe he knows how (and of course the 5400 knows)...


if vlan4 can now see the rest of the 5400 vlans, but vlan4 can't get out to the internet (which is via the cisco rtr [and maybe others after it]) then this is the last most likely suspect problem...

you're close :-)
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Got it. Thanks again for all your help Jeff. Everything is working properly now :)
Jeff Carrell
Honored Contributor

Re: ip proxy-arp ??

great news!

just curious, what was the final solution?

cheers...jeff
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

Per your advice, adding the static route to the cisco router :)
Tom Hardy
Frequent Advisor

Re: ip proxy-arp ??

problem solved