Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

newly installed 9308M crashes on configure terminal

pal_3
Occasional Visitor

newly installed 9308M crashes on configure terminal

After setting up our 9308M switch I've been unable to configure it without its crashing.

Can someone advise? If I need to update the firmware, could someone send a pointer? Seems unlikely that would be the problem. Nothings connected, just trying to configure it for use.

Here's the output of the crash/reload -

HP9308>show flash
Active management module:
Code Flash Type: AMD 29LV033C, Size: 64 * 65536 = 4194304, Unit: 4
Boot Flash Type: AMD 29LV040B, Size: 8 * 65536 = 524288
Compressed Pri Code size = 3712427, Version 07.6.00dT53 (h2r07600d.bin)
Compressed Sec Code size = 3712427, Version 07.6.00dT53 (h2r07600d.bin)
Maximum Code Image Size Supported: 6815232 (0x0067fe00)
Boot Image size = 252416, Version 07.06.00 (m2b07600.bin)

HP9308>enable
No password has been assigned yet...

HP9308#configure terminal

trap_save done
Active management module crashed!!!

BOOT INFO: RESET ANY
master arbitrate : become primary arbitrator.
BOOT INFO: Become active CPU module
M2 BI Boot Code Version 07.06.00
Enter 'b' to go to boot monitor ...
BOOT INFO: load from primary copy
BOOT INFO: bootparam at 3fffffe0, mp_flash_size = 0038a5ab
BOOT INFO: code decompression completed
BOOT INFO: branch to 20000104
Reset all modules ...
Unsupported dma version 1848 at slot 7 dma 0
Unsupported dma version 1848 at slot 7 dma 1
Init Management module 1 ...
Init JetCore ASIC 1..2..
Init module 3 ...
Init JetCore ASIC 1..2..3..4..
Init module 4 ...
Init JetCore ASIC 1..2..3..4..
Init module 7 ...
Init JetCore ASIC
Parsing Config Data ...
Load config data from flash memory...

SW: Version 07.6.00dT53 Hewlett-Packard Company
Compiled on Sep 07 2002 at 20:40:38 labeled as H2R07600d
(3712427 bytes) from Primary h2r07600d.bin
J4138A HP ProCurve Routing Switch 9308M
HW: ProCurve HP9308 Routing Switch, SYSIF version 21
==========================================================================
SL 1: J4885A EP 8 port mini-GBIC Management Module, SYSIF 2 (Mini GBIC),
M4, ACE
Serial #: US90020513
4096 KB BRAM, JetCore ASIC IGC version 49, BIA version 89
32768 KB PRAM and 2M-Bit*1 CAM for IGC 0, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 1, version 0449
==========================================================================
SL 3: J4895A EP 16-port 100/1000-T Module, SYSIF 2
Serial #: US90020319
4096 KB BRAM, JetCore ASIC IGC version 49, BIA version 89
32768 KB PRAM and 2M-Bit*1 CAM for IGC 8, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 9, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 10, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 11, version 0449
==========================================================================
SL 4: J4895A EP 16-port 100/1000-T Module, SYSIF 2
Serial #: US90020312
4096 KB BRAM, JetCore ASIC IGC version 49, BIA version 89
32768 KB PRAM and 2M-Bit*1 CAM for IGC 12, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 13, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 14, version 0449
32768 KB PRAM and 2M-Bit*1 CAM for IGC 15, version 0449
==========================================================================
SL 7: J4881A EP 48 port 10/100-TX RJ45 Module, SYSIF 2
Serial #: US90020174
0 KB BRAM, JetCore ASIC IPC version 00, BIA version 89
==========================================================================
Active management module:
466 MHz Power PC processor 750 (version 8/8302) 65 MHz bus
512 KB boot flash memory
16384 KB code flash memory
256 KB SRAM
512 MB DRAM
The system : started=warm start
Crash time : 00:00:00 GMT+00 Mon Jan 01 1900

FSecure SSH is included in this product
5 REPLIES
Gonzo Granello
Valued Contributor

Re: newly installed 9308M crashes on configure terminal

Hi,

Looks like you need to upgrade firmware. My first course of attack would be to remove all blades except managment. It looks to me that you got a newer version 10/100 module which is not compatible with the version of code (hence the unsupported DMA message), unfurtunatley hp choose not to roll the partnumber (a-b) as it looks like :-). Anyway the website should have the latest code 7.7.?? - however i have not tested this codebase therefore i would advise to be careful.

GG
most time the day i have to mask my contempt for the a-holes in charge......
pal_3
Occasional Visitor

Re: newly installed 9308M crashes on configure terminal

Thank you so much for the prompt response!

This does seem unlikely since all parts were ordered at the same time well over a year ago, and were all delivered in the same box. Could HP really ship all parts for a switch that didn't have a supported firmware version?

At any rate, I will be onsite tomorrow and will attempt your suggested mode of attack; removing enet blades and updating the firmware.

I surely don't want to try the very latest and greatest version if it's not completely qualified. However, I will check for one version back and install that.

If any of this information helps to suggest a different problem, pls reply.

thank you again!
-pam
Gonzo Granello
Valued Contributor

Re: newly installed 9308M crashes on configure terminal

Unfurtunatley, this can happen even if you ordered it 9 years ago :-). Those days no company has a huge stock of anything and most parts get sourced just in time for delivery. The serial number of the blade in slot 7 suggests it is the newer version, which by itself is actually a good thing since they are newer ASICS that have all the latest fixes build in... On the other hand, I'm not 100% sure about the timeline, it can also be the 10/100 blades where simply not supported in that release because they did not exist when they wrote this particular code. Anyway, the software on the web is the latest you should use. If it's still not working after you upgrade, let me know.

GG
most time the day i have to mask my contempt for the a-holes in charge......
pal_3
Occasional Visitor

Re: newly installed 9308M crashes on configure terminal

Hello again,

Finally finding time to attempt the firmware update!

I see 3 option of firmware to download, could someone guide me as to which I need? I have a 9308 with (1) mgmt module. My 3 options for firmware are -
1) Current software and boot code w/ redundant managment: 07.7.01
2) Current software w/out redundant management: 06.6.38
3) Current boot code w/out redundant management: 07.1.08

Thanks again!
-pam
Gonzo Granello
Valued Contributor

Re: newly installed 9308M crashes on configure terminal

you "want" 7.7.01 code. You NEED to upgrade the bootcode first and if you want to skip any steps in between the I would advise to boot the 9308 via the TFTP server you have (need) to upgrade the bootcode / firmware. That should be described in the Manual and is really the easiest way. If the description is not usable write back and I send you the right one.

GG
most time the day i have to mask my contempt for the a-holes in charge......